Previous 1 8 9 10 11 12 Next 238 Replies Latest reply: Sep 29, 2015 9:49 AM by CONSTRUCTIVEcriticism Go to original post Branched to a new discussion.
  • Alistair Swatridge Level 1 (0 points)

    Regretably I must join the growing list of ATV3 users (or now non user) who has lost the ability to use wifi on the ATV3. Have tried everything but no joy. Local shop appears non interested in problem as bought in Argos some months ago. So now an expensive paperweight!!! Come on Apple solve this please.

  • stw1958 Level 1 (0 points)



    i solved the problem by using a static ip address. procedure in this thread

  • kathorun Level 1 (5 points)

    I too am having this problerm!


    Honestly I do not know why I keep giving Apple a second (third, fourth, fifth and six) chance!


    This problem has been identified for so long it's long time Apple issued a fix for this. Meanwhile, I will continue my love/hate relationship with this brand.

  • Justin Paul Reese Level 5 (4,235 points)

    I've come to the conclusion that with the numerous internet connectivity issues being reported here, as well as our Apple TV display unit at Micro Center, that this software update needs a bug fix.


    I've taken the time to download the previous Apple TV software version, flashing and restoring the Apple TV (using a USB micro-B to A cable) through iTunes.


    The Apple TV now works as expected with the older version of the software.

  • Level 1 (0 points)



    This is bad. There so many complaints filed in just past few weeks and no reaction from apple.


    Please fix this. this is really bad. all i see on wifi screen is other button which wouldnt even load any wifi signals.


    it is so frustrating.

  • happymacman99 Level 1 (0 points)

    Had the same problem as everyone else, worked fine for a few days then wouldn't  connect to internet. Local apple store diagnosed faulty wireless chip and sent unit away for repair??? got it back today and now it wont even connect to my TV although it did instore. I've tried different TV's, HDMI ports and Leads all to no avail. so its back to the store tommorrow, It'll sonn cost  as much for fuel,  parking and my time as it did to buy.

  • RichStan Level 1 (0 points)

    I have been reading this discussion and others with the same subject matter a lot over the last few weeks as I have the same problem.


    Ever since the 5.1 software update my ATV 3 has been inoperative.  I am now on my 2nd device after a hardware issue was found with my original, which was working 100% before I pressed the dreaded "update now" icon.  It's even more difficult because here in New Zealand we don't have any Apple stores, so am relying on talking to people from Australia and Singapore.


    Apple have been very co-operative and understanding, but that still doesn't alter the fact that they haven't publicly admitted that there is a problem (which there evidently is).


    I'm not going to hold my breath, but as I have told them, all I want is someone/anyone to come out and say "our name is Apple and we have a problem".  I want (and I'm sure all you other ATV owners want) to know that a bug fix is being worked on and that my ATV might just work (for more than 10 minutes at a time) sometime this decade!


    I will keep you all updated on what happens next........


    <Edited By Host>

  • esadr Level 1 (0 points)

    I'm having the same problem, in addition to wifi issue that doesn't appear, ATV3 can't connect thru ethernet either. This ATV3 is 5 months old.

  • RizB Level 1 (0 points)

    I have been following this thread for months. I tried upgrading the firmware, downgrading, reset, restore etc and everything failed. Yesterday I heard about the new update 5.1.1 and tried updating using Ethernet. It updated fine and I then removed the Ethernet cable. And voila, it started detecting wifi again. Mine is a 6 months old ATV3.  Prior to the update I was on version 5.0.2

  • RichStan Level 1 (0 points)

    So, after 2 months of updates, downgrades, e-mails to Apple, phone calls to (and from) Apple I received my 3rd (yes, 3rd) Apple TV device today and hey works, and it's even been per loaded with 5.1!


    I cannot fault Apple's customer service.  Even though other people have had pretty awful customer service experiences, mine has been top class.  Living in NZ is quite difficult because there are no Apple stores, but Apple couriered my new Apple TV to me from Australia!


    So, I would say to everyone having problems.....please persevere, things will come right eventually.


    <Edited By Host>

  • djaysteven Level 1 (0 points)

    your post made me hopefull but sadly for me it didn't work..


    last update messed up even my LAN and had to downgrade, this update (5.1.1)

    went smooth and works with LAN but still didnt fix my wifi signal..


    i'll just have to keep hoping..


    by the way, did u do anything alse than updating i should know of?

    i'm tired resetting all my ATV and Router settings over and over again without result

    so better ask here

  • Jimmy Jam Level 1 (5 points)

    Yup!  Sadly been having the same issue here for months now.  Discouraging.

  • RizB Level 1 (0 points)

    I am kinda surprised that 5.1.1 did not fix the issue for others. So here are some more details on the problem I had and how it got resolved. Hope it helps

    1. I have an ATV3 that I bought in US and brought to India around 6 months ago.

    2. Sometime in mid-October 2012 ,it stopped detecting wifi. In Networks menu it would just show the Others button and nothing else. In wifi menu, it would just show one bar. When I plugged in the Ethernet cable it worked as expected.Also tried a lot of resets and restores.. But that did not fix it.. I couldn't get it exchanged since the authorized service dealer as well as phone support in India told me apple tv is not covered in India, and I had no choice but to hold on to it.

    3. I tried updating to latest firmware a few days later, as there was one available. I don't remember the version but that messed up the device further as even Ethernet connection stopped working.

    4. Next, I followed instructions on the net to downgrade the firmware to 5.0.2 through iTunes. That resolved the Cable issues and I was able to use it using Ethernet. Of course still no wifi.

    5. Finally couple of days ago, I reset all the settings and upgraded to firmware 5.1.1 - released nov 29 - through Ethernet cable

    6. I then updated my settings, logged into iTunes using cable and downloaded a couple of trailers to ensure it was working on cable. And then disconnected the cable and went to search for wifi. And finally, 2-3 wifi networks in the vicinity showed up. Connected to mine and it's working perfectly now. I have switched off the device couple of times since then and had no issues connecting to wifi once its back on. So in my opinion, it does look like a software issue and not hardware..

  • Jimmy Jam Level 1 (5 points)

    Tried downgrading to 5.0.2 and still no luck.


    Went to the Apple store.  They experinced the same issue with no WiFi.  They replaced the unit with a white box.  I'll let you all know if it works..

  • Greythound Level 1 (0 points)

    Really glad the software update (via ethernet) has worked for some ... for others I recommend that you take your device (if possible) to an Apple Store ... mine was replaced on the spot (although I did have to have a little stamp of my feet to accomplish that). I had tried everything with my ATV(3) to get it working (reset, restart, restore, downgrade, upgrade and night classes in wifi engineering) all to no avail. In frustration I set up a genius appointment ... new unit, working solidly on wifi (& ethernet) with everything I can throw at it. When I asked if there had been many people with issues like mine the young 'Genius' rolled his eyes & intimated I wasn't alone.


    So my advice (again) return your device to Apple and seek a replacement unit.



Previous 1 8 9 10 11 12 Next