Previous 1 12 13 14 15 16 Next 238 Replies Latest reply: Sep 29, 2015 9:49 AM by CONSTRUCTIVEcriticism Go to original post Branched to a new discussion.
  • betsy310 Level 1 Level 1

    Hi JarJart, What issues were you having with your HH3?

    wireless issues? Im using a HH3 which works fine with ATV3 but i do get drop outs if using homeshare, watching movies, from my pc in the next room.


    Can you explain a little more about the benefits bewteen HH3 and HH4?

    I n our house we use ipad 2, Iphone4, 4s, 5, ATV3 and hopefully a 5s/6 and newer ipad..

    what benefit would i see, quicker wireless? more range on the wireless?





  • jarjart Level 1 Level 1

    Definateley more stable and higher speeds - also streaming from Mac/ 3 iDevices/ xBox ++. Was slightly apprehensive but got it for a reduced price (£35) as we have only had HH3 for 6 months. More control over setings with separate tabs for 2.4gHz / 5gHz channel - set up separate paswwords etc - hope this helps 

  • bag of hammers Level 1 Level 1

    I got my ATV3 in April 2012, I mainly used it for Netflix at first and didn't notice many problems.  It always had problems connecting to the remote app on my iphone, many restarts would let it connect.

    Lately I've been trying to use home sharing to play music in the living room (where ATV3 is) from the mac mini in the bedroom (linksys wireless router) and all the problems have got worse.


    Apple store exchanged the ATV3 yesterday, new unit still has same problems.  I have gotten used to restarting the ATV3 as soon as I turn it on or it won't do anything.


    Losing the wireless connection after 10-20 mins seems to be a consistent theme with Apple TV and airport base stations although I have never had this problem with macbooks, mac mini's, iphones, mac pro's. etc


    I feel like there is some long standing issue with Apple and wireless...

  • bag of hammers Level 1 Level 1

    Just an update FYI...


    I know this isn't a solution to the wireless problems but I connected the ATV3 to the router via ehternet and now I can actually use the ATV3 the way it was designed. 

    The remote app still losing connection with ATV3 and the itunes libraries but they come back eventually.


    I don't know if it's just that my wireless router is too old (it was discontinued several years ago) and the ATV3 needs something newer, or if there is just too much interference where I live.


    I might get a newer router soon and see if that fixes all the wireless problems but I'm kinda done with fighting this Apple TV. 

  • AbbotThomas Level 1 Level 1

    My ATV3 is now up and running wirelessly, but it's been a long, painful experience! Few suggestions based on what I've found over the last year:


    1) Try checking for wireless interference caused by, for example, cordless phones. I think this is what caused the problems with my ATV3 and when I changed phones, it started working fine. It took me ages to test for this because my ATV2 always connected fine. I now know that Apple changed the wireless hardware in the ATV3 so I wonder if this made it more sensitive to interference.


    2) Try different wireless channels to avoid congested areas of the spectrum.


    3) Try disabling wirelss multicast forwarding if it's an option on your router - I found that when this was enabled, Homeshare and Airplay wouldn't work.


    4) Apple have acknolwedged there's an issue with certain batches of the ATV3 - I've posted the link to the serial numbers affected before - so it's worth checking if yours is one of the dodgy ones.

  • ChaunceyB Level 1 Level 1

    Congrats on that AbbotThomas!

    My August 2012 ATV3 was just replaced by a very nice Apple Care phone attendant named Jessica.

    It was shipped through Ups and arrived by FedEx, very fast!

    It is not a serial number that falls within that memo in that article.

    It is 5.2 software, but I don't believe it is a 2013 model, I believe it is still a 2012 model.


    ... and it still has Wi-Fi problems.

    Wi-Fi is recognized then blinks out, then blinks in, etc. 5-15 second intervals.

    Exactly the same as the last ATV3 when I updated 3 different times to 5.1, no consistent wi-fi.

    So the from Sept 12-June 13 I had downgraded it to 5.0 and it worked without a single noticeable problem.


    So it must be a router problem, but wait....

    no other devices have any problem

    AND the Atv3 had NO problem with the old software (5.0)


    So is this ATV3 2012 problem from 5.1 and 5.2 software and/or a bunch of determined and yet to be determined physical machines?


    Can I ask how many of you are still hitting the "Update Later" button ?

  • ChaunceyB Level 1 Level 1

    Update: After a few hours restoring and resetting this brand new ATV and resetting the router and attempting to set the IP and DNS addresses manually, it still was an intermittent wi-fi signal. 5-10 seconds on, 2-4 seconds off, and repeat.

    I left it for a few hours, then came back to it and the signal was not blinking anymore.


    It appears to be working for now, and for no real apparent reason other than some router setting.


    My best guess about this whole Wi-Fi problem: There must be some miniscule router setting that is affected by all ATV updates after 5.0 and most people's routers aren't affected but some are.

  • ChaunceyB Level 1 Level 1

    Update Update: It lasted only 5 hours of steady, uninterrupted wi-fi signal, then a restart of the device had it doing the same exact intermittent non-connectivity.


    But that is proof that it cannot be the router which had 1 year of complete function under 5.0 software and now 5 hours under 5.2.

  • ChaunceyB Level 1 Level 1

    Update #3: The only way this "NEW" atv3 functions is by hooking up a physical ethernet cable.

        I updated the software to 5.3, ethernet continues to work, took out the cable and wireless is exactly the same blinking situation.



        August 2012: ATV3 bought new August 2012

                           Wireless wi-fi worked perfectly in 5.0.2

        Sept 2012: Updated to 5.1 and wireless is blinking in and out 5-20 times a minute

                         Downgraded back to 5.0.2, wi-fi is fine

                          Went to Best Buy, clerk said wi-fi was fine there, and they were out of an ATV3 for exchange

                         Made 1 more attempt at 5.1 and reset,restore,router reset,etc. = same blinking wi-fi

                          Downgraded back to 5.0.2, wi-fi is fine

                         hitting "Update Later" button

                         hitting "Update Later" button

                           hitting "Update Later" button etc............

         June 2013:  Saw "rumours" of a replacement program for ATV3 from April 2013

                           Attempted to update to 5.2.1, same blinking wi-fi problem

                          Returned to Best Buy, clerk said wi-fi is fine, heard nothing of replacement program

                          Called Apple care, hear nothing of replacement program, asked them to look it up, they semi confirmed that mine might be eligible and sent UPS shipment details

                          "new' atv3 arrived shortly with 5.2.1 installed, same blinking wi-fi

                           Reset router, attempted to switch router settings,

                           Wi-Fi works with 5.2.1 for 5 hours, then goes back to blinking connection

                           Connected ethernet, updated to 5.3

                          Unplugged ethernet, same blinking Wi-Fi connection

  • ChaunceyB Level 1 Level 1

    Hopefully the last UPDATE to this problem.

    We replaced the older Belkin Router, which was still functioning pretty much perfectly with everything except the ATV3, with an Aiport Express..... and it is working!


    So, this week's ATV3 replacement + a new Router makes the ATV3 actually function with wi-fi !


    There should probably be a label on all Apple TV's that says,


              "New router may be required for Wi-Fi to function"

  • HolmanAPPDev Level 1 Level 1

    Ok! I had the Same Problem after updating it it would not pick up a wifi signal. Here's What I did. While the apple tv was running I unplugged it. Waited 30 or so seconds (i am impatient cant wait the full 60) and plugged it back in. Connected without even having to tell it too. Hope this helps people! PS Apple come on!!! This problem has persisted for over a year get some people on it that know about signals and packets.

  • DCDUB Level 1 Level 1

    Looks a bit hopeless out there. I was about to write a complaint letter to apple but my technical support has expired. My apple tv worked for a few months and then wouldn't connect onto the wifi anymore. I read so many messages that it was a problem with netflix that I accepted this to be the issue. Ipads, iphones, laptops are all connecting to the wifi. I've not had issues with apple products until now...very disappointed. Tried an ethernet cable on the apple tv last night and it worked but this isn't a solution as it runs across the sitting room floor. The apple tv is looking at the router, about 2.5meters in distance away and no signal......what to do now....continue watching netflix on my ipad....Will I get any satisfaction from apple????

  • GreenAp Level 1 Level 1

    Try physically moving your AppleTV to another Iocation.  I had the same problem - great wifi, then no wifi.  It then began working.  A few weeks later it happened again - and I realized I moved the ATV back on top of an HDMI switcher (which is where I originally placed it when I first had problems).  I don't know for sure, but I believe as I was troubleshooting it - I was plugging and unplugging it and setting it in a differnt place each time.  I did not move it far - I took it off the top of the switcher and placed it next to it.  No problems since moving it.  I am guessing it was getting interference from the switcher.

  • vijayraheja Level 1 Level 1

    I just bought my new ATV and it wouldn't connect to the internet, though it would connect to my wifi router. After some troubleshooting, I found the solution - restart the Modem, Router and ATV.


    Restarting just the router or ATV is not sufficient, need to restart the Modem too.

  • tkblueyonder Level 1 Level 1



    I too have been suffering with the wifi dropping out on my ATV3, works fine over wired connection but zero wifi, it refused to find any wifi whatsoever...neighbours etc. Just said search for "other" when trying to connect


    anyway cut a long story short yesterday i found a Apple TV replacement programme that Apple had been running so i returned mine to the original Apple store where i bought it and they just replaced it without question even though its well over its 12 month warranty.


    if the read the article in the link Apple say they will replace your ATV unit if you have had it less than 2 years and it carries one of the serial numbers they have printed fortunately for me mine did.



    Good Luck!