6 Replies Latest reply: Jul 12, 2012 10:13 AM by WamboJambo
WamboJambo Level 1 (0 points)

When I plug my MagSafe power adaptor into my 13" Macbook, the main power source switches to the adaptor, but the battery does not charge and displays the Not Charging notification.  Is this an issue with my MagSafe port, and if so how can I fix it?  I'm not afraid to take MacBook apart and fix it myself, it's already way out of warranty and I'm pretty handy with computers.  Thanks in advance!

Mac OS X (10.6.8)
  • shldr2thewheel Level 7 (25,855 points)

    perhaps the charger is no longer good.  Borrow one from a friend to test it out or bring it to an Apple store or AASP and have them use a known good charger.

  • WamboJambo Level 1 (0 points)

    Ah yes, I too thought this was the case.  I have two MacBooks though.  The other one charges fine on my charger and I experience the same issue on that charger, that was one of the first things I tried.  Sorry, probably should have mentioned that in the original post..

  • mwm417 Level 1 (75 points)

    I work for an AASP and this is not an uncommon issue. It is likely either the MagSafe port or the battery has simply gone bad and will not charge.


    First, go to System Profiler and check the health of your battery. Instructions

    If it says the battery is bad then that is likely the issue.


    I would suggest resetting the SMC as explained here. This can even help get a little extra life out of a battery that is going bad.


    If that doesn't fix your issue, you may want to consider running a hardware diagnostic on your machine to see if it can point you in the right direction on what has gone bad. These instructions can be found here.


    The DC board is not too difficult to replace if you know what you are doing, but I definiately would't encourage you to do anything to it, especially if you've never taken apart a Mac before.


    Hope this helps

  • WamboJambo Level 1 (0 points)

    Alright, reporting back in on this one...


    So, System Profiler says my battery is in Normal condition with 689 charge cycles, says the battery is installed but that it is not charging.  So there's my problem.  I reset the SMC and nothing really happened.  Same situation, powers computer but does not charge battery.  I'm pretty sure I reset it properly, so I don't think that's the issue.


    I tried running the Apple Hardware Test but it kept booting normally, so then I dug up my old Snow Leopard install disc and tried again, but it still just booted normally?  Not sure what I'm doing wrong here either.


    On the final note, I can certainly replace the board, I just would like to do any troubleshooting things before I start chucking money at it.  I'm not sure if maybe just a wire is loose or something simple, or if the thing really is blown.  I've had this problem several times in the past few days.  I couldn't even get it started at first, so I switche the battery out of the other MacBook and then this one worked but wouldn't charge, so I plugged the charger in first and then stuck the battery in and it worked great?  This whole situation is just confusing and very iffy...


    And finally I just wanted to thank you for all your help, it's great to see a helpful and friendly Apple Support community!

  • PowerBook 100 Level 1 (20 points)

    You appear to have the same issue that I have. I took my macbook to the genius bar yesterday, and they ran their diagnostics software on it. My battery has around 650 cycles (close to yours) and it reported being in Normal condition. I'm borrowing an 85 L-shaped MagSafe at the moment, but it doesn't charge the battery. What does the battery show when you press the button on the bottom of it?

  • WamboJambo Level 1 (0 points)

    Yeah, I don't take my stuff to the Genius Bar.  My Apple items are all out of warranty and I can usually fix the problems myself.  When I check the battery's status on the bottom, it just lights up four of the lights, indicative of its charge right now.  No blinking lights to show that it's charging, just the four lights to show the charge its been at for a while now, since I've just been leaving my computer plugged in.