8 Replies Latest reply: Oct 15, 2014 4:24 PM by bomelkr
capaho Level 4 Level 4 (3,650 points)

Whenever I connect my Bluetooth headphones to my MBP iTunes opens automatically and starts playing music.  It's a nuisance I don't need but I can't find the setting that is responsible for this.  Does anyone know how to disable this "feature?"

  • capaho Level 4 Level 4 (3,650 points)

    The problem was apparently in the CD/DVD settings in System Preferences where iTunes was set to open automatically when a music CD was inserted.  It appears that, in Lion, connecting Bluetooth headphones is the same as inserting a music CD.  Changing that setting to "ignore" solved the problem.

  • lmiller287 Level 1 Level 1 (0 points)

    Same thing happens to me when I use my Bluetooth Jaybird earphones. This setting change seemed to fix my problem. Are they going to fix this bug?

     

    I mean, earphones arent really a cd... haha

  • Wolf Harper Level 1 Level 1 (40 points)

    None of that works for me.  I've tried every suggestion I've seen here and elsewhere on these forums.  Nada. I've even tried upgrading from OS X 10.6 to 10.8.  There are several other events which will also launch iTunes and autoplay, always to my great annoyance.

     

    I did write a perl script (posted in another thread) that kills iTunes when it tries to launch, that's the closest I've found to relief.  If it wasn't for that, I'd have removed iTunes entirely. 

     

    It's even worse on my iDevices.  Those have crossed the "annoyance event horizon" and I just removed all my music.   Isn't that awful?  Thank God they tore podcasts off into a separate app.  Genius idea, make podcasts out of all my albums.

  • sdchallis Level 1 Level 1 (0 points)

    I have found a good workaround to this. Download the app Event Scritps. This allows you run scripts based on events. So when bluetooth device connects quit itunes. I have actually selected the option to quit itunes when itunes launches becasue i never use itunes. works well. Make sure itunes isn't going to open in fullscreen mode to ensure it doesn't bother you at all.

     

    Steve

    MB Air 2012

    Plantronics Voyager pro

    latest version of Event Scripts

  • mcandre Level 1 Level 1 (0 points)

    There is no such setting post-Lion (e.g., Mavericks), especially on Macs without CD/DVD drives. Is there another way to disable this annoying iTunes behavior?

  • elliotfromlos angeles Level 1 Level 1 (0 points)

    I do not have CD/DVD settings in System Preferences. I have a Mac Air and there is no cd/dvd drive, so I guess they don't include it in settings.  I also have this problem where any bluetooth device connecting will launch itunes. 

     

    Why hasn't Apple fixed this? Does anyone have any help for someone with an Air?  I would really appreciate it as it keeps messing up my libraries. 

  • SJC1882 Level 1 Level 1 (0 points)

    For those who do not have CD/DVD System Prefs pane because their machines don't have optical drives and who DO NOT use iTunes at all, like myself, a hack/workaround follows:

     

    1. Right-click iTunes and select "Show Package Contents"

    2. Navigate to Contents/MacOS.

    3. Look for a UNIX file named "iTunes" and rename it to anything you like. I renamed mine "iTuned_Disable"

    4. Close the folder.

     

    DISCLAMIER: This is something of a nuclear option because it will prevent iTunes from opening entirly. Should you want to open iTunes again follow the above steps and rename the UNIX file back to "iTunes" and then launch iTunes.

     

    Hope this helps...thus far this has totally solved my problem.

  • bomelkr Level 1 Level 1 (10 points)

    I have a MacBook Pro Retina, which of course does not have a CD/DVD drive. I also am using my Beats B/T headphones and am plenty annoyed that iTunes start up whenever I connect them... I simply connected an external CD/DVD drive, and wupti, there was the setting to change in System Preferences:-)