14 Replies Latest reply: Jan 10, 2013 10:38 AM by Sk115
Aimee1234567 Level 1 (0 points)

I know that this question has been asked quite a few times already but I can't seem to find a solution to my problem. I recently bought an iphone 4 and updated to ISO 5.1.1 and imessgae will not work it just say's 'waiting for activation' and then after a while cancel's out telling me it failed and to try again. I've tried the following to try and fix problem

 

  • Restoring phone completely with and without backup information
  • Changing Date & Time from automatic and back again
  • Turning off imessage/facetime then turning off phone and on again
  • Signing in with Apple ID and back out again (only option i get)

 

I do not get the option to sign in using a mobile number only my apple ID, what I get is in the first picture (I have put my number in under settings>phone>my number).

 

IMG_0002[2].pngIMG_0001[1].png

If i click on sign in with apple ID and sign in with it i get this page in second image                   

 

If after that I click on recieve at I get the what is shown in the image below.

IMG_0003[1].png

I don't know if any of these pictures will help nor if this is where my problem lies or if I am just doing something wrong and missing something else but I would appreciate any help anyone can give me and thank you in advance.


iPhone 4, iOS 5.1.1
  • diesel vdub Level 7 (21,995 points)

    Are you using the same email address for iCloud?  Does that work?

    Do you possibly have a different email address for your Apple ID?

    Have you tried changing your Apple ID password?

  • Aimee1234567 Level 1 (0 points)

    email addresses should be the same and it works fine and I last changed my password about a week ago but I guess I can give it ago and see if it makes a difference 

  • Aimee1234567 Level 1 (0 points)

    Tried changing password and it's not made a difference

  • Aimee1234567 Level 1 (0 points)

    Been messing about with it and now can send imessage (though it still won't activate and my number is still not an option) and MMS messages but it will not let me send anything as SMS.

  • diesel vdub Level 7 (21,995 points)

    Have you tried all of the following:

     

    If you still can't send or receive iMessages

    1. To send and receive iMessages, your device must have a valid cellular or Wi-Fi data connection.
    2. Ensure that iMessage is turned on in Settings > Messages.
    3. iMessage registration validates your Apple ID for use with iMessage. If you are unable to activate iMessage, try the following:
      • Sign in to iMessage on your device using a valid Apple ID. After you validate the email address for use with iMessage, other iMessage users can connect to you using that email address. If you encounter issues registering or using an Apple ID account:
        • Ensure you have an active Internet connection.
        • Verify that you are using a valid Apple ID at myinfo.apple.com. You can also create an Apple ID or reset your password from this webpage.
        • Ensure that your date, time, and time zone are set correctly. If your country has recently made a daylight saving time (DST) change, it may be necessary to manually set the time zone to one that matches your local time.
        • Check that your email address is verified in Settings > Messages > Receive At.
          • If Settings > Messages > Receive At shows your email status as "verifying," follow the instructions in the verification email that was sent to complete the process.
          • Toggle iMessage off and on in Settings > Messages.
      • iPhone automatically registers your phone number for use with iMessage during activation. If you encounter issues activating or using iMessage with your phone number:
        • Verify that you are connected to a cellular network.
        • Toggle iMessage off and on in Settings > Messages.
        • If you are unable to activate iMessage on a device after remote wiping it, wait at least 24 hours and try again.
  • Aimee1234567 Level 1 (0 points)

    All fixed now thanks. I spoke to O2 over their live chat and it turns out I had an inncorrent message centre number despite the fact I had followed steps to input the correct number before, I for some reason the fact that I hadn't put + infront of the number didn't register to me lol. Anyway thanks for trying to help.

  • diesel vdub Level 7 (21,995 points)

    Glad you got it fixed.

  • AboudHelper Level 1 (0 points)

    I had the same problem and had it resolved by setting tiem from manual to set automatically (when changed took a few minutes to change) but thank you to diesel vdub

  • Singh19 Level 1 (0 points)

    Will a phone number with chatr work for iMessage and FaceTime with the iOS 6?

  • Corazon99 Level 1 (0 points)

    amy where did you take off the + on your phone because i can't find it

  • zilong13 Level 1 (0 points)

    Hi, neither the Apple ID and Phone Number unable to activate the iMessage and Facetime.

    when I key in the password for Apple ID, It shown : unable to login, please check your network connection and try again, I'm sure I have turned the Cell and Wifi Network. What Can I do the further setting check? Thanks

  • RajaSubbraj Level 1 (0 points)

    Check whether 3G is switched on in Settings (General --> Mobile Data --> Enable 3G).

  • MawieM Level 1 (0 points)

    I tried all of this but still I can't use my imessage and facetime what am I gonna do?

  • Sk115 Level 1 (0 points)

    Hi

    I tried activating iMessage and FaceTime but as usual it's not getting activated.

    Earlier it was working on my iPhone 5 but I changed the phone on New Years to 32gb.

    So now it's not activating.

    Any suggestions