1 Reply Latest reply: Aug 9, 2012 3:23 PM by planb77
cbarrett828 Level 1 Level 1 (0 points)

I have an iTouch 2nd Generation, running Version 4.2.1.  I have tried to purchase some TV shows, and they will not load.  The error it gives me is that the video is not supported.

 

The videos I am trying to purchase are Star Wars, The Clone Wars out of Season 1.  I already have a couple shows from season 1 loaded on my iTouch, and was just trying to buy more.  The video on the ones already loaded is HD, as is the video on the ones I am trying to purchase.

 

From what I can see, I am running the current version, and there are no more updates available.

 

Is there a fix to this problem?


iPod touch, iOS 4.2