11 Replies Latest reply: Sep 27, 2012 6:21 AM by CASD Schools
Overton Public Schools Level 1 Level 1

I updated Apple Configurator to 1.1 3 days ago, and since I have made the update, I can not add apps to any iPads. Whether I try to add just one app, or several all I get is a message that says Can't add app.


I have tried unsupervising a device and then re-supervising it. I have restored from back ups. Not restored from back ups. Reset the device. and none of these have worked.


I have done this with about 10 different devices so far, and I can not add any apps to them.


Just 10 min before I updated to Configurator 1.1 in the Mac App store, I had updated and installed new apps on 10 different devices. I know that it worked perfectly before the update, but since I updated I can not add any apps. The rest of the program works just fine.


Is there a way to fix this, or to go back to Apple Configurator 1.0.1?


Thank You in advance

Apple Configurator, Mac OS X (10.7.4)
  • BCPS IT Coordinator Level 1 Level 1

    We found that the first version of Configurator allowed you continue to Supervise devices with the profiles created to allow change "Never." Logically, that would mean the only person you would allow to change anything on the supervised device would be the person running the configurator.


    However, with the newer version, we found we had to modify all our profiles from "Never" to "Sometimes with a password" (paraphrasing the phraseology of the choice here). Next, you have to go into settings on each individual device and remove the profile, using the password you create. Then supervise your devices in configurator and add whatever new apps you want. Finally, you must re-add the profile by checking the box on settings and resyncing all devices with the configurator. It is a LOT more time consuming and really counterintuitive, but it does work.


    We have done over 1,000 devices this summer and the first version of Configurator was far less glitchy and intuitive. The biggest issue I am having is that some code spreadsheets won't even be recognized in the configurator (unaltered - pulled directly from what Apple sent me) and some of the codes are listed as "invalid" when also pulled directly from the spreadsheet. Apple replaced a few of the codes, but included in their email that they were doing this "even though the agreement states all sales are final." In  my business world "All sales are final" is based upon the understanding that the product you are selling me functions out the door... apparently Apple doesn't care because when you contact the VPP people about Configurator the tell you to contact the Enterprise Team and when you then contact the Enterprise team - they tell you to contact the VPP people. Best of luck to you in this endeavor.

  • Overton Public Schools Level 1 Level 1

    I had that problem as well.


    What I was told to do, and it has worked so far, is to have a profile that allows the installation of apps. I create a dummy profile called Install profile that leaves every setting as is. Then when I need to install an app, I just change the profile first to the install profile. Then I add the apps. Once the apps are added, I just change the profile back to one that doesn't allow the installation of apps.


    It takes a little bit of work, but it gets the job done. The only thing you really have to be careful of is to only check or uncheck apps once you have loaded the install profile.

  • CASD Schools Level 1 Level 1

    Any resolution on this? I'm deploying 28 of these Bretford carts. The first 5 were not bad....today I updated software on the MacBook Air and now the VPP code files from Apple come back with a null error. Free apps work fine but we will be purchasing thousands of dollars worth of apps for these carts and I can't import the codes! Been on the phone for 3+ hours and still not one person at Apple who even knew what Apple Configurator was!!!

  • gyrhead Level 3 Level 3

    I received this notice from our Apple Engineer yesterday:


    "If you are running Apple Configurator, please be sure NOT to upgrade to 10.8.2. If you are running Lion (10.7) or earlier versions of Mountain Lion, you are fine. There is am emerging issue only with 10.8.2 we are currently tracking.

    If you have already upgraded, and are seeing an issue importing VPP codes, please call the iOS/iPad and MacOS Phone Support - Education Customers can call for Toll-free- AppleCare - 866-752-7753 . Please be sure to keep your case number anytime you call; we can follow-up and escalate any issues if we have that case number as a reference."

  • avansickler Level 1 Level 1

    I've got more or less the same issue; even after swapping the existing restrictions profile with one that explicitly allows app installs, attempting to push apps in supervised mode gets me a whole batch of 'InstallProhibited' errors. Still running Lion 10.7.5, and had the same issue on current AppCfg 1.1.2 and previous versions. Currently on the phone with the nice gents at Apple .edu support, hopefully we can weed this out.

  • avansickler Level 1 Level 1

    Okay, so from what we figured it could be sort of an order-of-operations issue. If you back up a device with a restrictions profile installed, iOS will bake the settings from that profile into the backup, but not attach the profile to manage them. If you restore from that backup, you'll get the restriction settings before applying any profiles. If you go ahead and turn restrictions off per-device, then apply a profile, it should work as intended. Seems like the best practice for initial setup at the moment is to avoid setting restrictions prior to backup, and only manage them through profiles after restoration.

  • CASD Schools Level 1 Level 1

    So let me add this to the mix. The last 3 carts I've started to configure immediately begin to upgrade the IOS. I wind up with 10-15 of the ipads failing during the process with an "unrecognized device error".  Spoke with Apple and I have to find the devices..pull them and individually plug them in using itunes to restore. I should be finished up here sometime in April......That's okay because I'm a tech director at a school district with nothing else to do.....

  • CASD Schools Level 1 Level 1

    More info....they all lock up in recovery mode.......

  • gyrhead Level 3 Level 3

    I had this issue with the bigger Bretford carts that had 30 slots.  With smaller units this has not been an issue.  I believe it is a USB connectivity issue, possibly even cart related, and it might have nothing  to do with the Apple side of things.

  • CASD Schools Level 1 Level 1

    Understood....however Apple is selling the carts. In fact...I was told if I purchased another model I might have issues with support. We purchased everything direct from Apple so there would be none of this "other vendor blame" going on. I am just finishing preparing another cart of 30......14 pads failed during the ios upgrade. I did ask support if only plugging in 15 at a time would matter and was told no.....

  • CASD Schools Level 1 Level 1

    and to reiterate...I had none of these issues before. Have 5 of these carts that we setup with itunes and the iphone config utility....never had any problems...