10 Replies Latest reply: Mar 16, 2015 5:15 AM by Sean from Canada
Dougal222 Level 1 (0 points)

My iBook G3 Clamshell refuses to connect to my network with WPA. It just says "There was an error joining the network" just after i type the password.


When it asks for the password it does say WPA Personal in the wireless security section. It is running OS X Tiger 10.4.11 and I did all the updates.


The firmware on my Airport Card is 9.5.2 and the card says 128 Bit on it. In System Profiler and Software/Applications it says my Airport Utility is 5.4.2 and in extentions it says AppleAirport 3.4.9.


My wireless modem/router is a Thomson TG585V8 and is set as 802.11b/g/n mixed mode and WPA+WPA2 for security. I did try setting it to 802.11b only and 802.11b/g and i also tried WPA only but still the same problem.


If I set it up for WEP it accepts my password and works fine. If i switch security off it also connects fine.


Is there anything i could have possibly missed ?


According to the requirements, having OS X 10.4.11 and the updates and having the router set to WPA and 802.11b it should work. AFAIK only WPA2 and 802.11G upwards won't work.

iBook, Mac OS X (10.3.x)