8 Replies Latest reply: Apr 28, 2013 7:58 PM by marconiusrex
jason4101 Level 1 Level 1

I opened system preferences to look at changing the desktop picture.  Once I got to the place to do that I started to open the files in there to view the pictures that are there.  I opened one of the folders and it said loading image and then the beach ball started.  So I waited thirty minutes and nothing.  I have to force quit system preferences and then if I try to go back into screen saver it open and I get the same message with the beach ball again.  Im not that computer savey and have never had any problems before.  Is there something that I should reset or restart?  I tried restarting my mac and that did nothing.  Any help would be appreciated.

 

Thanks


MacBook Pro (15-inch Late 2011), Mac OS X (10.7.3)
  • crampy Level 4 Level 4

    Do you mean you opened System Preferences from the Dock? Or you mean from Finder?

    How often do you restart your machine? (apple at top, restart) How often do you run repair disk permissions?

    How much available disk space do you have?

  • jason4101 Level 1 Level 1

    Yes from the Dock.  I restart around twice a day.  Ive ran repair disk permissions from my user side and also from the safe boot side and nothing has changed.

     

    Thanks

  • crampy Level 4 Level 4

    and have you kept up to date with software updates? How much available disk space do you have?

  • crampy Level 4 Level 4

    I did a search of "beachball in pref's" and found this page...how many other app's do you have going at the time? maybe try quitting everything but Finder and then go to system pref's and see what is happening...

    http://www.macworld.com/article/1151583/spinningbeachballofdeath.html

  • jason4101 Level 1 Level 1

    That was helpful but didnt provide a fix.  I have 464.29 free out of 499.25 total which I assume is enough.  All software is up to date.  Ive repaire premission from safe boot, recovery, and user.  Ive spent the last hour deleting different caches and plist files with no success.  My mac is a late 15in Pro.  Everything else runs fine and system prefs wont freeze unless I try to change the screen saver.  After deleting all the pics i had for desktops the factory galaxy reapeared.  But that is all that I am able to do. 

  • TheMoose1973 Level 1 Level 1

    Hey,

     

    I just got the same problem as you described and took me a bit to resolved it but it worked for me by doing the below things...


     

    Started when I tried to change my Desktop Background/Picture and I think I clicked the iPhoto Folder to look for more pictures but after that no matter what I would do I always got the SPINNING BEACHBALL of DEATH!!! No matter how I tried to go into the System Preferences it would just do the BEACHBALL thing…


     

    So from the TERMINAL windows I tried the first line below to delete the system property settings but that didn’t work after the reboot. I decided to delete all 3 settings for the System Properties, Desktop and Screen Saver since that’s the area I was having issues in.


     

    After I deleted (well the mv command actually just moves the file but you can delete it off your desktop afterwards)… it all worked… Note that I did not do anything else to my system... disk repairs, file permissions changes... nothing just the 3 lines below...

     

    Make sure you don't have the System Preferences running or that it's not FROZEN (none responsive) if it is Kill the process by forcing it closed (OPTION + COMMAND + ESC) and you will get the FORCE QUIT APPLICATION Windows. Once you are sure it is not running do the below...

     

    FROM TERMINAL WINDOWS

     

    mv ~/Library/Preferences/com.apple.systempreferences.plist ~/Desktop/com.apple.systempreferences.plist

     

    mv ~/Library/Preferences/com.apple.screensaver.plist ~/Desktop/com.apple.screensaver.plist

     

    mv ~/Library/Preferences/com.apple.desktop.plist ~/Desktop/com.apple.desktop.plist

     

    REBOOT after this

     

    You should be set or it worked for me like a charm….

     

    Later

     

    Let me know it works out for you...

  • corey18 Level 1 Level 1

    Thanks TheMoose1973

    My computer now works again! Thanks for the advise

  • marconiusrex Level 2 Level 2

    Hey...the same thing happened to me recently on my MacBook Air, I did a search in the forums found this thread...followed your directions and worked great!

     

    Thanks!

     

    Mark