Previous 1 2 Next 23 Replies Latest reply: Aug 20, 2014 4:02 PM by bitgeeky Branched to a new discussion.
mruthjh Level 1 (0 points)

I can't seem to connect to Ethernet with my Retina MacBook Pro. I bought an adapter and when I plugged it in, the network setup assistant showed that I was connected to the internet but my web browsers (Safari, Firefox and Chrome) couldn't connect, nor could any other programs (like Mail). The error message said that my computer was not connected to the internet, which did not match what Network Diagnositcs said. After a phone call with Apple Support, I had a replacement adapter mailed to me. With the new adapter, my computer now says that it is connected to the internet and I even have an IP address, but programs still can't connect and I get an error message saying the DNS lookup failed. This happens even when I manually enter the DNS server. I have already tried running the Thunderbolt software update 1.2.1 as well as the recent Thunderbolt firmware update, but the installer says they are not compatible with my computer. The problem occurs for both Thunderbolt ports. Is anyone else having this issue? I have no problem connecting to WiFi, so my temporary work around is using internet sharing on my old MacBook, which can connect to the ethernet connection in my apartment with no problems.


MacBook Pro with Retina display, Mac OS X (10.7.4)
  • BGMac Level 1 (0 points)

    Yes I have exactly the same issue with my retina MacBook-It worked initially, but then now says it is not plugged in.  Wifi works fine.

  • mruthjh Level 1 (0 points)

    Well, it's good to know I'm not the only one with that issue. My guess is that it's some sort of software bug since it seems unlikely that there'd be something wrong with both thunderbolt ports. My computer recognizes that the adapter is plugged in, but it still can't connect. Have you talked to Apple Support at all? I've been on the phone with them several times but they weren't able to fix the problem, so I think I'll just have to wait until I can take it in to an Apple Store.

  • BGMac Level 1 (0 points)

    I have not spoken with them.  My problem is intermittent.  I disabled the wireless, rebooted and the Thunderbolt-Ethernet worked.  I think the problem may be that if you have both the hardwire plugged in and are receiving wireless, the computer sometimes defaults to wireless and drops the Thunderbolt-Ethernet connection.

    As for calling Apple Support- I find that I generally know more than they do, so it is kind of a waste of time.  I prefer to lurk in the chat rooms to find strings of questions and answers on such problems.

  • mruthjh Level 1 (0 points)

    Hmm. Well I tried rebooting with wifi off but that didn't fix things for me. Would you mind sharing what your System Information says under Thunderbolt? This is what mine looks like:

     

    MacBook Pro:

     

      Vendor Name:          Apple, Inc.

      Device Name:          Macintosh

      UID:          0x0001000D1290C120

      Firmware Version:          11.1

      Port:

      Status:          No devices connected

      Link Status:          7

      Link Controller Firmware Version:          0.11.4

      Port:

      Status:          Connected

      Link Status:          2

      Link Controller Firmware Version:          0.11.4

     

    Thunderbolt to Gigabit Ethernet Adapter:

     

      Vendor Name:          Apple, Inc.

      Device Name:          Thunderbolt to Gigabit Ethernet Adapter

      Vendor ID:          0x1

      Device ID:          0x8003

      Device Revision:          0x1

      UID:          0x000100020059EBB0

      Apple Serial Number:          DTN224606LWDWKHAX

      Route String:          3

      Firmware Version:          5.5

      Port:

      Status:          Connected

      Link Status:          2

      Port Micro Firmware Version:          0.0.8

  • xavibcn Level 1 (0 points)
  • evil_scientist Level 1 (10 points)

    I just had this problem, but it found this fixed it for me: I plug the adapter into the Thunderbolt port closest to the magsafe connector and my ethernet now works. I was having issues when plugged into the other port. This may only be a fix for my local problem, however, but I figured I'd throw it out there for folks. YMMV, as they say.

  • Hans Lijnbach Level 1 (0 points)

    I also have a problem with Thunderbolt - Ethernet.

     

    See this problem:

     

    https://discussions.apple.com/thread/4583827?tstart=0

     

    Hans

  • robnotman Level 1 (0 points)

    I am having the same intermittent problems using a thunderbolt to ethernet adapter.

    After playing around with it for a while, I belive it's related to my Time Machine backups (which I'm performing using a Synolgy NAS). When the backups are being performed I get a 'flaky' connection, when they finish, I get solid replies (no drops) on a constant ping I am using to test.

    Could anyone else verify that this is their issue also?

    Thanks.

  • Hans Lijnbach Level 1 (0 points)

    I am sorry,

     

    My problem is related to the ports. I had to change te internal port rooting to solve the problem. It is working now, but not the way it should work.

     

    Hans.

  • stmcloud Level 1 (0 points)

    Im having the same issues as Mrruthjh. Any solutions to this please?

  • Makpple Level 1 (0 points)

    Hi BGMac,

     

    I wonder if you have found a solution. I want to use both the wireless (connected to my home network), and my wired Ethernet via Thunderbolt adapter (connected to my work VPN) at the same time.

     

    In my previous macbook pro it works without any issues. But for the macbook pro with retina, the problem is exactly as you've described. It defaults to the wireless connection, rather than trying to connect via the wired connection if wireless can't reach the intended destination.

     

    I am hoping that you have found the cure.

     

    Derek

  • junoo129 Level 1 (0 points)

    Hey! I had this problem for a while and I was really frustraded... guess what, your way worked! I just had to plug it to the port near the power port! Thanks!!

  • davideglin Level 1 (0 points)

    Hi all, I've been pretty rattled by this same issue today as well. My Thunderbolt Gigabit Ethernet dongle connects for a while (with an IP address) but then drop's its connection. Whats frustrating is that in Network Preferences it says that it's connected (green light) and has the same IP address. When I ping the router or browse to its IP address though, I don't get anything. This is bugging me because the connection will stay up for varying times and then drop out.

     

    I can see that it's still talking to the ADSL router and the connection is still up, but no Internet connection.  IFCONFIG in terminal shows an IP Address still, but no ping responce. Weird thing is, I can still browse around my NAS which uses Bonjour and I can still see my Apple TV.

     

    I also have a USB Ethernet dongle and when I connect this, after the Thunderbolt link goes down, I get the same problem, IP address but no connectivity.. When I connect the same USB dongle to my older Macbook Air I get the same issue. I wonder if it's an issue with Ethernet drivers on the new MBP?

     

    Please anyone.!!!

  • michael_m_c Level 1 (0 points)

    I have the same problem. Green light + IP address but no internet.

     

    Did you solve the problem?

Previous 1 2 Next