12 Replies Latest reply: Nov 17, 2012 5:23 AM by SrgBrazil
clareau Level 1 Level 1

iMac, Mac OS X (10.6.8)
  • Terence Devlin Level 10 Level 10

    You'll need to try that again...


    There are 9 different versions of iPhoto and they run on seven different versions of the Operating System. The tricks and tips for dealing with issues vary from version to version and OS to OS. So before anyone can help, they need information to work with. Things like:


    - What version of iPhoto.

    - What version of the Operating System.

    - Details. What were you doing when the problem arose?

    - Did it ever work properly?

    - Are there error messages?

    - What steps have you tried already to solve the issue.


    Anything else you can think of that might allow someone else to understand your issue.

  • SrgBrazil Level 1 Level 1

    My iPhoto is not opening:


    - What version of iPhoto.


    - What version of the Operating System.


    - Details. What were you doing when the problem arose?

    I just tried to open when I started to work

    - Did it ever work properly?


    - Are there error messages?


    - What steps have you tried already to solve the issue.

    I did nothing, because I am concerned about loosing my photos.


    Can you help me?

  • LarryHN Level 10 Level 10
    Photos for Mac

    Not unless you tell us what actually happens  --  not opening is not enough - does it crash? show a spinning rainbow wheel? Exactly what?



  • birdy176 Level 1 Level 1

    Sorry, Larry, Old Toad and Brazil.

    My original thread was called : iPhoto 08 icon on dooc not working


    Appreciate your answers but could not locate my own thread and latched onto this one as it parallels my own woes. Have tried to re-install my original Leopard disks but they contain no Restore feature. The iPhoto icon reappeared in the App folder but wouldn't open the file. Have perused every advice you have given here and tried them all.


    Short of buying a new computer, is there any way I can order a new version (am on Snow Leopard now) so as to re-activate my iPhoto that came with my Leopard v. 10.5, upgraded to Snow Leopard 10.6.3? That might not fix my problem if there's something hidden that could re-appear in a new version.


    Please include instructions on how to get back to my original thread since I don't want to violate protocol. Your advice is too valuable. Your last suggestion to delete "Receipts" led me to a window with 4001 ominous error and exception warrnings.


    My 3-year Apple Care subscription ran out. Living in the boonies places me some 150 miles from the next Apple store. I hate to depend on my old Windows machine which has only about 5,000 of my 12,000 photos on it. Fortunately all of them are on an external drive and are not lost, just inaccessible.


    Thank you again!

  • LarryHN Level 10 Level 10
    Photos for Mac

    Your thread is here - https://discussions.apple.com/message/20202287#20202287


    Youe issues has nothing to do with this thread


    Please continue with the original thread



  • volterra Level 1 Level 1

    Since I updated iPhoto to 9.4.2 I've not been able to run it. (OS is 10.8.2)


    I've tried everything short of reinstalling only because I can't figure out how to reinstall something from the App Store. And it seems a bit extreme.


    It asks me to repair the photo database, I do, it does, it quits. Here's the start of the crash report.


    Process:         iPhoto [7996]

    Path:            /Applications/iPhoto.app/Contents/MacOS/iPhoto

    Identifier:      com.apple.iPhoto

    Version:         9.4.2 (9.4.2)

    Build Info:      iPhotoProject-710042000000000~2

    App Item ID:     408981381

    App External ID: 11723545

    Code Type:       X86 (Native)

    Parent Process:  launchd [162]

    User ID:         502



    Date/Time:       2012-11-16 11:19:30.468 -0800

    OS Version:      Mac OS X 10.8.2 (12C60)

    Report Version:  10



    Interval Since Last Report:          80890 sec

    Crashes Since Last Report:           1887

    Per-App Interval Since Last Report:  181 sec

    Per-App Crashes Since Last Report:   8

    Anonymous UUID:                      C914C1F5-F038-39FC-34FE-D9C080C60408



    Crashed Thread:  3  Dispatch queue: com.apple.CFURLCACHE_work_queue



    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)

    Exception Codes: KERN_INVALID_ADDRESS at 0x00000000f8082c88



    VM Regions Near 0xf8082c88:

        CG backing stores      00000000c720f000-00000000c738f000 [ 1536K] rw-/rw- SM=SHM 


        Submap                 00000000ffff0000-00000000ffff1000          r--/r-- process-only submap



    Thread 0:: Dispatch queue: com.apple.main-thread

    0   libsystem_kernel.dylib                  0x967307d2 mach_msg_trap + 10

    1   libsystem_kernel.dylib                  0x9672fcb0 mach_msg + 68

    2   com.apple.CoreFoundation                0x94cea599 __CFRunLoopServiceMachPort + 185

    3   com.apple.CoreFoundation                0x94ceff7f __CFRunLoopRun + 1247

    4   com.apple.CoreFoundation                0x94cef63a CFRunLoopRunSpecific + 378

    5   com.apple.CoreFoundation                0x94cef4ab CFRunLoopRunInMode + 123

    6   com.apple.CFNetwork                     0x951bc207 CFURLConnectionSendSynchronousRequest + 444

    7   com.apple.Foundation                    0x927e4de2 +[NSURLConnection sendSynchronousRequest:returningResponse:error:] + 332

    8   com.apple.iPhoto                        0x00970642 0x54000 + 9553474

    9   com.apple.iPhoto                        0x009703db 0x54000 + 9552859

    10  com.apple.iPhoto                        0x0096fe65 0x54000 + 9551461

    11  com.apple.iPhoto                        0x008dd766 0x54000 + 8951654

    12  com.apple.iPhoto                        0x003c30bd 0x54000 + 3600573

    13  com.apple.AppKit                        0x91dcdcca -[NSTabView selectTabViewItem:] + 1182

    14  com.apple.AppKit                        0x91dcd7c5 -[NSTabView selectTabViewItemAtIndex:] + 64

    15  com.apple.prokit                        0x024a885b -[NSTabView(MKTabModuleAdditions) selectTabViewItemWithIdentifier:] + 71

    16  com.apple.iPhoto                        0x003ce550 0x54000 + 3646800

    17  libobjc.A.dylib                         0x946ef5d3 -[NSObject performSelector:withObject:] + 70

    18  com.apple.AppKit                        0x922afc6b -[NSToolbarButton sendAction:to:] + 94

    19  com.apple.AppKit                        0x922afcca -[NSToolbarButton sendAction] + 82

    20  com.apple.AppKit                        0x922bb76f -[NSToolbarItemViewer mouseDown:] + 5473

    21  com.apple.AppKit                        0x91d91a21 -[NSWindow sendEvent:] + 6968

    22  com.apple.AppKit                        0x91d8ca0f -[NSApplication sendEvent:] + 4278

    23  com.apple.iLifeKit                      0x02274c9b -[iLifeKit sendEvent:] + 55

    24  com.apple.iPhoto                        0x000d4344 0x54000 + 525124

    25  com.apple.AppKit                        0x91ca672c -[NSApplication run] + 951

    26  com.apple.AppKit                        0x91c496f6 NSApplicationMain + 1053

    27  com.apple.iPhoto                        0x00063c99 0x54000 + 64665

    28  com.apple.iPhoto                        0x000632e5 0x54000 + 62181



    Thread 1:: Dispatch queue: com.apple.libdispatch-manager

    0   libsystem_kernel.dylib                  0x967339ae kevent + 10

    1   libdispatch.dylib                       0x9364ec71 _dispatch_mgr_invoke + 993

    2   libdispatch.dylib                       0x9364e7a9 _dispatch_mgr_thread + 53



    Thread 2:

    0   libsystem_kernel.dylib                  0x967330ee __workq_kernreturn + 10

    1   libsystem_c.dylib                       0x961ee04c _pthread_workq_return + 45

    2   libsystem_c.dylib                       0x961ede19 _pthread_wqthread + 448

    3   libsystem_c.dylib                       0x961d5cca start_wqthread + 30



    Thread 3 Crashed:: Dispatch queue: com.apple.CFURLCACHE_work_queue

    0   libsqlite3.dylib                        0x96a82eda sqlite3Update + 9370

    1   libsqlite3.dylib                        0x96a06ee0 yy_reduce + 30720

    2   libsqlite3.dylib                        0x969ff660 sqlite3Parser + 240

    3   libsqlite3.dylib                        0x969fd757 sqlite3RunParser + 295

    4   libsqlite3.dylib                        0x969fcf4d sqlite3Prepare + 1293

    5   libsqlite3.dylib                        0x969fc98e sqlite3LockAndPrepare + 270

    6   libsqlite3.dylib                        0x96a78b65 sqlite3_prepare_v2 + 53

    7   com.apple.CFNetwork                     0x952246eb __CFURLCache::PrepareSQLStatement(sqlite3_stmt**, char const*, sqlite3*, long) + 69

    8   com.apple.CFNetwork                     0x952245bb __CFURLCache::PrepareInsertStatement() + 441

    9   com.apple.CFNetwork                     0x952233f1 __CFURLCache::OpenDatabase() + 519

    10  com.apple.CFNetwork                     0x9522308f ProcessCacheTasks(__CFURLCache*, bool) + 1296

    11  com.apple.CFNetwork                     0x9522259f _CFURLCacheTimerCallback(void*) + 714

    12  com.apple.CFNetwork                     0x95224a81 __SignalWorkerTaskToPerformWork_block_invoke_0 + 18

    13  libdispatch.dylib                       0x9364ff8f _dispatch_call_block_and_release + 15

    14  libdispatch.dylib                       0x9364bc82 _dispatch_client_callout + 46

    15  libdispatch.dylib                       0x9364d160 _dispatch_queue_drain + 206

    16  libdispatch.dylib                       0x9364cffa _dispatch_queue_invoke + 50

    17  libdispatch.dylib                       0x9364cecb _dispatch_worker_thread2 + 230

    18  libsystem_c.dylib                       0x961ede12 _pthread_wqthread + 441

    19  libsystem_c.dylib                       0x961d5cca start_wqthread + 30



    Thread 4:

    0   libsystem_kernel.dylib                  0x967330ee __workq_kernreturn + 10

    1   libsystem_c.dylib                       0x961ee04c _pthread_workq_return + 45

    2   libsystem_c.dylib                       0x961ede19 _pthread_wqthread + 448

    3   libsystem_c.dylib                       0x961d5cca start_wqthread + 30

  • volterra Level 1 Level 1

    editing to add, that I did reinstall it -- and it installed 9.4.2 *sigh*

  • Old Toad Level 10 Level 10
    Photos for Mac

    Try this:  launch iPhoto with the Option key held down and try to create a new, test library.  Import some photos and check to see if the same problem persists.  


    If the problem does not exist with the new library your current library is the culprit. If that's the case make a temporary, backup copy of your library if you don't already have one (Control-click on the library and select Duplicate from the contextual menu) and  apply the two fixes below in order as needed:

    Fix #1


    Launch iPhoto with the Command+Option keys held down and rebuild the library.




    Since only one option can be run at a time start with Option #1, followed by #3 and then #4 as needed.


    Fix #2


    Using iPhoto Library Manager  to Rebuild Your iPhoto Library


    1 - download iPhoto Library Manager and launch.


    2 - click on the Add Library button, navigate to your Home/Pictures folder and select your iPhoto Library folder.


    3 - Now that the library is listed in the left hand pane of iPLM, click on your library and go to the File ➙ Rebuild Library menu option.


    4 - In the next  window name the new library and select the location you want it to be placed.


    5 - Click on the Create button.


    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments.  However, books, calendars, cards and slideshows will be lost. The original library will be left untouched for further attempts at fixing the problem or in case the rebuilt library is not satisfactory.




  • volterra Level 1 Level 1

    option #1: got as far as entering the new library name and it quit! (I've removed the iPhoto preferences from library. So the problem is with iPhoto. Which I've reinstalled twice now.

  • Old Toad Level 10 Level 10
    Photos for Mac

    Try the following:  make a temporary, backup copy (if you don't already have a backup copy) of the library and try the following:


    1 - delete the iPhoto preference file, com.apple.iPhoto.plist, that resides in your

         User/Home/Library/ Preferences folder.


    2 - delete iPhoto's cache file, Cache.db, that is located in your

         User/Home/Library/Caches/com.apple.iPhoto folder. 



    Click to view full size


    3 - launch iPhoto and try again.


    NOTE: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding down the Option key when launching iPhoto.  You'll also have to reset the iPhoto's various preferences.


    NOTE 2:  In Lion and Mountain Lion the Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and hit the Enter button - 10.7: Un-hide the User Library folder.

  • volterra Level 1 Level 1

    nope. did exactly as you described above.


    Fortunately, I have Time Machine, so I'm rolling back to the previous version. Did that before I got your message above and it worked fine so I'll restore that.


    Some more info for you. Having rolled back to the previous version (9.4.1), I went and checked my preferences to see what needed changing. When I clicked on the Accounts pane, it crashed. But when I reopened, it reopened just fine.

  • SrgBrazil Level 1 Level 1

    Good Morning.


    My situation was just like Volterra's. Thanks to Time Machine I rolled back to version 9.4.1 and it is working fine.  I really believe there is a problem with the 9.4.2 version, and I will not install it again.