Previous 1 2 Next 26 Replies Latest reply: Nov 22, 2014 9:41 AM by Spahrkee Go to original post
  • kinless Level 1 Level 1 (5 points)

    Disregard my last post. I removed some disabled drivers and made other adjustments and it finally installed.

  • Chippy99 Level 1 Level 1 (10 points)

    I have the same iMac and I just can't get Bootcamp to install.  I edited the bootcamp.msi file as suggested, tried "NOCHECK=1" and run from elevate command prompt but it still won't run.

     

    @kinless = please can you let me know what you did to get it to run?  I am tearing my hair out here!

     

    (I have moved a Bootcamp installation over from another Mac - both Macs are mine - and have it up and running on an external drive, which has been a right pain to get this far.  If I can just get the installer to run, I am hope and dry.  I only have a couple of exclamatin marks in Device Manager, but one of them is USB3 support.)

  • kinless Level 1 Level 1 (5 points)

    Oh man that feels like forever ago now.

     

    I believe the main issue (for me) was that there's 2 different graphics drivers when using VMWare Fusion. One is native for Boot Camp, and the other is for when using VMWare. I believe the installer didn't like the VMWare graphics driver so I booted into Boot Camp and uninstalled it from the Device Manager, as well as any drivers that had the exclamation mark. Only after this was installation successful. Once the new Boot Camp 5.0 was in and working, I then restarted back into the Mac/VMWare side and re-installed VMWare drivers, and restarted again to ensure success.

     

    So in short, boot natively into Windows, get rid of the VMWare Fusion graphics driver and any/all drivers that have exclamation marks. I think the Boot Camp installer wants things in tip-top shape before it will allow you to install.

     

    Of course, if you're not using VMWare, just focus on the problem drivers, but your solution may lie elsewhere if that alone doesn't work.

  • Chippy99 Level 1 Level 1 (10 points)

    Thanks ever so much mate - really appreciate it.

     

    As it happens, your suggestions didn't work though and were a bit of a red herring for me (but thanks anyway).  I uninstalled every driver I could think of - and made the system unbootable into the process, which took blinking ages to sort out - but it made no difference.

     

    In the end, I realised that the old Bootcamp Services was still installed from my Mac Mini, and although not running was still listing in Control Panel>Programmes and Features.  When I tried to uninstall that, I got the same error message about this version of Bootcamp is not intended bla bla bla.  Basically it would not uninstall.

     

    So I tried the Microsoft uninstaller repair tool, which did manage to remove the entry in Programmes and Features.  Whether it uninstalled the software, I have no idea.

     

    But anyway, after that I tried running the Bootcamp installer again and guess what, it worked!  So I now have a perfect Bootcamp installation, with all my programs and stuff on it, running off an external USB drive :-)  Just what I wanted.

  • ftcy Level 1 Level 1 (0 points)

    It really worked. Geez, thanks to you instead of apple created a crap version of bootcamp that meant to be a failure and let people lose hope. You are Genius!

  • ncasey88 Level 1 Level 1 (30 points)

    YES - FINALLY
    Thank you.

     

    12 hours after installing my new HDD I now seem to have a perfectly functioning version of Windows 7 on my Macbook Pro 5,1 Late 2008.

     

    My pain and frustration with Boot Camp began about 2 years ago when I attempted to install it after getting fed up with Parallels Desktop. At that time, I received some form of HDD error (I can't remember the details but I assumed it was to do with the HDD being on its deathbed - luckily it survived for a further 2 and is still trundling on in its second life as a USB drive at the moment)

     

    In the last 12 hours i've had to go through countless workarounds until last night i kept getting Bootcamp errors on windows and being unable to use the trackpad, audio card and graphics card as they were meant to be used.

     

    At last - all good.

     

    Now to install some games

  • jbrogaard Level 1 Level 1 (0 points)

    GrovrM, my son (the gamer) and I (his captain) owe you (almost) everything. I guess this would otherwise just have been a dead end. Thx

  • trevorsnyder77 Level 1 Level 1 (0 points)

    Thank you!

     

    This was exactly what I needed to get past the error message!

     

    I do want to note for anyone doing a Windows 7 32 Bit install that you need to drop the Launch Condition from the BootCamp.msi and not the BootCamp64.msi to kill the error message for a 32 Bit install.

     

    Thank you again GrovrM!!!

  • jjrvi Level 1 Level 1 (0 points)

    Thank you GrovrM! Installing Windows 8.1 Update using Boot Camp 5.1.5640 on a 15" MacBook Pro Retina still gave the same error. The problem was the LaunchCondition table in BootCamp/Drivers/Apple/BootCamp.msi. After removing it, setup.exe still doesn't work but double clicking on BootCamp.msi made it successfully install everything.

     

    I tried everything from different forums but in the end the working process was:

    - Make a backup...

    - Install Mavericks somewhere external. I wanted to keep Mountain Lion as the main system for now.

    - Boot to Mavericks, unmount internal hard drive and repair it with Disk Utility (mine had some small issues that prevented Boot Camp from creating a Windows partition)

    - Shave off 20 gigabytes from internal OS X partition for Windows, format as regular FAT.

    - Use the Boot Camp Assistant without the middle option (just because the download seemed to take forever).

    - Before rebooting, unzip manually downloaded BootCamp5.1.5640.zip in the USB stick root.

    - Make sure no external drives are connected, except the USB stick.

    - Hold command while booting, choose WININSTALL (EFI Boot didn't work, complaining about MBR later although it did give a nicer resolution during the failed setup).

    - Don't enable Windows updates just yet.

    - After install is done it pops up a message "The version of Boot Camp is not intended for this computer model".

    - Install InstEd 1.5.15.26 (free download).

    - Open BootCamp.msi, choose "Drop Tables" from tables menu and select LaunchCondition, save changes.

    - Install drivers using BootCamp.msi, reboot.

    - At this point there's less than 4GB of free space left on the Windows partition.

     

    System works, now try to move everything to an external SSD.

     

    - Connect the SSD so Windows installs drivers for it. Otherwise it won't be able to boot off it later. This is a LaCie 2big Thunderbolt bought a year ago, hard drives removed and using only a single Crucial 512GB SSD. Reports say some other drives work...

    - Reboot to OS X, make an image of the 20GB Windows drive using Winclone by Twocanoes. First set its preferences to remove pagefile and hibernate file. This software costs some money but I couldn't figure out how to avoid it and it does make nice backups.

    - Remove the 20GB Windows partition, leave it as empty space for now in case it needs to be restored again. Choose the whole disk in Disk Utility, select the 20GB partition and click on the "-" button. Apparently having two Windows partitions may cause them to not boot.

    - Create a new partition in the BEGINNING on the external SSD. I used to have Mavericks there and had to erase it at this point. If Windows partition is not the first, it won't boot.

    - Restore image to new partition using Winclone. It expands it to fit the new size and converts the partition to NTFS.

    - Windows doesn't boot. Oh well! It's possible to restore it on the 20 GB partition and play with it.

  • lemos_br Level 1 Level 1 (0 points)

    Works for me thank you! BUT I had to run the BootCamp.msi file. Running the Setup.exe I got the same error.

Previous 1 2 Next