6 Replies Latest reply: Jul 14, 2012 11:09 AM by jorkata
jorkata Level 1 Level 1 (0 points)

It started a week ago. I have my Macbook Pro for more than 2 years and the wireless connection was super. The router ( netgear wcr614v9) is in the next room and it has been there since the very begininnig. I am using WPA2 personal security. About a week ago the wireless connection become very slow and painfull , then it would drop off. I can see the airport searching for available wireless networks, sometimes it would pick it up, sometimes not. As soon as I move the laptop in the room where the router is it becomes as before - fast and no problems.  My ipad2 and my iphone4 have no problems with the wireless network connection at all!!! It is only the MBP. Advanced network setting in the system preferences panel looks OK. Do you guys have some ideas what would be the reason for this?

 

Regards


MacBook Pro (17-inch Mid 2009), Mac OS X (10.6.8)
  • Carolyn Samit Level 10 Level 10 (95,995 points)

    A wireless signal can be dropped for a myriad of reasons.. just takes some troubleshooting.

     

    Try turning off the router for about 5 minutes to allow it to reset then tuen it back on.

     

    As soon as I move the laptop in the room where the router is it becomes as before - fast and no problems

     

    Check out this support article >  AirPort and Bluetooth: Potential sources of wireless interference

     

    And try deleting the network preferences file. Could be corrupted.

     

    Open the Finder.

     

    From the Finder menu bar click Go > To Go Folder

     

    Type this exactly as you see it here;

     

    /Library/Preferences/SystemConfiguration

     

    Click Go

     

    Move the   NetworkInterfaces.plist     file from the SystemConfiguration folder to the Trash.

     

    See if that made a difference. Try your Wi-Fi.

  • idaveb Level 2 Level 2 (265 points)

    Also, you may have interference from other wireless networks, get on your router and change the chanel. Turning the router and modem off periodically can also help as suggested. All binary circuits need to be reinitilized periodically. If you have a wireless phone it can also interfer if the band is similar to G (2.4 GHz). Your router is not an G/N so the N band is not interfering, but that can happen when you have a dual band router.

  • jorkata Level 1 Level 1 (0 points)

    Hi Carolyn

    Thank you very much for your quick responce. I have moved the network preferences file to the trash but still no succes. I have already restarted the router and the modem many times with the hope to rectify the issue.  Note that the ipad, ipod and iphone use the same wireless connection anywhere in the house with no problems. So it could not be other wireless network interference. I think that could it be something in the MBP wireless network settings. Something in the TCP/IP or DNS etc. settins may be!!!

  • mr da Level 3 Level 3 (510 points)

    Just in case you want to check the channels nearby wireless stations are using, you can open About this Mac from the apple menu, choose More Info ..., and then select Wi-Fi under network. It should list all the visible stations and channels the channels they use. There must be a myriad of apps that will provide this information, too.

  • idaveb Level 2 Level 2 (265 points)

    If you move the MBP into the room where the router is you are reducing the attenuation of the signal. That means either the wireless card or antenna have a problem or the wireless radio on your router does. If the other devices work, it may be the card on the MBP. In the Preferences >> Network >> Wi-Fi click on Assist me... (near the bottom) and run through the diagnostics. Do it close and far away from the router.

     

    The mechanic of the wireless system in the MBP are a bit different than you other wireless devices, so it can also be increased interference by other routers, cordless phones, etc (on the 2.4 GHz band). These all increase attenuation. If you change the channel on the wireless radio on the router it may cut through some of the interference.

  • jorkata Level 1 Level 1 (0 points)

    Hi guys,

     

    thank you all so very much. I have checked in system profiler the networks in the neighbourhood and even though none of them was matching the chanel of my router I have change it from 09 to Auto. And it did the job. Now everything is back to normal. Once again many thanks!!!