Previous 1 2 3 4 5 Next 64 Replies Latest reply: Jan 13, 2015 7:56 AM by ashcj Go to original post
  • garz75 Level 1 (0 points)

    > > Should I change back my userid ?

    > First try creating a new account 501 and try that.


    Just did it. Did not work. I used the same apple ID for this new mac account. The App Store app, when logged as this user, showed me two apps to udpate (iPhoto & iMovie, the same as with the orginal mac account). Then when I clicked Update All, it asked me twice for my AppleID password, then told me that I had to buy the applications to update them.

    I chose cancel (I don't want to buy an app that's come for free with Mountain Lion...). And from now on, it gives me the same error message as before : To update this application, sign in to the account you used to purchase it.


    I really don't know what to do, except calling Apple support...


    > How does one find out which userid purchaced the software?


    I have no idea... The two apps I try to update, I did not buy them, they were coming preinstalled with Mountain Lion on this new MBP...

  • thedave3000 Level 1 (0 points)

    The only way I was able to correct this problem was to contact iTunes support and they had to reset my account so that I could update the applications.  They had me try several different scenarios and nothing worked.  My suggestion is to contact them, explain the issue, and have them reset your account.  Since doing that, the problem has gone away completely for me.


    You can contact the App Store support here:


    Good luck.

  • zit Level 1 (30 points)

    > > How does one find out which userid purchaced the software?


    > I have no idea... The two apps I try to update, I did not buy them, they were coming preinstalled with Mountain Lion on this new MBP...


    It must assign the userid when you first set up the new machine.

    Interesting that the message has now changed, so they may be accepting the 501 userid.
    This is likely DRM (Digital Restrictions Management) gone wrong.

    One wonders what "Resetting your account" does.


    I had this problem with a couple of third party apps.

    When I set up my machine, I left the original account 501 there and created a new userid to use.

    Logging on to 501 allowed the update, so your original idea will likely work.


    Let us know what you find out.
    Lots of people waste lots of hours on copy protection.

    More than the apps are worth :-(


    If you talk to Apple, let us know what they suggest, even if it doesn't work.

  • Jan Peeters Level 1 (15 points)

    I had the same problems and I think I know why this happening...


    The problem occurs when I try to update apps via the Appstore that weren't installed via the Appstore. Read e.g. came preinstalled on your computer.

    When I first deleted those apps from my harddrive and restart the Appstore I can install the apps without a problem.

    My guess is that this has nothing to to with DRM but with the sandboxing  system Apple uses with the Appstore.

    Hope this helps.



  • garz75 Level 1 (0 points)

    Thank you all for your answers. Like I said creating a new user with uid 501 did not work, but I do not want to change now my user id to 501 : I dropped an email to the apple support throught the support web site more than 24h ago. Since the system sent me an email saying

    "This is an automated reply, but an iTunes Store (Mac App Store) representative will review your request and send you a personal response, most likely within 48 hours."

    I will patiently wait for this amount of time ;-) I'm new at Apple support and MacOS, I wonder if they respect their deadlines when it comes to answer their users...

    I'll escalate to phone and/or go to the nearest Apple Store before trying your suggestion Jan, to remove and reinstall the applications...



  • aaronfromnew_york Level 1 (0 points)

    I was having this problem and found this thread.  My situation was slightly different, the user account that I had used to purchase the Apps (note not the Apple ID, the local Mac user) had been deleted.  I tried deleting the _MASReceipt folder for an App.  That did not work for me.  However, deleting the App entirely did work.  When I deleted an App and refreshed the Purchses page the status changed from UPDATE to INSTALL and I was able to do INSTALL successfully.  I tried clicking UPDATE on one of the other Apps and the error message returned.  I ultimately deleted and re-installed each one of the Apps with a Purchases page refresh in between.  It took hours, but it was, at least, predictable and effective.

  • JNICK1 Level 1 (0 points)

    I had the same problem. My problem was limited to iMovie, iPhoto, and Picture Collage Maker. I deleted those 3 from my mac. Then I reinstalled them and it fixed the problem. Now when I sign into the App Store they no longer come up. I hope this helps some.

  • Steve Cash Level 1 (0 points)

    JNICK1, my problem is (so far) limited to iMovie and iPhoto, how did you reinstall them? I have deleted iMovie by dragging it to the trash bin, but if I try to download it again, I will have to buy it. Is there another way to reinstall?

  • appleton_academy Level 1 (0 points)

    Steve, my solution to this iMovie & iPhoto update was as follows


    delete the _MASReceipt folders as described above then download the updates direct form Apple Support search for the update in the search field, in my case it was iMovie 9.0.8, (you can get the version from the app store update details) which was downloadable from Note you have to delete the _MASReceipt folder or it wont let you update this way


    Hope this works for others too

  • shimba Level 1 (0 points)

    This worked for me too.

  • nazemg Level 1 (0 points)

    Trashing the App and reinstalling it solved the problem for me.

  • spacbug Level 1 (5 points)



    I had the exact same problem with my new iMac.

    iPhoto and iMovie where in the updates tab but when I tried to update them it said I should use the account I used to purchase them. I only have one apple-id also.


    What I did was to call Apple Care and after I had talked to two persons I got an email from a third person in the US.


    He told me to try a few stuff that did not work and then he sent me three Redeem codes for iPhoto/iMovie/Garageband so that I could buy them with my apple-id.



    So if I were you I would call Apple Care.

  • shimba Level 1 (0 points)

    I realised i was getting this error because i installed the Xcode from a friend.  After trying everything the error keeps comiming back. since it keeps looking for the account it was initially downloaded from.


    The solution just uninstall the whole thing and reinstall with your own account, this solves the problem.

  • Rob Hill Level 1 (10 points)

    I had a similar problem and tried the reindex Spotlight fix,  and this solution at he-other-accounts-bug/ by commenter Renso. Nada.


    My problem was that all the apps that would not update were not in the Applications folder. For some reason they were actually on another drive. It seems the App Store app scans all the drives and because the apps were not in their original location it produced this misleading error message.


    This is such a poor error message—obviously a lazy programmer who couldn't be bothered specifying a real message pertinent to the actual problem.

  • t.gardner Level 1 (0 points)

    I had this problem on my iMac & MacBook Pro, the Spotlight fix worked brilliantly for me. I didn't even have to wait for Spotlight to finish Indexing, it worked immediately.