Previous 1 2 3 4 5 Next 64 Replies Latest reply: Jan 13, 2015 7:56 AM by ashcj Go to original post
  • jthrnbt Level 1 Level 1 (0 points)

    I deleted the _MASReceipt folder for Iphoto, downloaded Iphoto 9.4.2 and installed it. App Store now shows not updates needed and Iphoto shows release 9.4.2. I tried the other options and they wouldn't work for me.

  • AppleHI Level 1 Level 1 (0 points)

    I had this problem last year when I tried to update FCP X.  I got the same lame answer as lots of you did from Apple Support but after searching and trying different things (including this one with the Spotlight) I still had the problem.  So I reluctantly removed the app and downloaded/reinstalled and it "worked".  Of course now that I have another update, same problem.  I went back to this link and I found that doing 2 things worked for me.  First, repair your disk permissions using the Disk Utility.  Then re-indexing by turning off/on the Spotlight privacy did the trick.  Thanks for your help!

  • carpii Level 1 Level 1 (0 points)

    I have been struggling with this problem for a couple of hours, but eventually fixed it.

    My App Store was showing an 'Update' button next to an app I had bought, but clicking it said 'Sign in to the account you used to purchase this app etc etc'.


    Firstly, dont go deleting _MASReceipt if you know you legally bought the app AND it was installed via App Store.


    The App Store update process seems to rely heavily on Spotlight to find the receipts.

    Despite adding my Hard Drive and removing it, this didnt fix Spotlight.

    Infact I noticed Spotlight was not returning results for anything I searched for, so clearly it had crashed or some index problem.


    Try this...


    1) DiskUtil -> Repair Permissions


    2) Open Terminal,


    a) Stop spotlight..

    sudo mdutil -a -i off


    b) Erase spotlight index

    sudo mdutil -a -E


    c) Restart spotlight

    sudo mdutil-a -i on



    Finally make sure you close and reopen App Store.

    At this point clicking the Update button started downloading the update without further problems :-)

  • jfwilkus Level 1 Level 1 (0 points)

    The solution proposed by carpii worked for me.

  • igorkon Level 1 Level 1 (0 points)

    for me too! Thnx!

  • Nekoma Level 1 Level 1 (0 points)

    Thank  MarkRosewood


    I have a Macmini I buy in June 2010. I had to chande the HD with a new 500GB, but I do not update all OSX, and software  with time machine but with a NET disc.

    And this is because of the  problem to update iMovie and iPhoto, and have the account bug errors.

    The way I solvethis problem is to fix SPOTLIGHT, with your advice writing into the Terminal this line command

    sudo mdutil -i on /

    Thank You .

  • Nekoma Level 1 Level 1 (0 points)

    At the end of updating Spotlight with Terminal commands, and try to repair disk permission, this roblem still persist amd MAC tell

    " update available for other account" or " you never buy this software"


    I solved the problem 100% through the help of Time Machine !!!

    I get the original iMovie and iPhoto form my time machine, then recovered, and substitute from original.

    Now I have iMovie and iPhoto updated .


    Thank to all .

  • Alice T Bear Level 1 Level 1 (0 points)

    Worked a treat, anoying update reminder gone in a blink.


  • jdsahr Level 1 Level 1 (0 points)

    If you've been tearing your hair out as much as I have, then please read Rob's advice which I repeat to emphasize it's helpfulness:



    It took me 2 minutes to fix this (very stupid) problem that Apple created.



  • TV Cameraman Level 1 Level 1 (0 points)

    My problem was occurring with my iLife applications (iPhoto, iMovie, Garageband).  They came with my new iMac, but I kept getting the error that I had to log in with another account in order to update them ("You have updates available for other acounts"), even though I clearly "owned" these applications through the purchase of my new iMac.


    I called Apple and the 2nd-tier tech support rep (the 1st-tier tech support person was useless) recommended that I simply delete the iLife applications and then let the Mac App Store re-download them.


    I did just that and the Mac App Store has in fact re-downloaded the applications I deleted.


    All seems well.

  • mamod Level 1 Level 1 (0 points)

    This worked for me if it helps.




    BTW, for anyone who trips across this post, you don't need FindAnyFile. _MASReceipt is part of the package contents of the application. You can right-click on any application, including those that you purchased from the App Store, and choose to Show Package Contents. Open the Contents folder and you'll find the _MASReceipt folder. Deleting it for Fantastical solved my problem. Therefore, if you know the applications name that's causing the problem, close the Mac App Store, right-click on the application icon, e.g., Angry Birds, choose Show Package Contents, expand the Contents folder and delete the one labeled _MASReceipt. When you restart the Mac App Store, the Update button will have changed to Install and you'll then be able to complete the update.

  • TyfoidKid Level 1 Level 1 (0 points)

    This worked for me. I was a little confused Mamod because it reads like somone should right-click on the app in the App Store interface.  Once I figured out that you meant to right click in the app in the Applications folder and follow that down to that directory and delte it everything works fine now. I've had that iPhoto issue for about 6 months but haven't had time to care (I don't use iPhoto.)  Now it's fixed.Screen Shot 2013-04-30 at 8.36.31 AM.png

  • SoCalMtnBiker Level 1 Level 1 (0 points) he-other-accounts-bug/ (sudo mdutil -i on /) didn't work for me. I'm getting this message for Mavericks. I did repair permissions first. I also tried deleting the cache that someone recommended in one of these threads. I have more than one AppleID and tried logging into the other one, but that didn't help. Get the same message in both IDs.Obviously I can't delete the app. Repeated with restarts. Still same error.


    Any other ideas?

  • BocaBoy Level 1 Level 1 (25 points)

    You can delete the app(s) that are causing the problem. The app store will then allow you to reinstall them. That may be the most effective way for you to resolve this issue.

  • SoCalMtnBiker Level 1 Level 1 (0 points)

    Probably not clear from my posting, but i'm getting this message for upgrading from Mtn. Lion to Mavericks. So can't delete anything.


    I did figure out a work around. Downloaded Mavericks to another Mac and copied it over to the one with a problem. Installation went without a hitch. And the upgrade from 10 to 10.1 worked too.