1 2 3 4 5 6 Previous Next 83 Replies Latest reply: Aug 21, 2013 10:12 AM by AdamAndrew Go to original post
  • 60. Re: icloud not syncing documents to between new ipad and iphone 4s
    vincas Level 1 Level 1 (40 points)

    A work around that (at least during this morning) seems to work for me. Let's say I have a keynote presentation (though seems to work for all iWork iOS documents) on my iPad (or iPhone) with the "upload arrow" that does not upload. I open the presentation, and email it to myself to my mac. Move the file to the desktop. Then delete it from the iPad. Add the file to Keynote iCloud, and seems to sync then properly (i.e. migrates down to iOS devices, changes on iOS devices show up on Mac, etc.).

    I know it's a work around, not a simple solution, but until Apple fixes this on their end, it seems to work. Hope it's of some use to someone.

    Best,

    Vincent

  • 61. Re: icloud not syncing documents to between new ipad and iphone 4s
    joaomario Level 1 Level 1 (0 points)

    Yes, this solution worked for me as well.

     

    I had 5 documents stored on iCloud that weren't syncing. Two of them created on iPhone 4 and 3 of them on iPad 2. I sent them all to my e-mail and deleted them on the respective devices. After all, I opened them on my Mac and put them back on iCloud. They now work well on all devices.

     

    I have a feeling that when I start a document in iOS, using a device that is not connected to Internet, it won't sync well. That's the case with those five documents, even when connected later to the Internet (many times), it wouldn't work. All the other documents that I started on iPhone and IPad connected properly to the Internet sync perfectly.

     

    Best regards,

     

    joaomario

  • 62. Re: icloud not syncing documents to between new ipad and iphone 4s
    NaoiseOD Level 1 Level 1 (0 points)

    I discovered that any new documents created on my new iPad 2 would not sync to iCloud. It would pull down existing documents and I could edit them and they would successfully upload. However if created on the iPad all iCloud would ever see were "updating" ghost documents.

     

    Two days of forum reading and checking and resetting settings and even restoring and this forum finally gave a clue that solved my problem.

     

    I am an original @mac to @me to @icloud user. I always log in using my @me address out of habit.

     

    I emailed all the "stuck" documents to my gmail just in case and I would recommend saving them somewhere just in case. I did not need to use the backups though. Here's what I did:

     

    Deleted iCloud account from the iPad.

    Set iCloud back up using @icloud variant of my account

    Went into email settings and set the @icloud.com account as the default and switched off the @me.com account (I don't know if this has any bearing on the outcome at all but it is a step I took)

    Started up Pages holding my breath (this step is of course crucial)

     

    All the documents were pulled down from iCloud as usual and the stuck ones uploaded. I didn't even turn blue.

     

    Simply put - log in with xxxxx@icloud.com

     

    Hopes this assists someone else and thanks for the help!

  • 63. Re: icloud not syncing documents to between new ipad and iphone 4s
    Paul Mathias Level 2 Level 2 (175 points)

    Thanks gough_k, great suggestion! Worked fine here too.

    Two thumbs up.

  • 64. Re: icloud not syncing documents to between new ipad and iphone 4s
    I want an iPhone 3GS Level 1 Level 1 (10 points)

    Hey, recently I just found a way to fix this. Everything - turning off iCloud, documents, deleting apps, nothing worked! What I did was go to settings , general, reset, reset all settings. Tap it and it will ask you for your password and say that it won't delete any content (it doesn't). It will reboot so wait a couple minutes then come back once it's done. Now open settings again, and connect to your wifi network, you will have to enter you password again. Then once you are connected and have made sure Internet is working, (and after making sure pages iCloud sync is on in settings , pages) open pages and the documents should magically sync! Once they have all downloaded, go back into settings and go through everything and make sure to change the settings back to whatever you set it to before (if you can be bothered) the main thing you need to change is adding your password again. Also you may need to turn settings, notifications, mail, show in notification center and turn on banners because the are off by default.

     

    Hope this helps because it took me 3 months to figure this out.

  • 65. Re: icloud not syncing documents to between new ipad and iphone 4s
    iuwhite Level 1 Level 1 (0 points)

    I just noticed that some of my iCloud document data wasn't syncing either. I think it started happening after updating to iOS 6.1.  I was able to resolve the problem by doing a simple restart of the device (holding the power and home button together until the device rebooted). After it restarted, the syncing seems to be working again.

  • 66. Re: icloud not syncing documents to between new ipad and iphone 4s
    645763 Level 1 Level 1 (0 points)

    I have the same issue My iPhone 5 and iPad 4 is fine the docs in my iPad mini does not sync any solutions?

  • 67. Re: icloud not syncing documents to between new ipad and iphone 4s
    vincas Level 1 Level 1 (40 points)

    Hi,

     

    Did you try the work around I tried? At this very minute, I'm watching two iOS keynote presentations trying to upload (everytime I open iOS Keynote). I don't have a solid solution, but Apple reads these, knows about it, and is definitely working on it on their end, but after 1/2 a year or so, I'm still having issues, and trying to figure it all out. Some documents sync fine, and others not. For me, the problematic ones seem to be the bigger, graphics intensive iOS Keynote presentations (that keep trying to upload).

     

    Hope something in this thread helps! We're all in the same boat... : (

     

    Vincent

  • 68. Re: icloud not syncing documents to between new ipad and iphone 4s
    JohnDonovanPiano Level 1 Level 1 (0 points)

    Hi,

     

    I just found this thread after having syncing problems. I mainly update expenses spreadsheets using numbers on my phone while out, but occasionally access them on iPad. Last night I noticed that on the iPad my files were a couple of weeks out of date. Tried deleting & reinstalling numbers but it just restored the same out of date files. Eventually tried one of the suggestions above: simply rebooted each device- hold power and home buttons down together until the screen goes blank, wait a few seconds till the apple logo appears & release the buttons.

     

    I did the iPad first as that was the one I thought I was having the problem with. But it was when I rebooted the phone that actually sorted everything out. Although I'd been updating files on the phone & thought they were workings think it was the phone that wasn't syncing properly. So the iPad was fine, it was getting the most up to date files that were in the cloud; just the phone wasn't syncing. But all solved by the simple reboot!

  • 69. Re: icloud not syncing documents to between new ipad and iphone 4s
    vincas Level 1 Level 1 (40 points)

    Very glad it seems to have worked! What SEEMS to have worked for me lately is making extra room on all iOS and OS devices. A few days ago i noticed I had only about 200 MB space left on my iPhone. I freed up about 2 GB of space, and (knock on wood), seems to have solved the problem. On one hand, of course less flash space would lead to problems, on the other, I wish I had gotten a pop up warning saying that device X is running out of space...

     

    Vincent

  • 70. Re: icloud not syncing documents to between new ipad and iphone 4s
    Cinenance Level 1 Level 1 (0 points)

    Thanks.  This worked for me:

     

    aeberhar said:

     

    "I fixed the problem on the iPhone but [by] going to Settings > iCloud > Documents and Data.  In that screen, I switched off Documents and Data (answering in the affirmative to the subsequent prompt), then I switched it back on. Presto, iCloud documents appeared in Pages."

  • 71. Re: icloud not syncing documents to between new ipad and iphone 4s
    Pixelized Level 1 Level 1 (0 points)

    I had all of the above symptoms, the Pages app wouldn't sync between my iphone 4s and my iPad 3. In addition, iTunes on my MacBook Pro only saw the iPhone on Wifi sync. I performed the two-button reboot on the iPad and iPhone and iTunes eventually recognized both devices. Pages now syncs with both devices and I then performed a sync of both devices in iTunes. Devices are iOS 6.x and MacBook is on Lion.

  • 72. Re: icloud not syncing documents to between new ipad and iphone 4s
    vincas Level 1 Level 1 (40 points)

    hi, how about syncing from the mac to the ios devices? i've had to 'isolate' my issues. in some cases a document created on the mac migrates into ios Pages, but not vice versa. see also what documents migrate into iCloud.com.

    for the wifi sync, try connecting physically via the usb cable, then turn on wifi syncing when they are connected. hope you can narrow down your issue!

     

    vincent

  • 73. Re: icloud not syncing documents to between new ipad and iphone 4s
    Pixelized Level 1 Level 1 (0 points)

    I had no trouble with WiFi sync to either device after resetting them. iTunes on the MacBook at first only saw the iPhone so I believe the problem was in the iPad because once it was reset it immediately showed up in the available devices in iTunes. The pages application automatically synced documents without further effort from me.

  • 74. Re: icloud not syncing documents to between new ipad and iphone 4s
    Alturiak Level 1 Level 1 (0 points)

    I was having this issue with a document in Pages created on my iPad and not syncing with my iPhone. Before this document everything was syncing perfectly. At first I deleted and reinstalled Pages on my iPhone, but that didn't help. I actually only had to restart my iPad to get the document to upload! Hope this works for you...