11 Replies Latest reply: Apr 28, 2014 10:20 AM by wurmstrangler
ron lac Level 1 Level 1 (0 points)

iMac will no longer go into sleep mode


iMac (27-inch Mid 2011), Mac OS X (10.7.4), Sleep mode worked fine when new
  • rkaufmann87 Level 8 Level 8 (49,835 points)

    Please click the More like This link to your right, chances are the solution is in one of the posts with a green check mark.  The green checkmark indicates the thread has been answered.

  • den.thed Level 7 Level 7 (25,110 points)
  • Linc Davis Level 10 Level 10 (169,170 points)

    Test after each of the following steps that you haven’t already tried:

     

    Step 1

     

    ▹ System Preferences ▹ Print & Scan ▹ Open Print Queue...

    Check all printers for unfinished jobs. Deal with any you find.

     

    Step 2

     

    ▹ System Preferences ▹ Energy Saver ▹ Power Adapter ▹ Wake for network access: uncheck. You may need to unlock the preference pane by clicking the lock icon in the lower left corner and entering your administrator password.

     

    Step 3

     

    ▹ System Preferences ▹ Energy Saver ▹ Schedule… ▹ Start up or wake: uncheck

     

    Step 4

     

    Disconnect all wired peripherals except keyboard, mouse or trackball, and monitor, if applicable.

     

    Step 5

     

    Launch the Activity Monitor application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ If you’re running OS X 10.7 or later, open LaunchPad. Click Utilities, then Activity Monitor in the page that opens.

     

    Select All Processes from the menu in the toolbar of the Activity Monitor window, if not already selected. Enter “powerd” (without the quotes) in the "Filter" text field. Select the powerd process and click the Quit Process button in the toobar (stop-sign icon.) In the sheet that opens, click Force Quit. You’ll be prompted for your administrator password. The process will be relaunched immediately.

     

    Step 6

     

    Boot in safe mode and log in. The instructions provided by Apple are as follows:

     

    1. Be sure your Mac is shut down.
    2. Press the power button.
    3. Immediately after you hear the startup tone, hold the Shift key. The Shift key should be held as soon as possible after the startup tone, but not before the tone.
    4. Release the Shift key when you see the gray Apple icon and the progress indicator (looks like a spinning gear).

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Note: If FileVault is enabled under OS X 10.7 or later, or if a firmware password is set, you can’t boot in safe mode.

     

    Safe mode is much slower to boot and run than normal. Don’t launch any applications at first. If sleep still doesn’t work properly, back up all data and reinstall the OS. After that, if you still have the issue, make a “Genius” appointment at an Apple Store to have the machine tested.

     

    If sleep now works as expected, go on to the next step.

     

    Step 7

     

    Still in safe mode, launch the usual set of applications that are running when you have the problem, including your login items, one at a time, testing after each one. Some applications may not work; skip them. You might be able to identify the cause of the problem this way.

     

    Step 8

     

    If sleep is still working after you’ve launched all the usual applications, reboot as usual (not in safe mode) and test again. If sleep still works, you’re done, at least for the moment.

     

    If you still have the sleep issue after booting out of safe mode, post again.

  • SockRolid Level 1 Level 1 (5 points)

    Had the same problem.  iMac (mid 2007, OS X 10.7.4 "Lion") would appear to start sleeping after I pressed the power button, but it would immediately wake again after less than a second. All file sharing off, Wi-Fi off, reset the PMU several times to no avail.

     

    The problem appears to have been caused by my USB hub.  My iMac's keyboard is plugged into a USB 2.0 hub.  I simply pulled the power connector out of the hub for a few seconds, then plugged it back in.  Pressing the power button now causes the iMac to sleep and stay asleep.

  • alexanderfromjar Level 1 Level 1 (0 points)

    I have had this problem since i upgraded to Mountain Lion. Have tried "everything" except your step 4. A USB game controller was apparently keeping the machine awake. Screensaver worked but not sleep. Seems that Mountain Lion is more sensible than Lion to disruptions.

     

    Anyway, you have saved me a lot of energy (both electricity and frustration).

     

    Thanks!

  • darkedge3 Level 1 Level 1 (15 points)

    check internet sharing, under settings>sharing, and disable it...

     

    this problem was driving me nuts until I discovered this, which worked instantly!

  • Jim Busnach Level 1 Level 1 (0 points)

    I've had this problem for a few years, ever since my iMac was new and none of the so-called 'remedies' worked... particularly not calling Apple Care. 

    For a couple of years now, I have been using a little app called Please Sleep which cured it. 

    BUT, occasionally, my iMac still won't sleep. 

    The display will go dark, but heated air still keeps coming out of the vent at the top of the case in back. 

    I have found the solution which involves going into Energy Settings and making the display go dark before the computer goes to sleep.  If they are set to the same number of minutes, then no way will the iMac sleep. 

    I have the computer set to 10 minutes, and the monitor to 15 minutes. 

    Before this, even manually putting the computer into sleep mode (Control / Eject / Sleep) wouldn't make the computer sleep... not even going through all the rigamarole mentioned above and in dozens of other posts.

    And by the way... the only things that I have in Login Items are Android File Transfer Agent, Please Sleep, and SMC Fan Control, and Speech Synthesizer Agent... not dozens of items that might keep the computer awake. 

  • Cliff85 Level 1 Level 1 (0 points)

    I appreciate all the help from the folks replicating helpful suggestions from other posts, I wish they worked on my iMac, but the fact remains, iMacs do not properly go to sleep. If you type iMac into Google the sleep issue will auto populate because this issue is so prevalent. I have a 2013 iMac that will not go to sleep, this Mac has a fusion drive in it, which is great but the HD never goes to sleep when requested, it spins down and spins back up every 10 seconds or so. When the HD dies I have to throw away my $3,000 iMac because you can’t replace them anymore and this is exasperated by an HD that is constantly changing speeds rather than staying constant or turning on and off.

     

    My preferences are set to never let the HD spin down but this is what it does all day long if put to sleep. If I set it to allow the HD to spin down it will for 3 seconds then spin up, then spin down then spin up, this cycle continues eternally.

     

    If I manually put it to sleep it spins up and down every few seconds for days. I make 100% of my money as a graphic designer and I use my iMac for 100% of this. If Apple made a desktop computer that was under 3 years old for pros with USB 3 etc, I would buy one of those. I'm stuck with a consumer level computer that will not go to sleep.

     

    Jim Busnach, thanks for the Please Sleep suggestion, it worked once, which is better than anyting else on this help site.

  • Arafin Level 1 Level 1 (0 points)

    I have had this problem and read many forum solutions, of which there seem to be many. What worked for me was quite simple. Preferences / Sharing / deselect Bluetooth. That’s it. iMac sleeps when I want and stays asleep till I wake it.

  • Arafin Level 1 Level 1 (0 points)

    The first time this happened I de-selected Bluetooth Sharing and the problem was solved. Then I upgraded from Lion to Mountain Lion and the problem came back. After a little investigation I realized that the screensaver had been reset from one hour to 20 minutes. I changed it back to one hour and now the iMac will enter sleep mode either when I tell it to or when the timer tells it to. Hope this helps.

  • wurmstrangler Level 1 Level 1 (0 points)

    The USB hub was the problem for me. Rock Solid's suggestion solved the problem.

    Thanks