12 Replies Latest reply: Mar 31, 2016 3:14 PM by imasutiki
JVS45 Level 1 Level 1

All of a sudden, neither safari nor firefox will open web pages.  However, the computer is connected to the internet.  I have tried the network diagnostic and it says everything is fine.  I have tried turning airport off and on, same with the computer (even left it overnight) and time capsule.  At one point when I turned my computer back on I could get on the web again but the next time I went back to the computer it was the same problem and turning it off and back on did not work that time.  I originally could get on-line with my kindle fire just fine (thus I knew it wasn't my network) but on day 2 when it urned my kindle fire on, it was doing the same thing where it showed that I was connected to the internet but it won't open any web pages.  I've confirmed with other wirless devices though that the internet is working. I can't figure it out, nor figure out why the kindle fire would be affected to (or if that's just coincident and some other issue with my kindle fire, whcih is possible).  I've tried searching the internet and none of the suggestions I've seen for similar problems have fixed mine.  Any help would be greatly appreciated.  Thanks!


iMac
  • BDAqua Level 10 Level 10

    Make a New Location, Using network locations in Mac OS X ...

     

    http://support.apple.com/kb/HT2712

     

    10.5.x/10.6.x/10.7.x instructions...

     

    System Preferences>Network, top of window>Locations>Edit Locations, little plus icon, give it a name.

     

    System Preferences>Network, click on the little gear at the bottom next to the + & - icons, (unlock lock first if locked), choose Set Service Order.

     

    The interface that connects to the Internet should be dragged to the top of the list.

     

    Instead of joining your Network from the list, click the WiFi icon at the top, and click join other network. Fill in everything as needed.

     

    Try putting these numbers in Network>TCP/IP>DNS Servers, for the Interface you connect with...

     

    208.67.222.222

    208.67.220.220

     

    Then Apply.

     

    For 10.5/10.6, System Preferences>Network, unlock the lock if need be, highlight the Interface you use to connect to Internet, click on the advanced button, click on the DNS tab, click on the little plus icon, then add these numbers...

     

    208.67.222.222

    208.67.220.220

     

    Click OK.

    Also, turn off IPv6:

    System Preferences » Network » AirPort » TCP/IP tab » Configure IPv6

     

    Or whatever interface you connect with.

  • Ronald Hasler Level 1 Level 1

    This seems to mirror the problems I am having too with my Intel iMac. (see: https://discussions.apple.com/thread/4106764?tstart=0)

     

    I managed to get my Ethernet connection back but it has been unstable. No definitive path to restoring normal connectivity has been found as several pathways seem to work, including putting computer to sleep, rebooting modems/Airport, and restarting.

     

    What is the significance of those addresses you cite above...?  208.67.222.222   208.67.220.220

     

    TIA

  • BDAqua Level 10 Level 10

    DNS Servers are a bit like Phone books where you look up a name and it gives you the phone number, in our case, you put in apple.com and it comes back with 17.149.160.49 behind the scenes.  

     

    These Servers have been patched to guard against DNS poisoning, and are faster/more reliable than most ISP's DNS Servers.

     

    There are many more if you need.

  • JVS45 Level 1 Level 1

    Thank you for your response. I tried all of those things and my browsers still wont open web pages. It's definitely not the Internet connection. Could it be some virus that affects my browsers? Any other suggestions would be greatly appreciated!!  This is driving me nuts! :)

  • BDAqua Level 10 Level 10

    Open System Preferences>Network>Configure>Proxies Tab, make sure none are set, like for HTTP & HTTPS.

     

     

    10.5/10.6 instructions, System Preferences>choose interface>Advanced>Proxies Tab, make sure none are set, like for HTTP & HTTPS.

    See if you might have this malware redirecting DNS queries...

     

    http://macmegasite.com/node/3924

     

    http://www.ehow.com/how_2128387_remove-osxrspluga-trojan-horse-mac.html

     

    How to fix...

     

    http://www.macosxhints.com/article.php?story=20071031114140862

     

    Get MacScan...

     

    http://www.apple.com/downloads/macosx/networking_security/macscan.html

     

    Malware  list....

     

    How to uninstall MacKeper...

     

    http://applehelpwriter.com/2011/09/21/how-to-uninstall-mackeeper-malware/

     

    https://discussions.apple.com/docs/DOC-3039

     

    http://x704.net/bbs/viewtopic.php?f=6&t=4479

  • thomas_r. Level 7 Level 7
    expertise.macosx
    Mac OS X

    If it's happening with both your Kindle Fire and your iMac, it's likely to be something related to your network connection, not an error or malware on the computer.  It could be a misconfiguration of your router, or it could be a larger problem with the connection provided by your ISP.  Why it wouldn't affect all devices, I don't know.  Perhaps it's a sporadic issue with someone that has gotten cached on those two devices.  This will be a bit of a pain with an iMac, but can you find a way to test it with a completely different network?  Try at a friend's house, for example.

  • JVS45 Level 1 Level 1

    Turns out the kindle fire thing was a fluke.  The next day it was working fine and has been for over a week.

     

    I did move my physical computer into the room where my internet connection is and literally plugged it in to the internet and it works that way...so it has to be either something with time capsule or something with airport.

     

    Thank you for the advice.  If I can get it to someone else's house I'll try that...that should at least tell me if it's airport or time capsule I would think.

     

    Thanks.

  • JVS45 Level 1 Level 1

    So, I managed to fix it.  Once I found that the browsers were open when hard-wired to the internet through an ethernet cord, I just went ahead and re-configured TimeCapsule and started from scratch creating a network.  I still don't know what caused the problem, but at least it seems to be working now.

     

    Thanks to everyone who responded.

  • Tegan. Level 1 Level 1

    Browsers won't open pages, but internet is working perfectly?

     

    I was watching something on Netflix and it started getting choppy, so I tried to fix it by reloading, which didn't work. Then I tried to restart my browser... Now, it just won't do anything.

     

    "Neither Safari nor Firefox will open web pages.  However, the computer is connected to the internet."

     

    I have tried the network diagnostic and it says everything is fine. I have ethernet. I've run about seven different anti-virus softwares on it and can't find anything. I did the reboot, disk utility, set up a new address... Time Machine didn't work either.

     

    I was told I might have Google Redirect Virus or some other rootkit.

     

    Nothing I did fixed the problem, even temporarily.

  • diveactive Level 1 Level 1
    expertise.quicktime
    Quicktime

    Im have the same problems,   This link would not openRe: Browsers won't open webpages but internet connection is fine   had to past it into Chrome . fire fox has trouble too and Chrome also. it just gets worse as i try to fix things , been on here in another forum trying to fix it, Gone round in circles.

     

    getting me down as have dead lines for work. Router and internet are fine as the wife and two others are using it , no problem  PC or microsoft and galexy note not affected.  . 

  • gigicomp82 Level 1 Level 1

    If people are still having trouble, I got tech support help and easily fixed the issue.  I had tried flushing DNS, clearing cache, creating a new profile, etc.   Nothing worked.  Tech support helped me fix this in about 5-10 minutes (including wait time) by rebuilding the WI-FI network.  I have a 2011 MBP running Yosemite 10.10.5.  Here's what he had me do:

     

    1) Open System Preferences

    2) Select Network

    3) Select WI-FI in on the left column

    4) Click on the minus icon at the bottom of that column

    5) After current WI-FI is deleted, click the plus icon on the bottom of the same column

    6) Under the Interface pulldown menu that pops up, select WI-FI

    7) Click the Create option

     

    That was it!  I can't be certain that the other things I did didn't contribute to it working, but it seems it was as simple as rebuilding the network.  Also, the computer seems to be running faster now, so a little bonus for my hassle   I hope this helps someone else!

  • imasutiki Level 1 Level 1

    Thanks so much! This help me. Using OS X El Capitan version 10.11.4. Followed your instructions. At one point was asked how I connect to Wi-Fi and I checked airport which was correct.