2 Replies Latest reply: Jul 16, 2012 12:28 PM by nramsay
nramsay Level 1 (0 points)

I am using the airport express to channel music to the stereo using using airplay running on an iPad 2.

 

I have two routers, one (principal) connected to the ADSL modem and the other configured as a wi-fi repeater (ASUS terminology) which, basically, extends the network.  Both routers are configured with the same SSID, security and passwords.

 

The airport express is configured to run in client mode (i.e. to connect to an existing network). It automatically connects to the repeater router since it is nearer and has a stonger signal.

 

When the iPad is closer to the repeater router, everything works fine. I can play music on the iPad and stream it to the stereo using airplay. However, when the iPad is nearer to the principal router (which it automatically connects to because the signal is stronger), it cannot see the airport express and I cannot stream to the stereo using airplay.

 

It is as if airplay / airport express is treating the two routers as separate networks although their configuration is identical (in fact, the repeater has few setup options).

 

Questions:

Is there any way to overcome this limitation (which seems to be that airport express is only available over one hop in the network)?

Would it work better if, for example, the repeater and principal routers were both ASUS?


airport express
  • thomas280 Level 1 (0 points)

    So the iPad will connect to the strongest signal it can find from the network. If you have 3 routers on the same network, and you can see the air AirPort Express when you're close to it and AirPlay to it, but the same doesn't happen when you're closer to a different router, then it sounds like the middle router (or first) is blocking ports. Check the 1st and 2nd router and unblock ports 80, 443, 554, 3689, and 5353 per Well known TCP and UDP ports used by Apple software product

  • nramsay Level 1 (0 points)

    Thomas,

     

    I have checked the configuration of the two routers. I can't see any settings that would block ports (in fact, I can't find any settings that even mention ports). Most security settings (apart from WPA2 Personal) are unchecked. I tried disabling the SPI firewall to no avail.

     

    Do you have guidance about which settings could be used block ports?

     

    Do you think it would be worthwhile to see if the problem goes away if I disable all security for the routers?