0 Replies Latest reply: Jul 17, 2012 11:03 AM by NeedForSpeed73
NeedForSpeed73 Level 1 Level 1 (0 points)

Hello, I've just upgraded my 2011 11" MBA to a 2012 mainly because of the USB 3.0 support on the newer machines, provided that i work with virtual machines stored on a Lacie Rugged USB 3.0 external HDD that i share between my Macs and my PCs.

Now I'm quite upset because plugging the Lacie drive into my brand new 2012 MBA, it gets recognized fine but works at USB 2.0 speed (30MB/s from all benchmarks) and System Profiler (or Sytem Information? My OSX is in italian so i'm translating to english) shows the Lacie disk as connected to the "High Speed USB Bus", leaving the "Super-Speed USB Bus" empty.

The cable I'm using is the same I use to connect this disk to my Sony Vaio with which it works fine as USB 3.0. I've updated the MBA and also tried the Lacie Firmware Upgrade Tool to update the disk too; tried to reset PRAM too with no luck. Still at USB 2.0 like the old 2011 MBA! Did I waste 1000€?

Thanks in advance to anyone for the help!


MacBook Air (11-inch, Mid 2012), Mac OS X (10.7.4)