11 Replies Latest reply: Apr 2, 2014 12:26 AM by MYMMSM
tyler82 Level 1 (0 points)

I have been using the magic mouse for about a year now and have noticed something very annoying. At times, the magic mouse will act very sporadically. If I move the mouse, the cursor on the screen does not correlate precisely with the mouse position, but will jump wildly in certain positions and can be impossible to reach a pinpoint position on the screen, such as closing a window with a small close button. It is like it is stuttering. The only solution is to restart my computer, then the mouse will work fine for a while, but after a few days will be back to its old habits.

Having to quit everytihng that is open and restart my computer is not an option any longer for me.

I am using Mac OS 10.7.4 and a MacBook alunimum unibody 2008.

 

Please help!

  • Barry Hemphill Level 8 (37,327 points)

    Hello:

     

    Try a couple of things (intermittent problems are sometimes hardware-related, of course).

     

    Reset the SMC and PRAM.

     

    If that does not help, delete the device, restart the computer, and let the assistant find it again.

     

    Barry

  • tyler82 Level 1 (0 points)

    Thanks, I deleted com.apple.bluetooth.plist and reset the pram. Hopefully it works out in the end!

  • tyler82 Level 1 (0 points)

    Nope, didn't work. Still acting up.

    I forgot to mention, I have my MacBook connected to a 27" LED Cinema Display. I have read on other discussion boards that the Mini Display Port can cause the Magic Mouse to act up like this, for some weird reason. Apparently there is a shielding problem and some people have been using tin foil?

     

    https://discussions.apple.com/thread/2445439?start=45&tstart=0

  • captfred Level 7 (26,290 points)

    tyler82,

     

    Bluetooth and wifi can conflict with each other because they both use the 2.4Ghz band.  Another way to fix the problem is to change your Wifi to a lower channel like 1-3 or to change to the 5Ghz band.

     

    http://support.apple.com/kb/HT1365

  • Barry Hemphill Level 8 (37,327 points)

    Apparently there is a shielding problem and some people have been using tin foil?

    News to me...tin foil shielding sounds like something out of a science fiction book. 

     

    Try something else.  Delete the mouse (system preferences).  Turn it off.  Restart your computer, turn the mouse on, and let the assistant discover it.

     

    It is always possible that the mouse is failing, of course.

     

    Barry

  • tyler82 Level 1 (0 points)

    Great advice re: bluetooth and 2.4ghz wifi. I read about that the day before you posted that and hopefully staying exlusively on my 5ghz airport band will help.

    I deleted the mouse from bluetooth, restarted, and rediscovered the mouse. I bought it on Aug. 2, 2011, so I have a week left to see if it still acts up and whether it is a hardware problem

  • Slim G Level 1 (0 points)

    Try the following as it resests the tracking and lag issues for the magic mouse:

     

    Open terminal and type in: defaults write -g com.apple.scaling (choose any number between 2 and 8)

     

    Restart your mac and it should be sorted.

     

    Let me know if it works as it worked for me.

     

    Regrds.

  • tyler82 Level 1 (0 points)

    It's been 3 weeks so far and not one Magic Mouse lag or stutter after keeping my WiFi on the 5GHz band. Wow.. thank you!

  • captfred Level 7 (26,290 points)

    Great news!  Glad to help. 

  • jarrodmakesvideos Level 1 (0 points)

    hey thanks for the terminal tip! this worked perfectly and instantly for me!

  • MYMMSM Level 1 (0 points)

    Having very similar problems.  I reset my wifi to 5ghz and selected channel 2 for the 2.4ghz.  No luck.  I have tried to delete the mouse, however, the minus sign is not activated until you deselect the mouse in system preferences/Bluetooth, by clicking the gear tooth symbol.  Once deselected, you can't use the mouse to click the minus/delete button.  How do I use the keyboard to delete the mouse in order to re add it.  Thanks