Skip navigation

TS3499: Portables: L-shaped MagSafe power adapter does not charge computer and LED indicator light does not illuminate

Learn about Portables: L-shaped MagSafe power adapter does not charge computer and LED indicator light does not illuminate

TS3499 2007MBP, L-shaped adapter, and a firmware update that didn't work.

521 Views 1 Reply Latest reply: Jan 20, 2013 12:05 AM by schaudry RSS
keads Calculating status...
Currently Being Moderated
Jul 17, 2012 4:27 PM

My replacement L-shaped adapter worked for a day on my 2007 MacBook Pro, then stopped abruptly. I've tried the SMC reset as well as the firmware update. When I tried the latter, I received an alert that my computer does not need the update.

 

Please help me! This is driving me crazy. The only answer I can get online is to install the firmware update, but it refuses to install. I'm assuming that means I already have the update. What's the next step for someone in my situation?

 

I appreciate any help you can give me.

MacBook Pro, Mac OS X (10.6.8), Purchased in Jan. 2007
  • schaudry Calculating status...

    Were you ever able to get a resolution to this? I have an 2007 MBP 17" and bought a new adapter that stopped working after 2 weeks. I bought a brand new one today, it charged the battery to about 90% and then went dead. Now the LEDs won't turn on and it will not charge or power the computer. I think the issue is with the laptop but have no idea what it could be. Has anyone heard of this before or have any ideas on how to troubleshoot/fix this? I've checked the SMC firmware to make sure it is up to date, i've reset the SMC. i've left the adapters unplugged for a few hours....nothing has worked. Please help...

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.