3 Replies Latest reply: Jul 18, 2012 5:28 AM by mende1
Warrd.Habib Level 1 Level 1

i have a problem with my ipod touch it is an ipod touch 3rd generation ipod that is 8gb and it still is 4.2.1. i want to update it to the newest version (5.1.1) but every time i click on update on itunes it says that my ipod is updated to the newest version?? my sister has an ipod 3rd generation but hers is 32gb and i think that they count it as an iphone because the summary on itunes has the picture of an ipod touch 4th generation soo i am confused i dont know what i am suppose to do how do i get my ipod updated to the newest version if you have the same problem and found a way to solve it please help me by sharing your ideas that would be very helpful of you. Thanks!!


iPhone 3G, ipod touch
Solved by mende1 on Jul 18, 2012 12:41 AM Solved

Welcome to Apple Communities

 

You have a 2nd generation iPod touch. You can use iOS 4.2.1