Previous 1 2 Next 17 Replies Latest reply: Dec 5, 2012 8:14 AM by Scotty-H Branched to a new discussion.
agodfrin Level 1 Level 1
Mac OS X

Can someone clarify / confirm the way mail "redirect" works ?


Here is what just happened to me. Last week I had sent a notification to a list of correspondants. Today I had to send the same notification, with a few corrections to another correspondant. So I used the redirect method.


I then got a window with the original email, with empty TO: and CC: boxes. I made a few changes in subject and content, filled in the new recepients (TO and CC) and sent the mail.


Then the receiver replied asking why I had sent the mail to that list of other correspondants that I had sent the original email to.


When I checked my received copy of the mail (I always ask for a BCC copy of all mails I sent) as well as the copy in the SENT folder, I saw that both still had the full list of the original recipients. The mail headers look like this:


Resent-From:      (my email)

From:             (my email)

Subject:          (new updated subject)

Date:             (Original date)

Resent-To:        (New recipients)

To:               (Original recipients)

Resent-Cc:        (New CC recipients)

Cc:               (Original recipients)


Can someone confirm that the email was actually resent to the original TO and CC lists as well as the new recipients? I think it did not since I did not hear from any of those recipients about that mail, but I would like to be sure that the redirected mail is ONLY sent to tne NEW recipients (not the old).


The other concern (even if that mail was not resent) is that the new recipients are able to see the original recipients. They should not have been able to see them.


Finally, the mail was sent using the original date, not the new date. This makes the email look like an old mail.


I was actually thinking that the REDIRECT function worked like the "EDIT AS NEW" function in Thunderbird which allows me to take any email and modify it (including recipients and content) as a basis for a new mail, with all traces of previous recipients removed.


Finally, is this the way redirect is expected to work ?





MacBook Pro, Mac OS X (10.7.4)
Reply by thomas_r. on Jul 18, 2012 9:59 AM Helpful
If it's a message you sent, use the Send Again feature.  Select the sent message and press command-D, or choose Message -> Send Again.  (Or something like that...  I'm on my iPad currently, and giving that advice from memory, which could be flawed.)

All replies

  • thomas_r. Level 7 Level 7
    Apple Watch

    Redirect is meant to send the message on in such a way as to appear, unless the headers are examined, as if it was sent directly to the new recipient(s) by the original sender, without going through you first.  It is not meant to be used as an "edit as new" function.

  • agodfrin Level 1 Level 1
    Mac OS X

    Thanks Thomas.


    In my case, I am the original sender, so both the original and redirected mail should come (and do) come from me.


    I also did a quick test. It shows that when I redirect a mail, it is ONLY sent to the new recipients (TO and CC and probably also BCC). It is NOT sent to the original recipients, even though the original recipients are still in the TO: tag of the message header. The new recipients are in a RESENT-TO: tag.  Here is an example.


    Return-Path: <xxxxx>

    Subject: Testing redirect 2

    Mime-Version: 1.0 (Apple Message framework v1278)

    Content-Type: multipart/alternative; boundary="Apple-Mail=_5EA32528-66C5-4884-9890-16FAF7275242"

    From: <xxxxx>   This is the original sender

    Resent-From: <xxxxx> This is the "re-sender" (both are the same in my case)

    Date: Wed, 18 Jul 2012 17:38:21 +0200

    Resent-Date: Wed, 18 Jul 2012 17:39:32 +0200

    Resent-To: <xxxxxx> This is/are the new recipient(s)

    Message-Id: <xxxx>

    To: <xxxxx> This is/are the original recipient(s)

    X-Mailer: Apple Mail (2.1278)

    X-Source-IP: []

    Content-Length: 4353


    So the only issue is the presence of those original recipients. Depending on the mail client used, the new recipients may or may not see those. Most seem to show the original recipients only, not the "resent" recipients. So at the end this is confusing.


    I did some more searches in the forum. I found one that says that this was reported as Apple Bug #6468751 that was then fixed in MacOSX 10.6. But 10.7 (Lion) seem to still have the problem.


    Lesson learned: i will stop using the redirect method when I need to modify and resend an existing mail. But I can see it is a simple way to spoof mail: make believe that a mail comes from and goes to different recipients than the real sender and receiver.



  • crampy Level 4 Level 4

    That sounds so complicated.

    I forward, and highlight and erase the previous addresses, and in subject line remove "re" and forward.

    Or start a fresh email page, then open the item to forward, and highlight the copy you want to send, click and drag to the new email and send...this will look like a brand new email, and no hints of previous readers or recipients...

  • thomas_r. Level 7 Level 7
    Apple Watch

    If it's a message you sent, use the Send Again feature.  Select the sent message and press command-D, or choose Message -> Send Again.  (Or something like that...  I'm on my iPad currently, and giving that advice from memory, which could be flawed.)

  • agodfrin Level 1 Level 1
    Mac OS X

    Thanks, Thomas. That looks pretty much like the "edit as new" in thunderbird.


    It is actually shift-command-D. Works like a charm.



  • joyss Level 1 Level 1

    Mine is a different problem.  My Fat Cow mail account was hacked and I had to change my password.  In Mac preferences, I went to Mail - account summary and put in the new Fat Cow password so that its mail could again be forwarded to my Mac mail.  It didn't work.  What can I do?  Thanks. JoyceL.

  • crampy Level 4 Level 4

    hello Joyss: if this does not work, I suggest you start a new question and folks will answer.

    When you put in the new password, did you get asked by computer "want to save changes?" and if so  did you? If not, the password was not entered. Are you SURE the incoming and outgoing mail servers are correct? And in mail>preferences>advanced- do you have Authentication selected as password?

  • joyss Level 1 Level 1

    Hi Crampy

    No, I never received a memo asking me to save changes.  I also went back to FatCow to ask about the problem. Fatcow does not accept the new password unless I retype it in.  This may be part of the problem. Also, they are not Safari literate. I guess they're not looking at Apple stock prices.


    The incoming and outgoing mail servers are those I always used for Fatcow.

    Authentification is password.


    I am thinking of changing the password again. What do you think?  Thanks.

  • crampy Level 4 Level 4

    Well, you said to me what the problem, without intending offense. I would get a different mail than "fatcow" (never heard of it). What I do, in addition to the cloud, I use my ISP. They offer as part of the package mail, so I have a webpage and I set my mail in computer to retrieve, but I leave on server in case I delete prior to seeing all I want.. and delete at the webpage.

    If your cow thing refuses your password at the webpage, then they are a bad site, or you are doing typo when entering your password (I did that once... only when I typo'd would I get in...then I got to switching it and entered VERY carefully).

    Sorry I have no cure.

  • crampy Level 4 Level 4

    OK just for fun...Openmail pref>accounts>select the troublesome account.

    In the outgoing mail server bubble at bottom of pane, there are up and down arrows- see them? Click and hold and go down to edit  outgoing mail server.

    MAKE SURE YOU CHECK THE OUTGOING SERVER TO YOUR FAT COW ACCOUNT, and then click sure and then back at the accounts page, select USE ONLY THIS SERVER.

    Now, go to the cloud account last and do the same thing...if iCloud(iCloud) has vanished, enter it by hand, then again, check yes, exit then at the reg page, check USE ONLY THIS SERVER.

    Why do iCloud last? I noticed mine then interrupts a send from cloud with hey there is no server selected- and then you may THEN select it..but i prefer to avoid interruptions...

    Other than that, I am out of ideas

  • joyss Level 1 Level 1

    I don't have iCloud.  I had already cliced on  USE ONLY THIS SERVER in mail. Thanks.

  • joyss Level 1 Level 1

    FatCow is the web host that got me my website name and helped me create it.  One of the things they offer is an email account with my website name.  I've used them for about 8 years with no problem.  It all started with someone trying to hack my email account and having to change the password.  I'm going to change my password again and see what happens. (*_*))

  • crampy Level 4 Level 4

    Hmmm, I wonder if the hacker is resetting your password also? ACK.

    I hope he cannot get into your website....especially if it is business.

    As to the checking use this server only- just checking it will mess things up, if you do not use the sequence I described, as you HAVE to make sure the server you check is the server to the email address you want it to be.

  • thomas_r. Level 7 Level 7
    Apple Watch

    Try removing that password from the keychain.  Quit Mail, then open the Keychain Access app (use Spotlight to find it), find the right password and delete it (select it and press delete).  Then re-open Mail and try putting in the new password again when asked for it.  If that doesn't work, you'll probably need to contact Fat Cow support.


    Also, a couple notes... first, the original question had nothing whatsoever to do with the problem you're having.  In the future, you would do better to start your own question for this kind of thing.  What's going on now is called threadjacking, and it is frowned upon, as it can seriously disrupt a conversation, preventing the original poster from getting his question answered.  I'm sure you were not aware of this, but it's something that you need to become aware of for the future.


    <Edited By Host>

Previous 1 2 Next