Previous 1 2 3 4 Next 48 Replies Latest reply: Jan 12, 2016 8:05 PM by madmu5icjunky
Victoria Herring Level 2 (290 points)

I have a MacPro and 4 drives inside it, one of which I need/want to erase.  I have backed it  up and using DU tried to erase it = by both highlighting the drive identifier and the name - in both cases, whether I try to erase disk or set it to erase to one partition, I get a message saying it can't do it because it can't unmount the disk.

 

I backed up my startup drive to this drive so I could wipe and reinstall OSX on my new SU drive but now I can't delete items off the backup drive [the one I want to erase] because the message says I can't delete backup items.  And I can't erase the drive to get a brand new drive to work with.

 

I don't need the old SU material on this drive, it was just a way to be sure I had it before using Migration Asst to reinstall the SU on the new SU drive = I used SuperDuper to clone the old SU onto this drive - then I used Migration Asst to move the stuff back to the new startup drive = but now I want to EITHER get rid of the system files and apps [no need for those = I don't min


Mac OS X (10.7.4), iPad and iPhone4
  • macjack Level 9 (51,639 points)

    Are you booted from the drive you are trying erase?

  • Linc Davis Level 10 (192,679 points)

    Boot into Recovery (command-R at startup) and erase the volume.

  • Victoria Herring Level 2 (290 points)

    No i am not booted into that drive but the idea of the Recovery drive to wipe it sounds good = thanks much.

  • Victoria Herring Level 2 (290 points)

    Just reporting back that I rebooted into Recovery [held Option key down at startup and chose the Recovery HD] and it did what I needed...thanks much

  • niccodeamus Level 1 (5 points)

    I realise that you have solved this problem, but I have solved a similar issue differently. 

    It appeared that the external drive would not unmount because some activity was using it.  fsck_hfs process was working away as shown by activity monitor.  It seems that Spotlight was struggling with a the failed drive and would not let it go so the unmount and erase could not occur.

    This was solved by disabling Spotlight (terminal: sudo mdutil -a -i off) temporarily.  After disabling Spotlight, Disk Utility performed its job and my corrupted drive was restored to use.

     

    (Spotlight is turned back on with: sudo mdutil -a -i on)

  • Kajoneslaw Level 1 (0 points)

    Thanks that terminal advice was spot on.  I even set a one-on-one session and we could not figure it out.  Thanks!

  • RichardHuman Level 1 (0 points)

    Made an account to say that was just what I needed to assist with an external drive I was trying to erase.  Thanks niccodeamus!

  • marcfrombenfleet Level 1 (0 points)

    Logged into my old account to thank niccodeamus, big help! Thought I was going to have to buy a new external!

  • fineartist99 Level 1 (0 points)

    I tried the terminal option but I still got this error

     

    Partition failed with the error:

     

     

    Couldn’t unmount disk.

     

    Is my only option to "Boot into Recovery (command-R at startup) and erase the volume." ?

  • genemachine Level 1 (0 points)

    Had a similar issue, The drive would not unmount in disc utility to be erased, disk warrior could not even see it.

     

    I used the sudo command that niccodeamus suggested, I also forced quit the fsck_hfs process, my drive then began to erase without issue

     

    Thanks

  • desbrisay Level 1 (5 points)

    Thanks for the above info!

     

    I had a similar problem, Disk Utility would not erase and reformat my external disc and complained about being unable to erase the external disc.

     

    I tried disabling Spotlight as described above, but that didn't fix the problem.

    I then searched for an fsck process:

     

         ps -ax | grep fsck

     

    and then killed that process:

     

         sudo kill <process number>

     

    Problem solved!  Disk Utility then successfully erased and reformatted the external drive!

     

     

    Many thanks for the clues that led me to this solution!

  • robot3021 Level 1 (0 points)

    excellent advice desbrisay when combined with what niccodeamus suggested. Was about ready to thromw WD My Book Studio through the window until I found this (My Book failed to unmount when erasing or partitioning)

  • taramaple Level 1 (0 points)

    Thanks so much this worked!!!

  • eplt@odw Level 1 (5 points)

    I had similar problem, can't unmount easily.

     

    Ending up connecting the disk as a target disk (holding T key on startup) connected to another Mac.

     

    Then using terminal, used the following commands to force unmount disk and erase the disk after.

     

    To check for the exact name of the disk:

    sudo diskutil list

    (you will see the list of drives/partitions, take note of which one is the one you are trying to unmount/format, should be something like /dev/disk<number>)

     

    Then to force unmount disk:

    sudo diskutil unmountDisk force /dev/disk<number>

     

    You should get a response to the success or failure to the unmount command.

     

    Then if you want to format force format the disk:

    sudo diskutil erasedisk JHFS+ Untitled /dev/disk<number>

Previous 1 2 3 4 Next