3 Replies Latest reply: Jul 19, 2012 12:50 AM by Ramón G Castañeda
David Medley Level 1 Level 1 (0 points)

I want to update my software to leopard 10.6 but it said I don't have Intel based.  What does that mean?  Why wouldn't I be able to update from leopard 10.5 to 10.6?