12 Replies Latest reply: Jul 6, 2014 4:37 PM by Charles Whitmer
alexsubrizi Level 1 Level 1 (0 points)

Mid-2011 13" Macbook Air (4,2), new USB Superdrive (vendor ID 0x05ac) all software up to date (OS X 10.7.4, etc) and about one out of every 10 CDs hangs my Superdrive, meaning I can't import the disc's music into iTunes. By "hangs" I mean that the tracks are displayed correctly, but then the drive seems to hunt repeatedly when the import is underway. The progress bar on the first track never goes anywhere, and after a few attempts (have to put my ear close to the Superdrive to hear it hunting) the disc ejects and the error message reads "Error occured while importing the file <name of second track>. The required disk cannot be found." Note that at this point the first track hasn't been imported either, but it names the second track as the "problem".

 

My guess is the problem is the Superdrive, since the last two discs that gave me this problem were brand new and play fine in an audio CD player. Also I get the same error message if I just yank the Superdrive's USB cable while it is hunting for that first track during import. My question is do I just have a lemon Superdrive or are all recent USB Superdrives behaving this way, in which case buying a new one will land me in the same frustrating place? Anyone else experiencing problems like this?

 

Thanks!


MacBook Air, Mac OS X (10.7.4), iTunes 10.6.3, USB Superdrive
  • 1. Re: USB Superdrive hangs on audio CDs
    FranksWildYears Level 1 Level 1 (0 points)

    I've exactly the same problem! Seems to be happening with more than one in ten though.

  • 2. Re: USB Superdrive hangs on audio CDs
    Growing-Apps Level 1 Level 1 (0 points)

    Hi, same problem here... I've a MBP with Retina and an AIR Super Drive.

    The problem in my case is limited to CD related to Warner Music Group.

    The same CD works perfectly with previus MBP (2009 to 2012).

    iTunes detect the tracks but can not play (or rip) the CD.

    Thanks!

  • 3. Re: USB Superdrive hangs on audio CDs
    SeanFearon Level 1 Level 1 (0 points)

    I've been getting this problem aswell, predominantly with Warner Music releases, but also from companies such as Nonsuch and Reprise. Do you think it could be a problem that will get fixed by iTunes 11 or would it be with the hardwear its self?

  • 4. Re: USB Superdrive hangs on audio CDs
    sindova Level 1 Level 1 (0 points)

    Same problem with new re-editions of Warner and Atlantic.

  • 5. Re: USB Superdrive hangs on audio CDs
    Bentheboatman Level 1 Level 1 (5 points)

    I have been on to apple about this, by phone, no solution has been found, and no courtesy call.  I went to the apple store, and they had an older model Superdrive for store use it loaded up Warner CDs no problem.  The Store gave me another Superdrive (new model) which I took home and tried, but the problem remains.  The Superdrive is clearly faulty.  I have just rung apple again, no solution was given.  I am coming to realise that apple are not as good as they once were, a fat cat company in complacency.

  • 6. Re: USB Superdrive hangs on audio CDs
    Growing-Apps Level 1 Level 1 (0 points)

    For the one interested in another thread... (without solution unfortunately)

    Best regards...

    https://discussions.apple.com/message/20473944?ac_cid=op123456#20473944

  • 7. Re: USB Superdrive hangs on audio CDs
    fljoshua129 Level 1 Level 1 (0 points)

    Anyone heard from apple on this one? Mine started acting up today. Imported a couple of cds on atlantc and it was fine, then the third cd, also atlantic caused this problem and evey other cd I tried to import after. It frustrates me that we have been able im import or burn cds for years now. It is a simple technology compaired to some of the amazing products and programs that we use within our macs, yet apple seem to have had this problem and other similar problems for a long time

  • 8. Re: USB Superdrive hangs on audio CDs
    GP81 Level 1 Level 1 (0 points)

    I have been having this problem ever since I got my new iMac and have to use a Superdrive. Certainly more than one in ten and I had put it down the new "improved" iTunes which I personally hate but it seems to be the Superdrive iMac combination.

    Nothing from Apple after this thread starting nine months ago. I guess they just want everybody to download music from iStore

     

    G

  • 9. Re: USB Superdrive hangs on audio CDs
    Fishcrash Level 1 Level 1 (5 points)

    I too have found similar problems with my new iMac (Late-2012 27") and USB SuperDrive (A1379) combo.

     

    Reading the posts (and the several other threads on this topic as seen in the "More Like This" list on the top right of this page), the Warner/Atlantic observation panned out - indeed my problem CDs were all Warner Music Group, including a couple that were UK based labels that doing a quick search revealed were ventures with WMG. And these were over a wide period of issue, so not likely to be some sort of CD manufacturing glitch.

     

    I found that I didn't get error messages, the drive would keep looping around noisily, and iTunes would stop responding. Had to Force Quit iTunes and wait for the SuperDrive to calm down and stop, before ejecting the offending CD.

     

    I suspect there is some encoding/DRM/watermark(?) 'special' feature in Warner CD imprints that the current models of SuperDrive can't handle.

     

    My money is on a firmware fix being needed to solve this as earlier models of SuperDrive (admittedly internal ones) work fine with the latest OSX and iTunes combo.

  • 10. Re: USB Superdrive hangs on audio CDs
    Pmania Level 1 Level 1 (0 points)

    I bought the new gen SuperDrive to use it with my late 2012 iMac. I have ripped quite a few CDs of mine but today I decided to rip two compilations - Enya - Only Time (The Collection) and Ray Charles - The Complete Atlantic Recordings. Unfortunately the first collection is released by Warner and the second by Atlantic and yes both of these failed to rip properly - the Warner one has a distorted sound and the Atlantic one skips constantly. There is obviously a problem with the new SuperDrive  and it turns out I can't rip my original CDs so I have to illegaly download them which is absurd. Any solution for this?

  • 11. Re: USB Superdrive hangs on audio CDs
    RPSea Level 1 Level 1 (0 points)

    Exactly same problem with 2012 iMac and new 2012 Superdrive--except that it has occurred on Random House Audiobooks.  The problem occurs only on the last and/or second-to-last cuts on the CD. 

    How about it, Apple?  Do I really need to go to the trouble and take up your time at the local Genius Bar?

  • 12. Re: USB Superdrive hangs on audio CDs
    Charles Whitmer Level 1 Level 1 (0 points)

    I had the same thing happen and thought it was a Roxio Toast problem. I figured out that it was my 10 month old Apple Superdrive and replaced it with a MUCH less expensive LG slim portable dvd writer and the problem was solved. It "only" took about 20 CD's to figure out that the problem was the disc drive and not the discs, not Toast, and not my 2013 MacBook Air. I can't believe what's happening to Apple's quality reputation.