13 Replies Latest reply: May 20, 2013 7:39 PM by dbocks
Jdem Level 1 Level 1 (10 points)

I have Googled, BING'd and otherwise searched the heck out of this error and to my knowledge, its only ever showed its head in Germany!

 

Anyway, since there does not appear to be any tangible or viable information on this in English anywhere, I thought I would share my findings with everyone here. On a whim, I ran a Hardware Test on my new r-MBP. I say on a whim because I had no problems but had read of other's issues.

 

The test returned the error 4SNS/1/40000001:IDOR-0.000. I called Apple Care and they had "no idea what that error is" so they made a genius appt for me. Before I drove the 70 miles to my nearest Apple store, I decided to run the test again with the power connected (IDOR-0.00)...you guessed it, no more error.

 

 

Bottom line, Hardware Test Error: 4SNS/1/40000001:IDOR-0.000 = No power connected.

 

Maybe not earth shattering, but it should save some of you who get the same error from getting nervous.


MacBook Pro (Retina, Mid 2012)
  • 1. Re: 4SNS/1/40000001:IDOR-0.000
    .dark Level 1 Level 1 (65 points)

    xD glad it was all worked out jdem good information to know didnt even know there was an error code for power not being connected.

  • 2. Re: 4SNS/1/40000001:IDOR-0.000
    Jdem Level 1 Level 1 (10 points)

    Thanks .dark, I'd be lying if I said I wasn't nervous at first!

  • 3. Re: 4SNS/1/40000001:IDOR-0.000
    mlynch16 Level 1 Level 1 (0 points)

    Thanks for this post.  I just did the test on a whim as well and got this error.  You saved me a lot of stress!

  • 4. Re: 4SNS/1/40000001:IDOR-0.000
    Shanefrommi Level 1 Level 1 (0 points)

    I called apple about this same problem and they told me that it was sent DOA. They sounded pretty certain that my Retina MBP was dead on arrival. So I just set up a refund and bought a new one.

    The reason I called is because my MBP was going really slow, and sometimes the usb wouldnt work correcty. I was getting download speeds of 3mbps. Not write speeds. My bottom of the barrel Toshiba picks up 20 mbps download speeds in the same excact room. My 2.4GHZ MBP isnt much slower. But now that Ive seen your post I wonder if AppleCare was incorrect. When I retested it with the power pluged in it came up with no errors.

    Now im worried. Im still getting a new one, but I dont want to have to return that one too. If there really is nothing wrong with my computer I guess I just dont want it. I got to say I really hoped for better speeds. All of my software is up to date. I have the base model with 8GB memory, but I dont use any memory intensive apps.

    Any help would be appreciated.

    Thanks

  • 5. Re: 4SNS/1/40000001:IDOR-0.000
    bacardiconlimon Level 1 Level 1 (0 points)

    I took the MBPr to the apple store and even with the computer plugged the error still appear.

  • 6. Re: 4SNS/1/40000001:IDOR-0.000
    Jdem Level 1 Level 1 (10 points)

    What was the outcome?

    If you saw this specific error with a power supply attached then you may have a defective power supply. Did you plug it into their ps or yours?

    Did you try it with a different PS?

  • 7. Re: 4SNS/1/40000001:IDOR-0.000
    bacardiconlimon Level 1 Level 1 (0 points)

    They wanted me to leave the MBPr with them and replace the logic board. I tell you what no apple personnel knew what this code even meant and to me that was very frustrating. Apple never left a list of error codes for their employees. I decided to reorder a new one. When I got my second MBPr I started it up and did the test and the same error code appeared again. I sent it back and awaiting for my refund. Bottom line there shouldn't be an error code on a $2,500 computer period! In addition, Apple should have the list of codes and what they mean to all Apple employees to avoid customer frustration.

  • 8. Re: 4SNS/1/40000001:IDOR-0.000
    Jdem Level 1 Level 1 (10 points)

    You are absolutely right, there should not be the volume of issues people seem to be experiencing with this machine. I think some of it is hysteria to a degree, especially with regard to the Image Retention thread where people are searching for something to be wrong...but a lot of people are finding legitimate issues with these machines...issues that should not be happening with such frequency on such an expensive computer.

     

    I think at the end of the day though we may be in the minority here as most people that come here start out with a problem in the first place. I wonder how many thousands of these have shipped and are problem free. Just a thought.

     

    I am sorry you had bad luck with this, hopefully with the next iteration they will work out the kinks and you can try again. It really is a great computer when it is a good one.

  • 9. Re: 4SNS/1/40000001:IDOR-0.000
    NunoPinto Level 1 Level 1 (0 points)

    Thanks for this post.  I just did the test on my mbp as well and got this same error.  You saved me a lot of stress.... precious information!

     

    Best regards[]

     


  • 10. Re: 4SNS/1/40000001:IDOR-0.000
    danprime47 Level 1 Level 1 (0 points)

    Exactly the same thing happened here.  I just set up my new RMBP and had been having some issues with the black screen.  Ran the Hardware Test on battery, got the error, just re-ran it plugged in, no error.  Running the test in extended mode.  Will see what it comes up with.

     

    Oh and between resetting PRAM and running the Disk Utility, I seem to have whipped the problem with the black screen.  Still think I will keep my appointment with the Geniuses this evening, though.  Just to be safe.

  • 11. Re: 4SNS/1/40000001:IDOR-0.000
    CraigB1960 Level 1 Level 1 (0 points)

    Bought my MacBook Pro yesterday, ran the Apple test this morning and got the same error: 4SNS/1/40000001:IDOR-0.000.  Ran it again with the power adapter connected and got no error.  Running the extended test now (though not connected to the power adapter.), it will be interesting to see if it fails with the same code.

     

    I imagine that this test does look for power input, but it should state to be sure to connect the power adapter before running the test.

     

    No other issues with this computer.  I switched from Windows and really like this Apple and Mountain Lion OS.

  • 12. Re: 4SNS/1/40000001:IDOR-0.000
    CraigB1960 Level 1 Level 1 (0 points)

    As a follow-up, the extended test finished (I plugged the power adapter in halfway through) and the test finished with no errors.

  • 13. Re: 4SNS/1/40000001:IDOR-0.000
    dbocks Level 1 Level 1 (0 points)

    I would like to say thank you that just saved me a lot of worry and a 2 hr drive