Previous 1 2 Next 16 Replies Latest reply: Mar 2, 2013 8:48 AM by Studio X
BTXtech Level 1 Level 1 (0 points)

I'm having an issue with audio after transcoding with Compressor. I'm currently using Final Cut Pro 7 and Compressor 3. I'm creating very simple product demonstration videos.

 

I'm shooting the videos with a Canon Vixia HF S200 and an external Lavalier Mic plugged into the camera. I take the video shot and "log and transfer" into FCP7. Once the video is imported I edit everything down and just add the intro & outro. The intro and outro use the same music which is a ".aiff" file. When finished I adjust all the levels, then play everything back. Within FCP7 it plays back beautifully.

 

My next step is "sent to" Compressor. Since I am posting this to YouTube, I just use the YouTube preset and call it a day. Once it's finished, I play it on my computer and it plays just fine.

 

The issue comes when I upload to "YouTube" and people try to play the video on an iPhone or iPad. The intro & outro ".aiff" music plays fine but when the actually camera audio kicks in, it completely drops off and you barely hear it and it's all distorted. This same issue does happen on some window PCs but that is hit or miss.

 

Am I doing something wrong? Is there specific procedure for making the video play smoothly on everything? I am at a TOTAL loss! Any help is GREATLY appreciated!

 

Thanks!

 

~Erick


Final Cut Pro 7, Mac OS X (10.7.4), YouTube video won't play on mobile
  • darbypsnm Level 3 Level 3 (720 points)

    What are your sequence settings?
    What does FC says the audio settings are for the Canon clips are?

     

    It could be a sent to issue.

    I personally do not use send to Compresor as I have gotten varied results.

    I export a quicktime(reference or self-contained) and then bring that into Compressor and render(A reference file is like a band-aid. I never use it more than once maybe twice).

    You can then check the playback before Compressor and confirm audio and video in QT.

     

    I would also confirm that the exported files from Compressor have AAC(128kbps) audio.

    Open file in QT(command+I) to see the specs.
    Confirm the exported file meets these specs:

    http://support.google.com/youtube/bin/answer.py?hl=en&answer=1297408

  • BTXtech Level 1 Level 1 (0 points)

    These are my settings. Keep in mind the "Canon" clips original audio was 16 bit Integer but I brought it into Soundtrack Pro and when finished it became 32 Bit Floating. I don't think this has any bearing giving that it happens even when I didn't edit the original audio.

     

    SETTINGS:

    http://i46.tinypic.com/162681h.jpg

     

     

    So I ended up exporting the project out of FCP7 first using the setting in the link provided. Then I brought that file into compressor and compressed it for YouTube. After uploading to YouTube, I played it on my iPhone 4, and the sound is great , IF I have the headphones plugged in, but when I try to listen to it via the speakers, it drops out and the sound is garbled. So frustrating.

  • Meg The Dog Level 6 Level 6 (10,620 points)

    What you describe sounds exactly like what happens when a mono source is recorded out of phase on a stereo pair.

    In FCP, remove or mute one of the two channels of sound from the camera on the timeline. You will probably need to adjust the level of the remaining channel to compensate.

    Now do your export and see if the result is the same.

     

    MtD

  • BTXtech Level 1 Level 1 (0 points)

    I believe you are right.

     

    So what I did was mute one of the channels and when i played the video the audio was coming out of the left, which makes sense because the left channel is the active one. So I double clicked on that left channels and set the pan to 0 and now it was playing in stereo. Then I played the video again BUT it was still playing out of the left. I exported just to see and the audio still only plays out of the left.

     

    I'm obviously doing something wrong and I apologize if this is basic, but it's my first time encountering this issue. Any help is appreciated!

  • Meg The Dog Level 6 Level 6 (10,620 points)

    If you are willing, try this:

    Make a copy of your sequence by clicking on the sequence icon in the browser, and once selected, control-click on it and from the drop down menu choose Duplicate.

    Name this copy something unique, then, working on the copy you just made:

    Select all the clips on the timeline, and once selected go to the menu Modify > Link.

    Next, while the clips are all still selected, go back to the same menu and choose Modify > Stereo Pair. This will unlink the audio from the video, and remove the stereo pair linking, so that you can remove the extraneous channel.

     

    Now select all the clips on the second audio channel only, and once selected, delete them.

     

    Now you should have only one audio source for the camera mic, adjust gain and pan to your liking and try the export again.

     

    MtD

     

    Message was edited by: Meg The Dog to fix typo

  • BTXtech Level 1 Level 1 (0 points)

    I followed your instructions and I delete one of the camera mono tracks. Now all I get is the remaining track coming out of the left. The pan is set to "0" and I even shifted it far left and far right but nothing happens. Now I haven't exported but I can't imaged exporting would make that full stereo, unless i'm wrong. Any idea's?

  • Meg The Dog Level 6 Level 6 (10,620 points)

    After doing the above, you double click on the remaining audio clip on the timeline so that it loads to the viewer, on on the audio tab in the viewer,  adjust your pan and hear now change when you play the clip on the timeline?

     

    Try trashing your preferences.

    https://discussions.apple.com/docs/DOC-2491

     

    MtD

  • BTXtech Level 1 Level 1 (0 points)

    So I did as you instructed. I doubled clicked on the remaining audio clip (Mono a1), and adjusted the pan but nothing changes when panning to either direction. When I play with the levels I can hear the change but nothing when I play with panning. I also downloaded and trashed the prefs.

     

    What could be the issue?

  • Meg The Dog Level 6 Level 6 (10,620 points)

    How are you monitoring the sound on your computer?

     

    MtD

  • BTXtech Level 1 Level 1 (0 points)

    Using stereo speakers and I used regular headphones. It's not a fancy editing suite over here. Doing the best we can with what little we have. So I listened via the speakers and the headphones. In both cases I don't get any response.

  • Meg The Dog Level 6 Level 6 (10,620 points)

    Sorry, I cannot replicate your problem so I don't have a solution. My only other suggestion would be:

    Create a new project, and in that project a new sequence and see if the behavior follows into the new project and sequence - if not, it would indicate your original project or sequence is corrupt.

    If it works in the new project/sequence, then copy your clips from your old sequence into the new.

     

    But my suspicion is that the problem is something obvious, that is somehow being overlooked.

     

    MtD

  • BTXtech Level 1 Level 1 (0 points)

    I'm not sure if it helps but here is a link of screen shots of my project. Might give you some insight that I'm missing.

     

    dl.dropbox.com/u/5658633/FCP_project%20screenshots.pdf

  • BTXtech Level 1 Level 1 (0 points)

    @Meg The Dog:

     

    I figured it OUT!

     

    Ok... so I had the audio in the sequence setting set to "Dual-Mono". I changed it to "Stereo", then, I unlinked the stereo pair from the camera audio and deleted one of the tracks. Then panned that track to "0" and raised the level a bit. Exported the sequence back out and BooYah! It sounds GREAT! Somewhat similar to what you were suggesting bu missing the part about changing the sequence setting.

     

    I thank you SO MUCH for your help!

     

     

    ~Erick

  • n0cho Level 1 Level 1 (0 points)

    Thanks for this workaround.  Had a similar issue where audio captured from a camera wouldn't export via quicktime or aiff .  This fixed helped me hit a deadline.

Previous 1 2 Next