Previous 1 2 3 Next 34 Replies Latest reply: May 29, 2013 3:36 PM by BeatingAround Go to original post
  • BeatingAround Level 1 Level 1

    Brilliant! That worked. Pondini and Mr Reed, I am really indebted to you both. I have my website back!

     

    Many thanks,

     

    Simon

  • Pondini Level 8 Level 8

    Really?  Cool! 

     

    I would have bet that it either wouldn't work, or we'd need some UNIX magic from Thomas.

     

    Anyhow, glad it's sorted out!

  • Linc Davis Level 10 Level 10
    expertise.applications
    Applications

    Never mind.

  • BeatingAround Level 1 Level 1

    No! I spoke to soon. I can now open it in iWeb -- hence my jubilation -- and edit it there but I can't save the site. When I try to save in iWeb, I am yet again told: The document “Domain.sites2” could not be saved.

     

    What is going on here?

  • Linc Davis Level 10 Level 10
    expertise.applications
    Applications

    Problems such as yours are sometimes caused by files that should belong to you but are locked or have a wrong owner. This procedure will check for such files. It makes no changes and therefore will not, in itself, solve your problem.

    Launch the Terminal application in any of the following ways:

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

    ☞ Open LaunchPad. Click Utilities, then Terminal in the page that opens.

    Drag or copy — do not type — all of the next line into the Terminal window, then press return:

    find . $TMPDIR.. \( -flags +sappnd,schg,uappnd,uchg -o ! -user $UID \) -ls

    Triple-click anywhere in the line to select it. The command may take a noticeable amount of time to run. Wait for a new line ending in a dollar sign (“$”) to appear.

    Post any lines of output that appear below what you entered — the text, please, not a screenshot.

    If any personal information appears in the output, edit before posting, but don’t remove the context.

  • BeatingAround Level 1 Level 1

    Thanks, Linc. That produced pages and pages of text. Would you suggest posting it, nonetheless? (I type as I watch obscure Olympic nations march across my screen.)

  • Linc Davis Level 10 Level 10
    expertise.applications
    Applications

    No, that's not necessary. Your home folder is screwed up. It's a common scenario in Lion, for reasons that I haven't been able to determine. Until recently, Apple made it ridiculously hard to recover from this condition. Things have improved, but it's still not a one-click operation as it should be.

     

    This is a two-part procedure. First you'll unlock all locked files in your home folder, then you'll reset permissions and ACL's.

     

    Part A

     

    Back up all data.

     

    Enter the following shell command in the same way as above:

    sudo chflags -R nouchg,nouappnd ~

    You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up. You don't need to post the warning. If you don’t have a login password, you’ll need to set one before you can run the command.

    The command may take a noticeable amount of time to run. Wait for a new line ending in a dollar sign (“$”) to appear, then quit Terminal.

    The procedure below will reset the permissions of a home folder in OS X 10.7.4 or later. If you're running an earlier version of 10.7, update to the current version first. This procedure should not be used in OS X versions older than 10.7.4.

    Part B

    Back up all data again.

    Step 1

    Click the Finder icon in the Dock. A Finder window will open.

    Step 2

    Press the following key combinations, in the order given:

     

    Command-3
    Shift-command-H
    Command-I
     
    The Info window of your home folder will open.

    Step 3

    Click the lock icon in the lower right corner and authenticate with the name and login password of an administrator on the system. If you have only one user account, you are the administrator.

    Step 4

    In the Sharing & Permissions section of the window, verify that you have "Read & Write" privileges. If not, use the "+" and "-" buttons in the lower left corner to make the necessary changes.

    Step 5

    By default, the groups "staff" and "everyone" have "Read Only" privileges. With those settings, the files at the top level of your home folder will be readable by other local users. You can change the privileges to "No Access" if you wish, but then your Public and Drop Box folders will be inaccessible to others, and Personal Web Sharing won't work. Most likely, you don't need to change these settings.

    Step 6

    If there are entries in the Sharing & Permissions list for users or groups besides "me," "staff," and "everyone," delete them.

    Step 7

    Click the gear icon at the bottom of the Info window and select Apply to enclosed items... from the drop-down menu. Confirm. The operation may take several minutes to complete. When it does, close the Info window.

  • Pondini Level 8 Level 8

    How is part B better than resetting home folder permissions to default values (per Resetting Password and/or User Permissions)?

  • Linc Davis Level 10 Level 10
    expertise.applications
    Applications
    1. No reboot is necessary.
    2. Extra ACL entries are removed.
  • Pondini Level 8 Level 8

    I thought the reset would fix ACLs, too, as shown on the Reset Password window?  (Don't think I've ever seen a support article about it, though.)

  • Pondini Level 8 Level 8

    BeatingAround:

     

    Note that if a lot of permissions/ACLs are changed, your next backup will be larger than usual.  Even if only the permissions are changed on a file, it's treated as changed, and will be backed-up.

  • Linc Davis Level 10 Level 10
    expertise.applications
    Applications

    resetpassword removes the last entry from the ACL, or at least it did prior to 10.7.4; they may have fixed it. It also adds an ACL entry where one exists in the user template. It doesn't remove extra ACL entries, which is why I always had to instruct a shell procedure to do that. After resetpassword, I would often get people coming back and saying their home folder was still messed up.

     

    What happens now with Apply to enclosed items... in the Finder is that the ACL's are completely deleted, and added back automatically where they should exist.

     

    I saw this in a recent tech note, but I don't have the link.

  • Pondini Level 8 Level 8

    Ah, very interesting.

     

    If you find it's fixed in ML, please let me know.

     

    Thanks!

  • BeatingAround Level 1 Level 1

    Brilliant! It worked. I can save and have now updated my website.

     

    Thomas, Pondini and Linc, thatnks so much for helping me out. I dont know how many hours I've devoted to trying to fix this thing, but it appears finally fixed.

     

    I hope someone els can benefit from the solutions here.

  • Pondini Level 8 Level 8

    Terrific!