8 Replies Latest reply: Jul 27, 2013 6:10 AM by jrabenson
MarcusInSingapore Level 1 Level 1 (0 points)

I havent used Conpressor 4 for a while so not sure when the problem appeared. But now for every movie i process SD or HD the output file stop at 48bytes and then it just hangs and nothing happens.


Tested with different source movies but still same issue. There is plenty of free disk space and i have tested with both internal and external output folders.


Anyone know what this may be or have any idea how to resolve?


Im using Max OS X 10.7.4 and Compressor 4.0.4




Compressor, Mac OS X (10.6.8)
  • Russ H Level 6 Level 6 (18,895 points)

    How are you getting the movies into Compressor – from the Final Cut Share menu – or are they previously exported movie files that you're dragging into the source well? Are you using clusters?



  • MarcusInSingapore Level 1 Level 1 (0 points)

    Hi Russ,


    Thanks for the reply, yes im sending it from Final Cut Pro X to Compressor via the Share menu This used to work but havent used it for the last six month and theres been some patches so not sure if that has affected it or something similar.


    I also tried reinstalling and cleaning out library and preference but it did not resolve the issue either.And also repaired disk permissions.


    Export from Final Cut Pro X using quick time works fine though so seems the issue is specific to compressor.


    Probably should add that my OS is the Server OS but i am not haveing any clusters and there are no other computers connected all processing is local.



  • Russ H Level 6 Level 6 (18,895 points)

    I'm not sure. Seems like a lot of the reports of Compressor problems involve the interoperability of FCPX and C. So each might perform properly when used independently but act up when they have to cooperate.


    If you take a QT file and give it to Compressor will it complete whatever job you give it?


    In addition to the steps you're previously taken I'd reset background processing and repair permissions. Also see if you can isolate any plug-ins or third party apps that are new to your system over that 6 month period.



  • Russ H Level 6 Level 6 (18,895 points)

    Just noticed you're already done permissions.

  • MarcusInSingapore Level 1 Level 1 (0 points)

    I have now reinstalled reinstalled FCPX and Compressor again, completely uninstalled Motion.


    I tried to give a MOV file to Compressor but result is same. I did then try to just send a clip of just few seconds from FCPX to Compressor and that actually worked, so after this i added a 20 min clip and send again to compressor and the 48 bytes issue appears again , however the computer seem to be still processing, just not saving any data, checked all drives not much activity except that the swap file keeps growing. I have 8 GB so memory should not be an issue.


    -rw-rw-r--@  1 marcus  staff         48 21 Jul 14:00 TestMovie.m4v-1


    Really strange,,, Im not sure what else can be done..


    The only app i have installed recently is Motion and i have already uninstalled that.I dont have any plugins for FCPX.


    Not sure exacly what you meant by background processing in this case but i have deleted all the Qmaster related files.During the reinstallation so there is no exisiting queue.



  • Russ H Level 6 Level 6 (18,895 points)

    Although I doubt it would accomplish anything more than you've already done, the reset I had  in mind is found in the Compressor menu tool bar under Compressor.


    I've re-visited the published Apple trouble shooting document and the only thing I see that we haven't checked is whether the computer's name is entered in Sharing (in the Advanced tab). Is it?



  • Wayne Richmond Level 1 Level 1 (0 points)

    Hi Marcus,


    I have exactly the same thing happening to me (Compressor 4.0.6) and I've tried all of the things you tried and that have been suggested to you by others.


    Did you ever sort this out?


    I am desperate!  :-(





  • jrabenson Level 1 Level 1 (0 points)

    I hope you managed to sort out your problem - I gave up for a long time but I think I found a solution for a similar if not the same issue: https://discussions.apple.com/message/20479332#20479332

    basically, I had old versions of compressor still running. By getting rid of them (using terminal because they are installed in /usr/sbin) I got things back up to date.


    good luck