Previous 1 9 10 11 12 13 Next 184 Replies Latest reply: Dec 24, 2015 7:39 AM by Tehila L Go to original post
  • Sandy Lockhart Level 1 (5 points)

    Works perfectly on iOS 5.1! Thanks you are my hero!

  • dimonukr Level 1 (0 points)

    Dude! I even bothered to sign it to say THANK YOU! You are awesome You just fixed my iPhone.


    Hey Apple people hire this guy to work for you. He is better than 99.9% of your employees out there.

  • ahhc Level 1 (0 points)

    Worke perfectly! thanks Sissy Ribbons.

    I too signed in to say Thanks.


    instructions were clear and perfect!

  • akd78 Level 1 (10 points)

    Can i ask how long you waited for it to activate?

  • dimonukr Level 1 (0 points)

    It took about 25-30 seconds to activate. At first, I thought that this solution is not woring, but then all of the sudden, after 30 seconds it got activated. I am using iPhone 4S.

  • Teeneylynn Level 1 (0 points)

    *Thank You SissyRibbons, this worked for me* :)





    Re: iMessage "An error occurred during activation. Try again."

    Nov 19, 2012 8:54 PM (in response to MartinF123)

    Hey you guys. After several stressful hours,I found a solution (hopefully it will also work for you)

    I currently have iOS Version 6.0.1, but this should work for everyone


    After hours of trying several methods to fix your iMessages from different forum websites, i mashed all methods together. 

    This all started when i accidently hit "iMessage" and turned it OFF, then it was not able to turn it back on using my number, but instead it was giving my email address for texting, or just giving regular text.  Hopefully this will work for you. Please read throughout all directions in order


    At this time, make sure your iMessage and Facetime are BOTH ON ( if you cant find these two options, skip a few steps down and it will tell you how to get to there)


    Before we start, BE SURE YOU HAVE A VALID "APPLE ID"


    Make sure your Date,Location, and Time are correct according to your time zone and location.



    Go into "Settings"

    Find and enter the "General" Tab

    In the General Tab, find and enter the "Date and Time" tab

    Turn OFF the "Set Automatically" ---- then. manually change the "Time Zone" to where you are currectly located" OR nearest location  (e.g. -  I am located in "Richmond CA," but the time zone I am checked in is "Cupertino CA(15 minutre drive away," So no big difference) ----Dont try and find me creepers, im a serial killer who rides a Donkey, serious business.

    Turn "Set Automatic" back ON, (If it automatically find the closest city near you, no biggie)

    End of Step


    Location: iMessages

    Go into "Setting"

    Find and enter the "Messages" tab

    Scroll down and enter "Send & Receive"

    Click on your Apple ID:

    Click on "Change Location"

    Make sure your "Region" is accurate to where you are located"

    End of Step


    Location: Facetime

    Go into "Setting"

    Find and enter the "Facetime" tab

    Click on your "Apple ID"

    Click on "Change Location"

    Make sure your Location is accurate

    End of Step


    Okay, Now for the goodies, not too much though, might cut your tongue.



    Step one: Sign out of your Apple ID.

    Find and enter your "Store" app ( where you download all your apps for your iPhone), select the "Featured" category located at the bottom left of the app.

    Scroll down on the page, you should see a tab where it shows your email Apple ID address. - click on it and Sign Out.

    If youre already signed out, SIGN IN AND BACK OUT AGAIN

    End of Step


    Step two: Turn off Wifi.

    Go into "Settings"

    Find  and enter the "Wi-Fi" tab,

    Turn OFF Wi-Fi

    End of Step


    Step Three: Enable then Disable Restrictions

    Go into "Settings"

    Find and enter the "General" tab

    Find and enter the "Restrictions" tab

    If  Restrictions are already disabled-----Enable it.

    It will ask you for a "Restrictions Password" (I put the same code i use to log into and unlock my iPhone)

    After you Enable it ---- DISABLE IT again, so that every tab is "OFF" and greyed out, unable to be clicked.

    End of Step


    Step four: Turn off iMessage

    Go into Settings

    Find and enter the "Messages" tab

    Turn OFF iMessages

    End of Step


    Step Four: Turn off FaceTime

    Go into "Settings"

    Find and enter the "Facetime" tab

    Turn OFF Face Time

    End of Step


    Step Five: Reset Network Settings

    [NOTE: This will NOT erase contacts or any of the naked pictures you take of yourself/ Personal information, ex. Music, Schedules, or your only Girlfriend Siri (Doesnt count if youre a woman, Men, dont deny it, my Siri forced me to be her Husband :'( ]

    Go into "Settings"

    Find and enter the "General" Tab

    Scroll Down and enter the "Reset" tab

    Click on the "Reset Network Settings"

    It may or may not ask you for a password, just use the same password again you use to get into your iPhone


    End of Step


    After you pressed "Reset Network Settings" Your phone should have automatically restarted.


    Now for the Finishing Steps.


    Now that your phone has restarted, You must do the "Cha Cha Slide" and "Hokey Pokey" to induce a magical spell onto your iPhone. Just kidding, but try it, you'll make a fool of yourself and relieve some stress from all the researching you have been doing to fix this problem.  It's Okay if you didnt, im still your friend. =D


    NOTE: DO NOT SIGN INTO WIFI, From now on until your "iMessages/Facetime" Works, You should be running on "3g or 4g" internet



    Step Six: Sign in into your Apple Store

    Find and enter your "Store" app ( where you download all your apps for your iPhone),

    Select the "Featured" category located at the bottom left of the app.

    Scroll down on the page and SIGN IN

    End of step


    Step Seven: Sign into iMessages (MAKE SURE YOUR WI-FI IS STILL OFF or "Not Connected"!! and running on "3g/4g")

    Go into "Settings"

    Find and enter the "Messages" Tab

    Turn ON "iMessages" (It may or may not ask you to sign into your Apple ID, just sign in whenever they ask you to.  OR there might be a tsb where it will say something about "You need to sign into your Apple ID, blah blah blah, something along those lines, Click it and Sign in)

    Let it load ( loading times may varry, from five minutes to 1 and a half hours, keep checking in all while you DO NOT SIGN INTO Wi-Fi!)

    IMPORTANT! - Now, when i turned ON iMessages, IT FAILED THE FIRST.. or second time(cant remember), KEEP TRYING! It should turn on after three or four tries.


    Now do not toggle the On&Off button during the proccess of it loading because it will restart the whole loading process. Just wait until it says "unsuccessfull" to Turn off iMessages and on again.


    HOPEFULLY when your iMessages is turned on,


    Step Eight: Repeat step: Seven,

    For your Facetime.  That also failed once for me before it started to work again.



    After both iMessages and Facetime are working, you are now free kiss a baby or Pet(Gold Fish, Husband and Wife included) on the cheek out of joy....but put him him/her/it down, youre scary looking and might make the baby/pet cry


    You are also free to sign back into Wi-Fi


    I hope this works for you. Enjoy your day and help a random stranger out.


    If it worked and you feel generous, Copy Paste this into any Forum or Website (Eg. Yahoo Answers) so others can see and be helped.



    SissyRibbons OUT!


    ^Best nickname ever.









    Like (5)

  • andreasfromtx Level 1 (0 points)


    Anybody know the problem to this error?

  • buxnaapple Level 1 (0 points)

    Tnx that worked for me

  • txgirl95 Level 1 (0 points)

    Thank you so much SissyRobbins! I had been trying for weeks to get my imessage to activate and your steps did the trick. THANK YOU THANK YOU THANK YOU!

  • Grandmstrbud Level 1 (0 points)

    What a waste of time, after the long process of 7-8 steps it still fails.          

  • Bubbles54 Level 1 (0 points)

    All I had to do was go to the "date & time" tab in general settings and turn off "set automatically" and turn it back on again

  • Bubbles54 Level 1 (0 points)

    "Date and time"

  • ohheyitsashlee Level 1 (0 points)

    I had to restore to my latest backup, and surprisingly even though I lost some pictures from my iphone and the messages went back to the old ones, it worked fairly well.

  • deeRN Level 1 (0 points)

    I must say,"Thank you." I have a son living in Japan and one of the few ways I can communicate with him without any charge is iMessage. Suddenly it wouldn't work. I could not figure out what was wrong and I am not a novice. As I went through your solutions one by one I came to the Facebook instructions and found out that somehow Facebook had  inad-vertently been turned off. Just that one thing kept stopping my activation.  So I wanted to take the time to thank you. I greatly appreciate your posting. From an appreciative mother whose son is in Japan and who misses him very much.

  • YoJoLo Level 1 (0 points)

    It worked for me the first time.  My daughter kept trying to send me a picture today, which is about a month after I bought my 4S, and I never received it so she sent it again.  Still didn't get the picture and stumbled on this site after Googling the problem.  It worked and I am so thankful that you spent the time researching this problem.