Previous 1 2 Next 25 Replies Latest reply: Sep 4, 2012 1:02 PM by danas_blia
danas_blia Level 1 Level 1 (5 points)

I have recently upgraded to Snow Leopard and am having problems with my fonts.

After installing some of my previously used fonts, some of them didn't pass validation. I don't mind removing them - I barely use 1% of the fonts I have, but when I run Font Validation in Font Book and then select all the corrupt files and click "Remove" - Font Book just gets stuck.

Then I went by the list and removed MANUALLY all the invalid font files (the ones with the red cross sign).

Then only the minor warnings remained , but even when I try to remove them with Font Book - it still crashes.

It's ridiculous to remove them manually one by one, cause I have a huge collection of 1000s of fonts and there are more than 500 corrupt fonts there. I'm not using many fonts, but I want to keep my library up and working, so I want to get rid of everything that might cause problems...

Any help?


MacBook Pro, Mac OS X (10.6.8)
  • Kurt Lang Level 7 Level 7 (34,325 points)

    Font Book's database has been trashed. What you see happening is a common symptom.

     

    First manually delete all fonts from the Fonts folders they reside in you don't want in there. Then reset Font Book.

     

    Restart your Mac and immediately hold down the Shift key when you hear the startup chime to boot into Safe Mode. Keep holding the Shift key until OS X asks you to log in (you will get this screen on a Safe Mode boot even if your Mac is set to automatically log in). Let the Mac finish booting to the desktop and then restart normally. This will clear Font Book's database and the cache files of the user account you logged into in Safe Mode.

     

    You should also then clear the font cache files from the system.

     

    Close all running applications. From an administrator account, open the Terminal app and enter the following command. You can also copy/paste it from here into the Terminal window:

     

    sudo atsutil databases -remove

     

    Terminal will then ask for your admin password. As you type, it will not show anything, so be sure to enter it correctly.

     

    This removes all font cache files. Both for the system and the current user font cache files. After running the command, close Terminal and immediately restart your Mac.

     

    Once that restart is complete, now launch Font Book so it can create a new database based on the fonts which you left on the drive.

  • zeemoney Level 1 Level 1 (0 points)

    Thanks, Kurt. This solved my Font Book problem.

     

    Unfortunately, upgrading to Snow Leopard also caused a problem in Suitcase Fusion 2. Basically Suitcase no longer works. Either it crashes on launch, or I get an error message that it's "Unable to start Suicase Fusion Core." And when I try to turn this on in System Preferences, it crashes System Prefences. 

     

    Any idea what's going on or how to fix this? If not, any suggestions for a good font management application?

  • Kurt Lang Level 7 Level 7 (34,325 points)

    Suitcase could have two things going on. One, you should never have more than one font manager on your computer at a time. They will fight each other over control of enabling and disabling fonts. Even if the Font Book app isn't open, it's database will interfere with other managers. I'd do this:

     

    1) Copy the Font Book app to another drive, just as a safe place to keep it. Then delete it from the hard drive.

     

    2) Follow the steps above to boot into safe mode and then back. You want to get Font Book's database off the drive, which this will do.

     

    3) Uninstall Suitcase Fusion 2. Then reinstall it from your original disk or downloaded purchase.

     

    4) If step three doesn't fix Suitcase, shut down Suitcase if it's running. Go to the ~/Library/Extensis/Suitcase Fusion/ folder, remove the file Suitcase Fusion.fontvault and restart your Mac. This will force Suitcase to build a new vault file. Be aware that if you use the vault to store fonts, they will all be gone.

  • zeemoney Level 1 Level 1 (0 points)

    Thanks Kurt. Any recommendations for a Mountain Lion-compatible font manager? Font Book is too basic; Extensis is great but too buggy.

  • Kurt Lang Level 7 Level 7 (34,325 points)

    I've always used Suitcase and found it to be an excellent manager. Though the first OS X version (Suitcase X) was not very good.

     

    If you'd like to try something else, Linotype's FontExplorer X Pro is also a very good manager. If Suitcase were no longer around, I wouldn't hestitate a moment to use it.

  • danas_blia Level 1 Level 1 (5 points)

    Hi Kurt

    Sorry, was busy, didn't answer for some time. Thanks - it helped me to run Font Book again and install new fonts, but Font Book is still causing me a lot of trouble - never had so much in Leopard - I'm frustrated, maybe you can help on those:

    After completely wiping clean all my fonts databases and folders etc. I've started loading back my Font libraries into Font Book. I don't copy fonts to any new folder, I just activate them from wherever they are without copying. First thing I noticed, is the amount of "corrupt" fonts has increased enormously - I have a couple of folders with alsmot all 400-500 fonts corrupt (yellow sign) with this error message: 'kern' table structure and contents. All of them with the same Error message.

    The next thing that happened, is that at some point Font Book has just deleted my new font libraries again without any notice. Then I installed them back again. It deleted them again (I think after a restart).

    Another bug is that Font Book always activates all the new fonts upon loading them, although I clearly runed off "Automatic fonts activation" in the Preferences. So every time I load a library I manually disable all of the fonts, and then enable only the ones I use.

    BUT! What happens next, is completely outrageous - when I launched FB next time, all my new font libraries where activated again! jezus - I had to go and disable them all and again activate the ones I need. This repeated several times, until I decided to delete the fontbook.plist prefs file from Preferences. I think it helped for now, but I'm not sure yet - will wait and see.

    Also there is a bug in FB, that when I install a new library, it always jumps my cursor into renaming the name of this library, and doesn't let me navigate the fonts with keyboard, unless I restart. This is an obvious bug.

    And the last thing that happened is that I cannot type my Baltic languages fonts anymore - the input of the keyboard is completely wrong. Those are TrueType fonts, and most of them worked perfectly in Leopard with InDesign. Now when I type the baltic letters in InDesign I see squares. But when I open Glyphs - I see all those letters and need to put them in manually from Glyphs panel. This is totally frustrating and I cannot work. But I will make a separate post about this issue.

    Thanks in advance for help...

  • Kurt Lang Level 7 Level 7 (34,325 points)

    First thing I noticed, is the amount of "corrupt" fonts has increased enormously

    Font Book's font checking is virtually useless. It will catch truly bad fonts and mark them in red, but the vast majority of its caution tags are meaningless. As an example, I installed Mountain Lion from scratch on an erased drive. Obviously, all of the OS installed fonts are as clean as can be. Then move them all out of the Library folder and restart. Now add any of these clean fonts back into Font Book as a new entry and it will say there are possible problems. That's how useless it is.

    After completely wiping clean all my fonts databases and folders etc. I've started loading back my Font libraries into Font Book...

    Everything you mention is usually related to a corrupt Font Book database. A very common symptom is not being able to activate, or deactivate fonts. That and Font Book showing you that fonts are active, but none of them appear in any apps. If you already did a Safe Mode restart to clear Font Book's database, cleared cache files and such, then there are only two real possibilities left.

     

    1) The OS is damaged and needs to be reinstalled.

     

    2) 400 - 500 fonts is a lot to try and activate at once, especially with Font Book. It's intended to be a light use font manager for a home user, not someone in design or related industries where you have to handle lots of fonts all the time. The point for this one is that any number of those fonts can be damaged. Bad fonts will in turn once again damage Font Book's database and you'll be right back to where you were before the Safe Mode restart and cache cleaning. Meaning, you have to do it all over again to fix the problem.

  • danas_blia Level 1 Level 1 (5 points)

    1) The OS is damaged and needs to be reinstalled.

     

    Oh my... trully, I have no time for it but if it will continue like that I will be forced to make a clean install... I need a vacation! : /

     

    2) 400 - 500 fonts is a lot to try and activate at once, especially with Font Book. It's intended to be a light use font manager for a home user, not someone in design or related industries where you have to handle lots of fonts all the time. The point for this one is that any number of those fonts can be damaged. Bad fonts will in turn once again damage Font Book's database and you'll be right back to where you were before the Safe Mode restart and cache cleaning. Meaning, you have to do it all over again to fix the problem.

    But it worked fine in Leopard! And the whole point is that  I don't want them active - I only want to preview them fast and activate only a couple that I work with. But FB chooses to activate All fonts every time I load a library into it, even though in the Preferences I choose not to. So I usually just select all and deactivate, and then activate only what I need. But now I cannot deactivate them  for some reason. I will try again clearing font caches with all possible means, and safe booting...

     

    But the Lithuanian language characters problem, as I guess, is not related to caches or bugs in FontBook?

  • Tom Gewecke Level 9 Level 9 (74,495 points)

    danas_blia wrote:

     

    But the Lithuanian language characters problem, as I guess, is not related to caches or bugs in FontBook?

     

    If you only see it with InDesign (and not TextEdit, Mail, Safari, etc), then it sounds like an Adobe issue.  You might want to ask in their forums.

  • Kurt Lang Level 7 Level 7 (34,325 points)

    And the whole point is that  I don't want them active - I only want to preview them fast and activate only a couple that I work with. But FB chooses to activate All fonts every time I load a library into it, even though in the Preferences I choose not to.

    When you moved to Snow Leopard, did you just install it over Leopard? Apple of course says you can do that without issue, but many users have problems with such an install. It does work well on very clean systems. It doesn't work well where any number of small issues have built up and caused damage to the OS, where installing a new one over it exaggerates the problems that were already there. I never, ever use an upgraded OS. I always install it to an erased partition, and after I feel confident it's a stable release (like at least 10.x.2), then I'll start using it as my day-to-day OS.

     

    But the real problem here is Font Book. It's database is easily damaged. For the type of work you seem to do, involving the use of many fonts, get Font Book off the system and use something much better. I would suggest Suitcase Fusion 4 or FontExplorer X Pro.

  • danas_blia Level 1 Level 1 (5 points)

    When you moved to Snow Leopard, did you just install it over Leopard?

    Oh, yes yes - I did install it over the old OS. I know it's not healthy, but frankly, to put back all the software and settings back again on track would take me a month. I was used to it when I worked on Windows, but on Mac I got relaxed and didnt have to reinstall the system in 4 years.

  • danas_blia Level 1 Level 1 (5 points)

    Tom Gewecke wrote:

     

     

    If you only see it with InDesign (and not TextEdit, Mail, Safari, etc), then it sounds like an Adobe issue.  You might want to ask in their forums.

     

    No, you got it a bit wrong - let me explain: I can see the Lithuanian characters in any software if I manage to type them in, because the characters do exist in the fonts. But I cannot type them, because it seems that they don't match the keyboard layout any more. In Indesign I can open the Glyphs panel, and it let's me see all characters available for that font. So from there I can choose them and manually insert into text, but I cannot type them with the keyboard. Looks to me like an encoding problem. By the way - this doesn't happen with Russian fonts or with Hebrew fonts - only Lithuanian...

  • Tom Gewecke Level 9 Level 9 (74,495 points)

    danas_blia wrote:

     

    I cannot type them, because it seems that they don't match the keyboard layout any more.

     

    Can you also not type them in TextEdit?

     

    Are you using the Lithuanian keyboard layout provided by Apple in system prefs/language & text/input sources (so that you see the Lithuanian flag in the top right corner of your screen)?

  • Kurt Lang Level 7 Level 7 (34,325 points)

    I know it's not healthy, but frankly, to put back all the software and settings back again on track would take me a month.

    When I need to keep working, but get a clean install of everything going, I do it all on a spare drive or partition as I have time. It gets done eventually without bringing you to a standstill.

Previous 1 2 Next