Previous 1 2 3 Next 72 Replies Latest reply: Nov 26, 2013 11:36 AM by oscarguindzberg
blauw777 Level 1 Level 1 (0 points)



Bought the new 11" 2012 MacBook Air last week. Unfortunately I can't use my 3G dongle with it. (it's a T-Mobile branded Huawei E173) The Air just doesnt recognize it. Even not as disc image. When I plug it into my 15" 2009 MacBook Pro it just works fine. Disc image with the pre-installed software pops up and it can be used to access the internet. It works fine on my 2008 Mac Mini as well and tested it on my dad's 2010 iMac as well. It just won't work in my Air. Any idea??


Thethering from my iPhone is not an option because T-mobile has blocked that. Mifi is too big for my pocket and I don't want to think about charging it all the time. So a dongle is the way to go for me.


Thanks in advance.

MacBook Air, Mac OS X (10.7.4), 11"
  • captfred Level 7 Level 7 (26,265 points)

    If you want the disk image to display on the desktop or finder sidebar, Finder > Preferences > general tab > check external disk.   Do the same on the sidebar tab.

  • blauw777 Level 1 Level 1 (0 points)

    Don't think that will help. If I put in my USB stick it shows up in the finder. The Huawei doesnt....

  • Oxygenee Level 1 Level 1 (0 points)

    I have exactly the same problem with a 2012 Macbook Air 11" and the Orange WiFi dongle.

  • Atters Level 1 Level 1 (5 points)

    This has been a very bad day for Apple. Just got the same problem with a brand new (less than 8 hours old) 11" Macbook Air. I am using a T-Mobile Huawei E173 3g USB modem. This is a new modem that I had to buy when I upgraded my MB Pro to Lion. The old modem only had 32 bit drivers the new one is 64 bit. This modem still works on my MBP running Lion 10.7.4,  it's getting a signal as I type this. When plugging the modem into either USB ports on the Macbook Air nothing happens. Could this be an issue with the new Airbooks having USB 3 and not USB 2 ports?


    With the fiasco of the Mountain Lion upgrade today, Apple really need to get their act together. Doubly annoying is that T-Mobiles UK support forums are returning a Proxy Server error tonight so can't even get their side of the story.

  • tovís Level 1 Level 1 (30 points)

    It seems that there are several versions of this modem: u1, u2..., s1, s2, etc. You can see it printed after "E 173" on the body, just removing the cover. Mine is "s1" and is not recognized if I plug it directly in the USB port, but IT DOES if conected through an USB hub.


    Moreover, I've tried another version "u2" and it works perfectly well.


    Don't know, then, whose fault is it, Apple or Huawei?

  • Atters Level 1 Level 1 (5 points)

    Just checked, mine is also S-1. As it works on a Macbook Pro running Lion it should really run on a Macbook AIr. This has to be an Apple issue as it works on older Macs running the latest OS, Apple should not be revising their own hardware specs in such a way to make recent peripherals inoperable.. I just think that the Macbook AIr is just not transferring enough power to the modem for it to work. I've have a call booked with customer services later to see what they suggest.

  • blauw777 Level 1 Level 1 (0 points)

    Is that a powered hub you're using? Power from the port could be the case. These things consume enourmous amounts of power. It degrades my battery like 50% faster when in use. 


    Mine is an S-1. I think I'm going to see if I can try a newer version....

  • tovís Level 1 Level 1 (30 points)

    That's right. Mine works also on a MacBook Pro (mid 2010 & Lion), and other portables w/Windows (all of them USB 2.0, I must say).


    But, not sure about the lack of power in the case of MacBook Air because it did work conected on a passive USB hub (which has a LED to power as well).


    I went to a shop of Apple with my modem and tested it on last June models, i.e. MacBooks with USB 3.0 ports (even Retina). None of them recognized the modem, so... "Apple, whe have a problem!"

  • tovís Level 1 Level 1 (30 points)



    You can read it in my previous answer: No, it is not powered.

  • Atters Level 1 Level 1 (5 points)

    Just spent 1 hour and 2 mns on the phone to Apple tech support. Was bumped up to a senior technician as Apple were not aware of the issue. Went through a series of diagnostic tests but there are no clues to what is going wrong. The USB 3 ports should not be supplying less power than previous Mac's USB 2's as they are designed to work to the USB specified guidelines.


    This has now been bumped up further and I've been told that Apple will want at least 24 hours to look into this. I am really pleased that Apple are taking this so seriously and very impressed with the level of customer services provided on this occasion.


    I'm also going to tak to T-Mobile to see if they have a solution and whatever I find will be send back to Apple. In the mean time going to use a Zoom mobile router so I can connect when out and about.


    More news when I get it.

  • blauw777 Level 1 Level 1 (0 points)

    Great!! Thanks for sharing. Looking forward to your next post!

  • Torsten Wolter Level 1 Level 1 (0 points)



    Yes, looking forward to you sharing more information when you have it. This is very annoying... BTW, to add some value: My Huawei E122 3G stick is not recognized but my Huawei E1750 is (they're from different countries hence I need both). So unless the two sticks' energy requirements vary I doubt it's a power issue.

  • blauw777 Level 1 Level 1 (0 points)

    Ok, I solved my problem. It cost me some money but I can use a dongle in my Air now...


    After reading on another forum how someone else solved this I went the following road: I walked into a Vodafone store and bought the dongle they offer with their dataplan. It's a Vodafone k3770 which is actually a Huawei as well. It has no simlock so it works with my T-Mobile sim. It got recognized immediately by the Air as a drive station and offered the Vodafone software (which cannot be installed on OS X 10.8) But the stick is being recognized as a modem in the network settings of OS X itself. The only thing I did is enter the phone number of T-Mobile *99# and I could connect! If you tick a box there to have to modem status displayed in the menu bar you can just connect by clicking the icon in the OS X menu bar. Awesome! Much better than the crappy software that comes with these dongles.


    I made a deal with the Vodafone salesman: if it doesn't work, money back. But it works. But note: in different countries it may be simlocked. I live in The Netherlands and over here it's not locked. It cost me € 60,- but it's worth it because I can't work otherwise....

  • alrowan Level 1 Level 1 (0 points)

    Same thing here. Have e173. Works just fine everywhere else, except the MacBook Air 2012 I just bought


    I need it, as it's my only internet ISP

Previous 1 2 3 Next