6 Replies Latest reply: Jul 23, 2012 11:08 PM by Bengt Wärleby
michaelv03 Level 1 Level 1 (0 points)

Hi everyone,

 

I have been trying to import a short video into Imovie. The original video file is wmv. I have used a free conversion software called "Any Video Converter'. As the video I am trying to create is a sort of medey of several videos, I remember importing one short video successfully before but I cannoy remember which format it was in. Obviously it was a format that Imovie accepts.

 

I have tried importing the following common video formats, all failed: flv, mov, mp4, mpg, avi

Any video converter does not offer any other formats to convert to.

 

What can I do now.

 

Please help.


Mac mini, Mac OS X (10.6.4)
  • michaelv03 Level 1 Level 1 (0 points)

    Anyone?

  • Bengt Wärleby Level 6 Level 6 (19,450 points)

    Hi

     

    all failed: flv, mov, mp4, mpg, avi

     

    Non of these are any Video Codecs - they are all containers and can hold Codecs iMovie can use - OR NOT

     

    Open one with QuickTime Player and then open Inspector [cmd+I] and read

     

    Video Format/Codec: nnnnnnnnnnnn

     

    Frame rate: yyyyfps

     

    What does they say.

     

    I use - StreamingDV - and this Codec works in iMovie alt is - AIC (Apple Interchangably Codec)

     

    Yours Bengt W

  • omracer Level 1 Level 1 (30 points)

    have you tried Miro video converter (from the app store and available on windows) and drag the wmv into it and select Apple Universal and then import that. i've imported some wmvs to iMovie using this method

  • michaelv03 Level 1 Level 1 (0 points)

    Hi Bengt,

     

    Thanks for your reply. As requested, I have opened one. I opened an mpeg one and it said:

    Format: mpeg1 muxed

    it does not say frame rate, only

    FPS: 29.97

    Data rate:1.296.54 kbit/s

     

    I used to have no problems importing video files, but this time inn 3 days of trying I have not been able to import even one, regardless of what 'container' the video was in. I don't get why this is so very difficult.

    Especially since I tried a video converter and even when converting to other containers or formats, nothing works whatsoever. I thought that the extension after the dot is the format! for example .mov  etc

     

    Mike

  • michaelv03 Level 1 Level 1 (0 points)

    I have tried Miro now and using the Apple Univeral feature it worked.

     

     

    Thanks!!!

  • Bengt Wärleby Level 6 Level 6 (19,450 points)

    Yes

     

    .mpeg1 muxed - should not or use not to work - but Apple Univeral should.

     

    Yours Bengt W