5 Replies Latest reply: Jan 2, 2013 11:59 PM by Howdidoo
purplebumblebee Level 1 Level 1 (0 points)

As of a couple of days ago, I was listening to a song on my iphone when the sound suddenly cut off. The phone kept playing the song, but the sound was completely gone.

The sound works with the use of headphones, and when I call people I can hear them, they can hear me etc.

I have tried:

  • Plugging in headphones, taking headphones out, several times, while playing a song and not etc.
  • Resetting iphone and resyncing it to the last back up.
  • Cleaning out the headphone socket (As aparently it might be because the phone thinks that the headphones are constantly plugged in)

I am now at my wits end, as I am missing phone calls and have to wear my headphones to use apps with sound.

 

Please help


iPhone 4S, iOS 5.1.1
  • AnaMusic Level 9 Level 9 (57,070 points)

    iPhone: Can't hear through the receiver or speakers..

    http://support.apple.com/kb/TS1630

  • purplebumblebee Level 1 Level 1 (0 points)

    Thank you,

     

    This hasn't solved the problem, as the volume ringer display just says 'Ringer' and not 'Ringer (headphones)'

     

    Could this mean that there is something wrong with the speaker itself?

  • sirjana Level 1 Level 1 (0 points)

    i read in one of the post this may be due to the upgrading iphone 4s ios 5.1.o to ios 5.1.1 i m too searching the solution but still not succeded

  • meade78 Level 1 Level 1 (0 points)

    I had the same problem a couple of days ago. A complete restore/reset through itunes solved it. Had to try a couple of times to get by error messages, though! Be sure to back up first!

  • Howdidoo Level 1 Level 1 (5 points)

    Hi All,

    I had this Sound / Speaker issue too on my iPhone 4S, with only Ringtone & Headphones working and no other sound coming despite several software hacks and solutions read on forums here. I managed to solve it today after reading online for a perfect solution.

    This seems to be a fairly frequent problem amongst users who are using 3rd party (Cheap Chinese) dock connectors or chargers. There is some residue on the charging connector and hence it seems to be stuck in Dock/Headphone mode. I personally had this issue that only Ringtone and Headphone were working. I cleared some stuck particles from the dock connector in iPhone below and voila ! Sound works perfectly. Try it using a cotton bud / swab with removed cotton or I did it with inverted metal paper clip carefully avoiding to scrap and destroy the PCB board. (Other common solution was to remove water particles from headphone hole but I didnt have any)

    All the best,

    Cheers !