13 Replies Latest reply: Dec 31, 2012 9:24 AM by barneyman1
Patrick Steven Level 1 Level 1 (0 points)

My iTunes Remote App isn't working. I meet all of the system requirements, as for "Look for iPod touch, iPhone and iPad Remotes" that isn't an option... it does read "iTunes is not paired with any remotes". I have turned home sharing on in iTunes, and after I log into my iTunes account on the App, it just reads "Turn on Home Sharing in iTunes on your computer or Apple TV..."

 

The best part of all of this is that I use to have a PC, and I never had a problem with the Remote App until I switched to my MacBook Pro. The App did work, the very first time I connected it to my MacBook, but never since.


iPhone 4S, iOS 5.1.1
  • rockmyplimsoul Level 5 Level 5 (6,160 points)

    Is your iPhone connected to wi-fi, and to the same network as your Mac?  (i.e. make sure the iPhone is not connected to a guest network if your router provides one)

  • Patrick Steven Level 1 Level 1 (0 points)

    Both my Mac and iPhone are connected to the same w-fi. No guest network.

  • rockmyplimsoul Level 5 Level 5 (6,160 points)

    You turned Home Sharing ON on your Mac, did you do so on your iPhone?  (Settings/ Music/ Home Sharing)  Even if enabled, since you've changed computers you may need to turn it OFF and then back on (both in iTunes and on your iPhone).

  • Patrick Steven Level 1 Level 1 (0 points)

    Yes, Home Sharing is ON on my Mac. Yes, I turned Home Sharing OFF on my iPhone and Mac, and then back on.

  • Patrick Steven Level 1 Level 1 (0 points)

    I've also uninstalled and reinstalled the app on my iPhone.

  • RonnieTheOng Level 1 Level 1 (0 points)

    Hi,

     

    I'm also facing similar problem with the Remote App with my Apple TV 3.

     

    I called the Apple Care and after the troubleshooting on the phone; which basically performed some turning on/off homesharing, restarting the Apple TV, iphone & ipad which I intended to use as remote, the Remote App still canot detect the iTune account.

     

    The Apple Care then said it may be due to the home router and send me an article and advise me to call the local support for the home router to open some tcp/udp ports listed in the article for the Apple TV (TCP 123, 80, 443, 53, 3689, UDP 5353).

     

    I'm going to call the local telco on this when I reach home this evening after work. Not sure if this will resolve the problem. You may want to try the same.

  • ericdjohns Level 1 Level 1 (0 points)

    I read on another post that the AppleTV3 overwhelms the number of connections that iTunes can accept - blocking your remote app from connecting. The solution is to set your AppleTV3 to never go to sleep, restart iTunes, problem solved. I did this, have had no issues connecting for the last 48 hours, so it seems to work.

  • MCGiorgi Level 1 Level 1 (0 points)

    I found an article on the internet (I don't remember the address otherwise I'd include it here) a suggestion to change your router to WAP2 security instead of just WAP.  I was having the same problem you are but when I changed from WAP to WAP2 the Remote app worked flawlessly.

  • fatjax Level 1 Level 1 (0 points)

    Thank you so much this is the second time this has happened to me. Once I went on to my main network instead of guest worked like a charm

  • Patrick Steven Level 1 Level 1 (0 points)

    Ok... now I know I'm going to sound like a total reject, but how would I go about changing my router to WAP2?

  • MCGiorgi Level 1 Level 1 (0 points)

    It should be in your router setup.  I'm no router expert but I accessed it through my browser by typing in the router's IP address which I found on the identification label on the bottom.  The router should give you the controls interface.  Check around in 'wireless settings', or something similar, and look for 'security settings'  You shiould see options like WEP, WPA (I originally said WAP by mistake) and WPA2.  You could also do a search on the router manufacturer web site for how to do this.

    WARNING!!

    You will have to re-connect all of your wireless devices since you are changing the wifi settings and your devices will be expecting the old settings.

  • mike2j6 Level 1 Level 1 (0 points)

    This worked for me! I have a Belkin wireless router and changing from WPA-PSK+WPA2-PSK encryption to just WPA2-PSK solves all the problems! Many thanks!

  • barneyman1 Level 1 Level 1 (0 points)

    Before you go to far into all the settings I found that a hard restart of my Iphone solved the problem. I couldn't find my computer or Apple TV with the remote app. Did a hard restart of the Iphone and everything showed up.

     

    This might not be your problem but it's a very simple first step.

     

    Good luck.