Previous 1 2 Next 18 Replies Latest reply: Jan 5, 2013 11:17 AM by floridajoseph
jimbim Level 1 (0 points)



I recently upgraded my new, latest generation MacBook Air to Mountain Lion (Gold Master). Since then, Aperture won't play the videos in my library anymore. It does display the thumbnail preview images (they have obviously been generated before), but it can't play the video and does not even show the video controls for playback. The videos I am talking about are all taken with my Sony NEX-3, which should be supported out-of-the-box.

Right now I can not even import new videos from my camera, as Aperture just tells me it does not know how to handle the video files (and proposes to just save the files somewhere in the file system instead of importing them into my Aperture library).


Is my installation corrupt? Am I missing some basic video codecs? Is Aperture not (yet) ML-compatible?


Any hints?




Macbook Air, Mac OS X (10.5.3)
  • jimbim Level 1 (0 points)

    Another observation: If I open my Aperture library in iPhoto, I can play the videos, but they are played in slow motion and the sound is not synchronized.

  • Michigan One Fly Level 2 (240 points)

    " I recently upgraded my new, latest generation MacBook Air to Mountain Lion (Gold Master)."


    Do you have some sort of inside track ?? Mountain my knowledge has not been released yet.  I have heard that it will be available tomorrow July 25 th. 

    Are you perhaps on LIon ? Your signature is OSX 10.5.3 ?


    Also what version of Aperture are you using  and what codec is your camera recording in?  I think your camera has a few different codecs it can be set to for recording.

  • William Lloyd Level 7 (21,040 points)

    Mountain Lion releases are available to registered Apple Developers and other means.  So there are "official" ways to get pre-releases of Mountain Lion.


    That said, these programs have an NDA as well, which generally prohibits any of this sort of discussion prior to the general release of the product.  There ARE places this can be discussed (developer forums or elsewhere depending on how you got Mountain Lion).


    Questions/answers related to Mountain Lion here... should wait until it ships, which looks to be tomorrow.

  • jimbim Level 1 (0 points)

    Thanks everybody,


    my company is developing Mac Apps, that's why I am a registered developer and have access to prerelease versions of OS X - in this case the (hopefully) final build of 10.8 Mountain Lion.

    I have posted my question here because I am not sure if this is Mountain Lion related or not and I will not talk about ML in any way. I agree that I might better have waited before posting this question.


    I am using Aperture 3.3.1 and my camera records 720p in h.264 (MPEG-4) format. I _have_ imported many of those videos into Aperture before and I also have lots of them in my library. The problem I have now is that I suddenly can not play those videos anymore, and I can not import new ones either. As I do not watch videos every day it could be possible that this behaviour was already introduced in the last Aperture update.

  • léonie Level 10 (90,815 points)


    we asked the community host in similar cases how to deal with Aperture questions, if Aperture is running in combination with pre release software, and the hosts advised us not to discuss these questions here. And as we are all guests here we should respect their wishes.


    It would be difficult anyway; we could not ask for screenshots, console messages, crash logs, terminal listings. everything would be in violation of the non-disclosure agreements.


    Some general advice with videos that will not play:

    • - Are the videos referenced? Try, if they will play if you make them managed.
    • - Aperture has been known, to not to be able to play video, if the library is in a shared folder.
    • - Check, if you have third party video codecs installed, like the 3ivx codec.


    Aperture 3: About Video and Audio formats in Aperture:




  • jimbim Level 1 (0 points)

    Thanks Léonie,


    I will respect our host's wishes and stop discussing this here (until this afternoon?) ;-)


    Best regards,


  • léonie Level 10 (90,815 points)

    (until this afternoon?)

  • jimbim Level 1 (0 points)

    Mountain Lion and Aperture 3.3.2 have just been released (at least here in Germany) and the problems I described above still persist: Aperture can not play the videos in my library. If I open my Aperture library in iPhoto 9.3.2 the videos play without problems. I still can not import videos from my NEX-3 into Aperture - will try to import via iPhoto now.

  • léonie Level 10 (90,815 points)

    O.K., I also have ML-GM installed, but not your camera. For your camera the codecs are listed as part of Mac OS Lion, directly built into the system.

    Maybe in ML it will help to register the camera with the lauch services database - see this post by Alan Roseman

    :Aperture 3 preview of raw file greenish, but read the follow up posts first (the lsregister command) as well, on how it is supposed to work andhow to correct the typos.


    This worked previously, when some cameras were not registered, but the support was built into the OS.


  • Snoopy5707 Level 1 (5 points)

    Same Problem here!! All old Videos cant open in Aperture!!



  • SierraDragon Level 4 (2,695 points)

    The new update claims to bring ML and Aperture into compliance with each other:




  • léonie Level 10 (90,815 points)

    I just checked again the list of supported video for Aperture. This list is not exhaustive, but I am not longer sure that your camera's video is supposed to supported.


    Aperture 3: About Video and Audio formats in Aperture:


    and the Sony NEX 3 is not on that list. Can it be that you had third party video codec installed previously, like flip-for-mac, that you not yet installed after upgrading to Mountain Lion?

  • Snoopy5707 Level 1 (5 points)

    i think is not a Problem with Aperture 3, but with ML. I have a lot of videos that were already in the library and also worked. I go back with TM to older Libriary and Aperture, but same Problem. No play and no import with any Videos.

    Now i make a clean ML install and test again.

  • jimbim Level 1 (0 points)

    Hi Léonie,


    my camera is on the list of supported cameras: Sony Alpha NEX-3.

    I have never had any additional codec packs like perian/3ivx and the like installed. It just worked out-of-the-box with Lion. And, like I said, the problem persists even with Aperture 3.3.2 (published today).

    I have the feeling that it might have something to do with a newer version of Quicktime, which is supposed to be handling all video-related stuff in Mac OS X.

Previous 1 2 Next