Previous 1 2 3 4 Next 52 Replies Latest reply: Sep 1, 2013 11:34 AM by bebing mae Go to original post
  • fixanymac Level 1 Level 1 (0 points)

    Adobe will determine the version based on your Mac automatically, if you just visit their site.

     

    Go to Adobe.com instead of some third-party's website and click on  "Downloads" near the top center in the navigation bar and then click on the "Get Flash" button.

     

    The current build, as of this post, is: 11.3.300.268

     

    I won't leave a direct link because I think we should get into the habit of always going to the source for ANY stuff we download from the web.

     

    I have been running Mountan Lion for over 4 months, because I have a Developers License. I love it.

  • esther X Level 1 Level 1 (0 points)

    Hey, my mac also didn't have a folder called "Disabled Plugins".

    However i don't have "2 version of flash" .


    There are 2 related name about the flash player are:

    Flash Player.plugin

    flashplayer.xpt

     

    I updated the new flash yesterday. And the flash is not working afterwards. It said "Blocked Plug-in".

    How can i solve this problem??

     

    > i'm really not good at computer, especially Mac; i just started using Mac this year...

     

    Wish anyone can help me ^^

  • doug38 Level 1 Level 1 (0 points)

    I ended up figuring it out.  I noticed my problem when visiting MLB.com to watch a baseball game through their Gameday view (if you aren't familiar with it you click on the little icon of the baseball field adjacent to the scores running down the left side of the home page.  I got a blocked plug-in message when it loaded the Gameday page. You can click on the blocked plug-in text and it will take care of it and download the right version.  Worked perfect for me.  Problem solved.

  • dolbyk Level 1 Level 1 (0 points)

    UPDATE:  I resolved the issue by doing the following.

    1. Make sure to install the most updated version of Flash. http://www.adobe.com/support/flash/downloads.html

    2. Delete all references to Flash or Shockwave in Macintosh HD > Library > Internet Plugins > Disabled Plugins

     

    Check to see if the version is older by looking at the Date Created sort field.  If they are Flash related and weren't installed today, delete them.

  • 4Better Level 1 Level 1 (0 points)

    This worked!  Thanks so much!!!

  • ahmedhussein Level 1 Level 1 (0 points)

    Big Thanks to you

  • csmiles Level 1 Level 1 (0 points)

    Thanks this worked for me, after two plus weeks of not being able to watch videos on Safari.

  • Bryan D Toder Level 1 Level 1 (5 points)

    Perfect! It works now and thanks so much!

  • OTAVVIN Level 1 Level 1 (0 points)

    Have tried all the steps previously mentioned here

     

    I had installed the newest version of flash and then deleted the old version within internet plug-ins folder, and this is still not working

     

    do you have any other clue for this issue?

     

    Thanks a lot in advance

  • fixanymac Level 1 Level 1 (0 points)

    Since you've tried the other steps, try reinstalling Safari by downloading it from Apple's website using another web browser, if necessary.

     

    You should also delete Safari's preferences from your user/Library/preferences folder. Safari will rebuild a new one upon launch.

     

    Then repair disk permissions, this may finish the process for you and get everything cleaned up.

  • kebner28 Level 1 Level 1 (0 points)

    I had this same issue -

    flahsplayer.xpt had an install date of several months ago so I deleted that file, re-installed flash again (from the Adobe site) and now it works.

    Good luck!

  • nonDr Girton Level 1 Level 1 (0 points)

    My girlfriend messed up her flash player installation, I don't know how. Here's what I did ( maybe it will work for you):

     

    Go to the Adobe site, find the UNINSTALL flash player for your operating system. Do it. Then, INSTALL the current flash player for your operating system.

     

    I had already tried the previous tips suggested here, such as going into various folders, and trying to find and delete various outdated/scraps and fragments. That had no effect, but un – installing, and re – installing flash player did solve the problem.

  • agodfrin Level 1 Level 1 (0 points)

    The strange thing in my case is that the plugin shows up as blocked in Safari only. Firefox has no problem whatsoever. The blocked plugin happened suddenly while I was listening to a web radio that I had been listening to all day long.

     

    I just popped the URL in Firefox and continued listening. But Safari just refuses to launch the audio player and shows the "blocked plug-in" message.

     

    I take it that all this talk about refusing to run an unsafe copy of flash is really just a Safari thing - not an OSX thing since other (non-Apple) components still use it. Am I right ?

     

    Albertt

  • erwinevs Level 1 Level 1 (0 points)

    Thanks for the information here, but, although I saw the same issue, with the disabled plug in under library and the old falsh xpt file, which I all deleted, installed the latesd flash plug in, it still keeps on showing in Safari as Blocked.

     

    If I remove the flash player first, Safari shows correctly, "missing plug in", then, when I re-install it, it says again blocked plug in. The plug in under the library directory is from today, but the xpt, keeps on being old, although I deleted it.

     

    I also tried the uninstall from Adobe, but no success.

     

    The problem started when I installed mountain lion. Before all worked fine.

     

    Any more suggestions?

  • OTAVVIN Level 1 Level 1 (0 points)

    I have also tried to uninstall and re-install flash and I have  gotten no success whatsoever, in fact, the safari seems to acknoledge my flash version, even doing all the tricks mentioned here it always keep asking me to download flash.

     

    Someone has suggested me to reinstall the safari, nevertheless, I'd consider this as the very last option. has anyone ever tried to get the plug-in information from time machine? has it worked? I'm really thinking on trying to do this before reinstall safari stuff.

     

    Thanks a lot in advance for all the advice provided