Previous 1 2 3 4 Next 58 Replies Latest reply: Feb 1, 2015 8:35 AM by pravijn Go to original post
  • datagears Level 1 Level 1

    I had the same issue and after reading through posts, this is what I did to fix it.


    It seems that this may occur when you have an icloud set up but there is no corresponding entry in the mail app or there is a issue with the set up (like port or server)


    Open your mail go to Preferences and then Accounts. Look to see if you have the icloud mail that you are getting the error for. If you don't add it right there by clicking the plus button at the bottom of the panel. After is adds it and verifies it, you whould be able to go back to the system preferences and the problem should be resolved and mail and notes should be turned on.


    If you already had the icloud account, delete it and re-enter the info again.


    Hope that helps.

  • aforkoshgm Level 1 Level 1

    I was finally able to acesss my iCloud Notes from my Mac Pro.  There was a bad plist in an Application Support file that needed to be deleted. Once I did that, I was able to connect Notes and all Mail accounts remained connected.


    I was able to diagnose the problem by running Console while I attempted, using System Preferences, to link my iCloud Notes to my MacPro. I saw a message of the form


    System Preferences[59374]: Could not write plist to ~/Library/Application Support/Mail/OnlineAccountTypes/ st


    When I drilled down to the file, I saw that it had not been modified since 2010. I moved it to the desktop and tried to again connect Notes. That attempt succeeded, and I noticed that a new version of the file had been generated. I ckecked that all email accounts were still accessible in Mail and then deleted the original file from the desktop.


    So this closes the issue for me.

  • Shiznit• Level 1 Level 1

    I had the exact same issue, everything apart from mail and notes would work, ie i could check the box in system preferences. When I tries the same with mail and notes I got the message that it could not be activated and to try later. This was only on MBP, all my other Macs worked fine.


    After many many hours messing around, trawling the Internet, and even reinstalling Mountain Lion, I have just worked out what the problem was for me. I have recently installed Little Snitch 3 Beta, and this was, for some reason blocking certain communications to my iPhone and iCloud. Everything is working fine now. So if you have Little Snitch installed it may be worth checking your rules on it.


    I have used LS for years and this is the first time it has ever done anything like this, I always allow system processes access so at a loss as to why it has happened this time.


    Hope this is of some help

  • jsmithy6 Level 1 Level 1

    I can confirm that the Mac OS X 10.8.2 update fixes the issue with Mail and Notes. or or

  • hduran Level 1 Level 1

    Same problem here.


    I spent hours and tried almost all suggestions posted here, but with no luck.


    Notes and mail will not sychronize on my iMac, whereas I have no problems with my MacBook. This is really strange.


    As a nasty workaround I access my notes through my web browser :-(

  • dBraf Level 1 Level 1

    Bad plist removal worked for me.

  • gatesnet Level 1 Level 1

    Open port 993 on your network , I opened it and its working well

  • hduran Level 1 Level 1

    Hello gatesnet,


    Sorry for this stupid question: How can I open port 993 under Mountain Lion?

  • nafs Level 1 Level 1

    iCloud Mail (+ Notes) failed to sync from my MBA connected to my home Wifi. My iPhone 4 was connected to the same network, and it synced to iCloud just fine.


    I turned on Personal Hotspot and connected my MBA to my iPhone 4, which connected to the internet via 3G network.


    With this setup, iCloud syncing from my MBA worked again. I turned off personal hotspot, and iCloud syncing continued to work. Apparently, it seemed to need some sort of jump start...


    I hope Apple will fix iCloud sync problems like these in the near future. It's hard to trust a system that can fail so easily and inexplicably.

  • sweetcaro Level 1 Level 1

    I have tried every single option offered and nothing has worked

    my notes can't sync.. it gets the error notes can't be enabled at this time

    my imessage can't sync either.. when I try to login to the icloud account in imessage it says could not sign in to imessage.


    tried turning off firewall completely not just opening the port.. did not work

    tried the whole add to mail account etc... did not work

    tried removing icloud account completely, readding it, ... not work


    this is after upgrading from snow to mountain lion

    not sure if it's anything to do with the @me account or anything


    is apple going to fix this?

  • wbardin Level 1 Level 1

    Jesus!! It should not be this hard to set up a lousy email account. I've wasted a number of hours and still don't have it working. I have been going over all the posts here and tried almost every suggestion but I still don't have a working email account on my Mac. It's frustrating when they can't even fix things like this at the Apple store. Works fine on my iPad and iPhone. At least I can use it on a limited basis. Hopefully some day Apple will fix this so it's as easy to set up as other accounts. I hate to say it but I really wish Mail, calendar and Contacts would integrate better and was more flexible. seems like a real throwback from a truly functional system. O well!

  • The Woodmaster Level 1 Level 1



    I've beeen trying to resolve this for ages and was going mad with it. Then I checked for peer guardian stuff in logins and there they were.


    Thanks - works great now.



  • artshiha Level 1 Level 1

    Hello Guys


    I'm quit new here, but i was suffering the same problem and went crazy try to find soultions. I searched a lot all blogs and apple community replies but no way. With ry and error i come to that solution and it works now.


    1- Go to you mail app/Perefernces/Uncheck the box to disable the iCloud from your mail

    2- Go to iCloud pereference pane ( you will find your mail unchecked already )

    3- Check your Notes ( you will be asked to merge notes with your iCloud account ) / accept

    4- With you notes already checked, check your mail again

    5- go to your mail app again, to make sure you recieved a mail from iCloud to let you know that your account is activated.


    It is all good and work for me


    Hope that will help you too


    Thank you

  • Tsukius Level 1 Level 1

    Opening port 993 on our firewall solved the problem for me.

  • hduran Level 1 Level 1

    Well, yesterday I could solve my problems witn Notes.


    Due to another problem I found out that I was NOT the owner of the folder ~/Library/Application Support. For whatever reason, it was owned by another user. Repairing permissions did not help, so I manually corrected it by making a copy and deleting the original folder.


    And voilà, it works now!