9 Replies Latest reply: Jul 26, 2012 12:32 PM by Ralph Johns (UK)
JFraser Level 1 Level 1 (0 points)

People keep texting my phone (some with iPhones with the latest iOS installed on them) but I'm not receiving the messages nor their anticipated alerts on Mountain Lion.  Are other users experiencing the same problem?


iMac, Mac OS X (10.7.2), Intel Core i5
  • weatherologist Level 1 Level 1 (0 points)

    Yes...I am...nobody seems to know how to resolve it though.

  • Ralph Johns (UK) Level 9 Level 9 (69,010 points)

    HI,

     

    Clear all old Messages off the iPhone

     

    In Settings > Messages > Received At > Caller ID enter the Apple ID in use in Mesage on the Mac.

     

    This will then sync the iPhone number to the Apple ID and you should see them in Messages.

     

    If you don't clear the old messages then the syncing does not fully work and the iPhone Number is isolated from the Apple ID and syncing of iMessages to the iPhone Number don't appear in Messages on the Mac.

     

    Some people have reported that turning their iPhone Off then On Again also seems to work (it probably breaks the contact with the iMessage server making it start again afresh).

     

     

     

     


    9:58 PM      Wednesday; July 25, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • JFraser Level 1 Level 1 (0 points)

    1. Does that mean that people will know my iCloud email address whenever I text message someone from my phone? (Caller ID)

     

    2. I have a ton of old text messages on my iPhone.  Is there away to quickly remove all of them?

     

    3. Do I have to keep my Caller ID on my iCloud email address as opposed to changing it back to my cell phone number after I perform the original sync in order to maintain synchronization with my Macs?

  • BennyboyOxtoby Level 1 Level 1 (5 points)

    I am having the same problem and solved it like so:

     

    Open imessages, send a message to a recipients mobile number (but only to icloud associated phone numbers) and then get your contact to delete the previous conversation, as it will show seperately.

     

    This is quite annoying as it only seems to work from the moment you send a message in imessages. I was under the impression I would open up messages for the first time and it look the same as my iphone. To be honest im pretty hacked off with it as it was my main reason for upgrading, and its not really as advertised at all.

  • JFraser Level 1 Level 1 (0 points)

    I tried all of the methods you listed above several times and none of them fix the problem.  The only method that partially seems to work, which the other guy mentioned above, is to initiate a text message from a Mac to an iPhone.  Nothing else seems to work.  Any other suggestions?  Is that a quark that Apple still has to fix for some accounts, or perhapse, overall?  It's unfortunate that it took about 1/2 hour to delete all my previous text messages on my iPhone just to see that the suggested process doesn't work.  Not that I lost anything important though for I already read them all and replied to the ones that I needed to.  I'll also try contacting Apple Care about this problem in the mourning...

  • sebgod Level 1 Level 1 (0 points)

    Thanks Ralph

    The simple thing of turning on and of my iphone DID IT !!!! IAM HAPPY!!!

    I did try all kinds of things already whent through at least 10 furoms and did about 100 different things to my phone and apple id and mac

    NOW IF THERE IS ANY BODY OUT THERE THATS HAVING THIS PROBLEM , PLEASE TRY AND REBOOT YOUR PHONE

  • Sheerwaterguy Level 1 Level 1 (0 points)

    I was told by Apple yesterday that iMassage only works on the Apple ID as it cannot detect a phone number. So in short until they ingrate the phone number with iMessage it will never work on the desk top for Mac. True I am able to send text messages to other Apple unsers but it really only works for email address. As I understand it you not be able to ever use IMassage on the Mac to send standard text messages to a person with a none Apple device.

  • Ralph Johns (UK) Level 9 Level 9 (69,010 points)

    HI,

     

    The only way I know is to enter one "conversation" and use the edit Button, then Select each and every message and then Forward.

     

    I Forwarded to my Apple ID so they would go to the Mac.

     

    It loses format but you have the whole "conversation".

     

    Yes your email will get sent to all contacts via this method.

     

    My experience in Messages Beta is that it pays to to stick to using the Apple ID.

     

     


    8:21 PM      Thursday; July 26, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Ralph Johns (UK) Level 9 Level 9 (69,010 points)

    Hi,

     

    I would guess with everyone downloading and setting up Messages that the servers are going to get hammered for a while and there will be delays.

     

    I also think there may be an issue with using a second computer with the same ID (i.e syncing across two computers as well as possibly two iOS devices) as there seems to issue with the way the second computer also tries to register the ID when it is already registered.

     

     


    8:31 PM      Thursday; July 26, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously