Previous 1 2 3 Next 806 Replies Latest reply: Feb 27, 2014 4:47 PM by Michael Paine Branched to a new discussion.
m@zo Level 1 (0 points)

I have major problems using Exchange in Mountain Lion. Under Lion everything worked fine (Mail, Calendar, Contacts incl. global address list). Under ML only Calendar works, Mail and Contacts show connection errors. Our corporate server is Exchange 2007.


Has somebody a fully working Exchange in ML?


Any ideas?


Many thanks!

  • justinhamlin Level 1 (0 points)

    Just wanted to let you know you are not alone.


    In fact, my calendar and contacts are not syncing either.


    I cannot RDP to any internal servers, connect to any Windows file servers or connect Mail or Outlook 2011 to our Exchange 2010 servers, all of them fail with Authentication errors, however, I know for a fact that my credentials are valid (2nd computer here still works on Windows 7 and my credentials)


    Looking forward to a solution to why ML does not pass AD Authentication correctly.

  • joshuaiz Level 1 (10 points)

    I had similar problems and what I did was go into Mail > Preferences > Accounts > Exchange > Edit SMTP Server list and then deleted the server I previously was using for my Exchange account (and any other legacy servers you may have in there). Then I re-added the server and made sure my Exchange account reflected the just added server.


    And yes, the server was the same as before.


    In addition, I deleted all my keychains related to the Exchange server and let Mail recreate them. From there I went into Accounts in both Calendar and Contacts and updated the settings there as well.


    After I did that, I haven't had any problems.

  • m@zo Level 1 (0 points)

    Thanks for your input.


    You pointed me into the right direction. After comparing the configuration for every program with another Mac, where 10.7 was still running, I figured it our: Somehow, ML got the "internal server name" wrong. Somehow it put in the name of the Exchange Sever itself, not the EWS-Server. Once I put in the adress of our Exchange-EWS-Server (the same server I used to setup the account in the first place) all started to work. However, I had to to this manually for every app (mail, contacts, calendar), as you suggested.


    But the problem is: Every app reverts to the wrong server setting after closing and reopening. Very frustrating!

  • joshuaiz Level 1 (10 points)

    This is why you have to delete the old server(s) and keychains. These apps have to get it from somewhere...


    You might try unclicking Mail in System Preferences > iCloud while you are doing this until the settings "stick" in Mail, Contacts, Calendars. Then turn it back on. iCloud should update with your new Mail settings.

  • mikeoliver Level 1 (0 points)

    I have same issue as m@zo - I deleted my exchange account, recreated it, and put in the full qualified server name (i.e. - it instantly syncs, works fine.


    As soon as I close the preferences, it puts the server name in the internal field box, then fails, then I have to put the full name back in . . . and so on.


    Outlook 2011 fired right up and no issues, syncs fine.



  • JamesPou Level 1 (0 points)

    I had the same problem.  Seems the culprit is either system preferences itself or the mail program even after wiping the keychain clean of any exchange passwords or settings.  I split the two and configured Exchange/IMAP for just e-mail and used Exchange for Contacts and Calendars only.  Seems to keep all the settings this way (hence my suspiction that it is the mail program). 


    I suspect an update will be out for the mail program in short order (or system preferences). 


    Hope the suggested solution works... If you finally crack your issue with exchange and did not use this solution, let me know!!!





  • trondeg74 Level 1 (5 points)

    I have the same problem - it looks as if exchange support is broken.


    I tried the remedies here (clean keychains, recreate account etc) to no avail. However, as it clearly looked as if mail client tried to contact an internal host (internal to another network - this is a hosted exchange server): The server name ended in .local


    So what I did was to add the internal server name along with the IP of the external server to /etc/hosts


    This sort of works: I get new email. However, I can't see older email either in the inbox or elsewhere - I have to resort to the web interface or my iphone/ipad for that.

  • dwalthour Level 1 (0 points)

    I did the same trick of editing the hosts file and now everything seems to work for me both for old email and newer email.

  • m@zo Level 1 (0 points)

    I have to admit, the solution in my case was quite easy:


    As opposed to Lion, my server really needs to be placed in the "external server" field, not hte internal. However, mail always fell back to the internal sever (the one not reachable) because of a stupid error: I forgot to turn on SSL for the external server. SSL is activated by default for the internal server, but not for the external server! Silly me


    Thanks a lot for all your suggestions. You pointed me in the right direction!

  • dwalthour Level 1 (0 points)

    Your fix didn't do it for me.  Even if I set the external server and turn on ssl it still wants to use the inernal server settings.  I still need the hosts file trick for everything to work right for me.

  • sonmezyildiz Level 1 (5 points)

    How can I access to etc/hosts ? Can you explain it a little more?

  • Timothy Swan2 Level 1 (15 points)

    Same problem here. Mail, connecting to an Exchange was initially working fine on an iMac that I upgraded to Mountain Lion, and also worked on my iPhone and iPad. A few hours later I started getting a dialog box that my password was incorrect. Mail continued to work fine on iPhone and iPad, as well as on my home computer. server,


    This morning I was still getting the error and when I tried to log in to the Exchange web client it failed there too. It turned out that my account had been locked, presumably because my work computer is sending the incorrect password. I unlocked the account, changed the password on the computer, iPhone, and iPad and was able to retrieve mail on all three. 15 minutes later I got the incorrect password dialog again on the ML computer, but the iPhone and iPad continue getting mail for about 30 minutes, at which point the Exchange account was locked again.


    Seem as though this could be a keychain problem, though it's very odd that it only happens with Exchange.

  • jabeard3 Level 1 (0 points)

    I am able to connect without issue but I'm experiencing problems sending mail.  It works sometimes and not others.  The mail activity shows 0 bytes per second.  Other times e-mails from the same account go through without issue.  Bandwidth tests show 24 down and 7 up so I don't think that's the problem... 


    Any advice would be appreciated. 


    the inbox associated with this account will not allow me to rebuild either... greyed out

  • justinhamlin Level 1 (0 points)

    Update from me.  I called into Apple to get support, see if this was known configuration issue - their response "Call Microsoft, clearly the problem is not with Mountain Lion"


    Yeah, I will leave that alone.


    I have had absolutely no luck, my Exchange server is not logging any failed connection attempts or logins, though I have had to turn up logging to see if I might find something.


    I switched over to Sparrow and using IMAP as a workaround for the time being, however, still no calendar/contact access....

Previous 1 2 3 Next