Previous 1 2 3 4 5 6 Next 831 Replies Latest reply: Feb 27, 2014 4:47 PM by Michael Paine Go to original post Branched to a new discussion.
  • justinhamlin Level 1 Level 1 (0 points)

    okay, everyone, please read this.  I dont have the time to reply to everyone individually, but since this is something I am dealing with too, I wanted to bring everyone up to speed.

     

    I do not work with Apple, but rather am a Microsoft Certified engineer and have been for 10+ years.  The reason you see "internal" server names and external server names, and why things change/update/etc, is due to how your backend Exchange server is configured.  The service that defines these values is called Autoconfigure.

     

    Autoconfigure is, essentially, an XML-based configuration that gets pushed down to any mail client, Outlook, Mail.app, or anything trying to access mail resources using MAPI over HTTPS.

     

    So, everyone complaining that these values are being changed, that is by design and setup so that your Exchange/Outlook/Mail profile will work when you are in the office, as well as when you are out of the office.

     

    The larger issue is with Mail/Outlook/Apple and how they are passing authentication credentials to the backend servers.  That is what I am trying to figure out myself, and I am working with Apple engineering on this.

  • Emma Richardson Level 1 Level 1 (0 points)

    Thanks for letting us know - it is good to know that it is being worked on!

  • HAN006 Level 1 Level 1 (0 points)

    Thanks for this, I went through it, did everything, unfortunately situation remains the same. I am really dissapointed and I am sure other exchange users as well. Can't work!

  • shot2bits Level 1 Level 1 (0 points)

    Hi, glad it's being worked on since I've tried the workaround but still experiencing the same issue.  Almost installed Outlook

  • justinhamlin Level 1 Level 1 (0 points)

    Might have just had a little breakthrough -

     

    I would like to see if someone else can confirm this resolves their issue -

     

    try and going into NETWORK PREFERENCES > (your connection, wifi or ethernet) > ADVANCED > HARDWARE >

     

    Set your Configuration to "MANUALLY"

    Speed - "AUTOSELECT"

    MTU = "CUSTOM" - set to 1350 (for example)

     

    Basically, there is an issue on the local network that prevents packet sizes over a certain size (at least for me) which was causing all these random issues.

     

    (also, you dont want to know what all i had to go through to figure this out)

  • shot2bits Level 1 Level 1 (0 points)

    Something odd just happened.  I'd installed Sparrow which doesnt support Exchange (didnt realise that at the time) so thought I'd remove my iCloud .me email from Mail and try Sparrow.  Once I'd removed my .me email from Mail, the inbox started to receive more of my mail up to May - a bit at a time so maybe more will come through...

  • shot2bits Level 1 Level 1 (0 points)

    OK, Im back - all my mail is there any up to date.  What did I change?  Basically removed my .me email account from Mail - for whatever reason that started the flow of mail into my Exchange inbox.  Odd!

  • trondeg74 Level 1 Level 1 (5 points)

    Changing the MTU doesn't help a bit here... and I'd be scared if it did, breaking the TCP/IP stack is worse than doing some bad changes to the exchange code in the name of more flexibility and not doing it quite right on the first try.

     

    No .me account either...  I don't have it on my macs after Apple's mess with apple id/iicloud/mobile me: I had one apple id which I've purchased everything on, and one mobile me account I'd paid for. I haven't used the latter since icloud, in hope that one day I could merge these.

  • Waverider020 Level 1 Level 1 (0 points)

    Sorry Justin,

     

    It doesnt make any difference here!

    Thanks for the effort.

  • Rea Productions Level 1 Level 1 (0 points)

    I was able to recover mine by adding a line to my hosts file via these steps.

     

    For this I'll refer to my email server as mail2.agency.com and the value that Mail 6.0 changed it to is exch2007.agency.local

     

    I used vi from the command line as root but there are other ways. The goal is to get your computer to look for the new server value at the IP of your mail server. You can disable root after this excesise is completed. I've provided an image below that shows what my account information looks like.

     

    You will need to know how to use VI for my example below.

     

    Adding the IP address for the Mail 6.0 internal value:

     

    1. Go to Terminal
    2. nslookup of of mail2.agency.com gives you the IP of your email server
    3. vi /etc/hosts (you have to enable root so you can save the file -- follow the steps below)
    4. Instert a new line that looks is the IP address <space> exch2007.agency.local
    5. Save the file and reboot
    6. Once you have restarted go back to Mail and wait for it to do it's thing. I had to force quit mail and restart and I don't exactly know why but I am up and running now.

     

     

    Enabling Root in Mountain Lion:

     

     

    1. From the Apple menu choose System Preferences....
    2. From the View menu choose Users & Groups.
    3. Click the lock and authenticate as an administrator account.
    4. Click Login Options....
    5. Click the "Edit..." or "Join..." button at the bottom right.
    6. Click the "Open Directory Utility..." button.
    7. Click the lock in the Directory Utility window.
    8. Enter an administrator account name and password, then click OK.
    9. Choose Enable Root User from the Edit menu.
    10. Enter the root password you wish to use in both the Password and Verify fields, then click OK.

    MountainLion-ExchangeFix.jpg

  • Emma Richardson Level 1 Level 1 (0 points)

    Once again, I just want to warn you that this will only fix it from when you are outside your office network (or if you do this when you are inside your office network, it will not work outside). The problem with directing the internal server address to a specific ip address is that the ip address for this server changes depending on your location.

  • Ondray Wells Jr. Level 2 Level 2 (225 points)

    RlaughIO,

     

    The instructions I provided should work for all Exchange enabled apps.  Don't try to modify the settings in each app.  Let ML set them as it sees fit.  Then follow the instructions I provided above to "trick" ML into thinking that the External Server you want to use is the Internal Server it wants to use.

  • Ondray Wells Jr. Level 2 Level 2 (225 points)

    Emma,

     

    The way it works at my company is that we have a particular server that we configure for use by smartphones and tablets that need to access employee Exchange accounts.  It is accessible outside of the corporate network without having to use a VPN.  For the purposes of this discussion I'm going to call it the "External Server".  Now we also have the Exchange Server itself that all of the Outlook clients on desktops and laptops are configured to use.  Let's call that the "Internal Server".  Apparently ML has some sort of auto-configure "feature" that is forcing all my Exchange enabled apps to use the "Internal Server".  Which is fine when I'm at work ... and a problem when I'm not.  Now YMMV, but at my job we are able to access the "External Server" from anywhere.  Inside or outside the corporate network.  If I'm at work and my iPhone is on the corporate Wi-Fi ... I can still get to my email, contacts, and calendar just as easily as I can anywhere else with internet access.  So what I did with Lion was to set up my laptop to use the same "External Server" as I use for my iPhone.  That way all my Exchange enabled apps just worked anywhere I had internet access.  So basically what my solution above does is allow ML to insist upon using the server name of the "Internal Server" ... but in my hosts file I've told it to resolve that server name to the IP Address of the "External Server".  And thus far my machine is working as it was in Lion both inside and outside the office.

     

    Now if your corporate setup does not allow your particular "External Server" to be accessible when you are in the office then my solution above will likely not work for you.  If that is the case, then it's going to be hairy because while Mail seems to respect the internal and external server setting in its preferences, Calendar and Contacts seems to ignore the external server setting altogether.  So my recommendation would be to not specify an external server in your settings at all.  Instead, just allow ML to use the server name it wants and then just connect to your corporate network with the VPN client your company gave you when you are outside the corporate network.  That way when you are working remotely your machine can "see" the server name that ML wants to use as if you were at work.

     

    Hope this helps!

  • ospreytc Level 1 Level 1 (0 points)

    I agree.  I went into "adnvanced" and saw that one of my SSL blocks was left unchecked.  After checking it, I retyped my server info into the correct fields (it seems to change those initially).  I tried a test from and to myself at the exchange account, and it worked.  It is working now for about fifteen minutes.  We'll see.  When I opened the accounts prefs, I saw that it correctly contained my SSL port info (info was blank previously).

  • ospreytc Level 1 Level 1 (0 points)

    justinhamlin some posts by m@zo and myself, ospreytc, show a piculiar fix centered around the SSL blocks in the "advanced" page of the acounts.

Previous 1 2 3 4 5 6 Next