Previous 1 3 4 5 6 7 Next 831 Replies Latest reply: Feb 27, 2014 4:47 PM by Michael Paine Go to original post Branched to a new discussion.
  • Emma Richardson Level 1 Level 1 (0 points)

    Understood.  I don't vpn into my work network and I have different ip's for the same fqdn of the mail server depending on if I am in or out of network which is why the hosts file fix will not work for me unless I change the ip whenever I go to the office or leave again - not an acceptable scenario in my book! Currently I am using Outlook for Mac just for my exchange account.  A sorry alternative but at least it works.  My tech is actually rebuilding our domain and switching over this weekend and will get rid of the .local part altogether so that should fix it for me because the internal and external servers will be then be the same and I am hoping mail will then bring in consistent server info that will allow it to connect from wherever. 

  • Scott Newman Level 2 Level 2 (220 points)

    I don't have time to read every post in this thread, but here's what worked for me.  My problem involved configuring exchange so that it would work away from my place of business (a college).  When I was on campus, there was no problem.  Off campus, the same settings simply wouldn't provide a reliable connection to the server for getting mail and I couldn't send mail no matter what.  I tried everything but since exchange essentially auto-configures, I couldn't get it to work.

     

    I set up a new account as "Exchange IMAP"  I have pretty simple needs but it appears to be working perfectly for all email needs.  It uses the same settings as are used when configuring iPads and iPhones for Exchange under IMAP.  In my case, I have to use IMAP on my iPhone to configure my iPhone's email account to connect to my college's Exchange servers.  The server names are not the same servers that are auto-configured by Exchange.

     

    I also set up an account as just IMAP (not Exchange IMAP) and that worked fine as well.  Hope this helps.  Given that my Exchange account under Lion worked perfectly yesterday and now Mtn Lion is causing these problems, I would place the blame squarely on Apple's shoulders.

  • RSpaight Level 1 Level 1 (5 points)

    There's clearly a problem here -- I was able to resolve it in my situation, and this might be helpful to others though I don't expect it will be universally helpful.

     

    We recently upgraded from Exchange 2007 to 2010, but the 2007 server is still there dealing with a couple of legacy requirements. After Mountain Lion got set up, the Internal Address got set to the internal address of the Exchange 2010 server, but (and this took me a while to realize) the External Address got set to the 2007 server. How that happened is anyone's guess. In that state, Mail kept trying to hit the 2010 Internal Server and failed (because I'm home).

     

    I put the external address for the 2010 server in the field for both Internal and External Address, and things starting working.

     

    At least for now.

  • RSpaight Level 1 Level 1 (5 points)

    Oh, and this only sticks until the app is restarted, then all the bad info comes down again. I'll have to bug the SAs tomorrow to see if the autoconfigure settings in Exchange are incorrect.

  • Scott Newman Level 2 Level 2 (220 points)

    Post removed...I was replying to an older message.  It wouldn't have made any sense.

  • Joseph Romano Level 1 Level 1 (5 points)

    Okay.  I THINK I got my Exchange account to work just now.  Here's what I did.  I went into Utilities and found the Keychain Access App.  Got all keychains related to the Exchange account deleted.  Also deleted the exchange account directly in Mail app. Preferences section as well.  Restarted my iMac.  Instead of logging into the Exchange account in the Mail app., I went into System Preferences and found the Mail, Contacts and Calendars app.  I set up the exchange account in there rather then in Mail.  Right now, it seems to be working! 

     

    I wasn't using the Exchange for anything but e-mail, so it didn't occur to me to go this route at first.  Anyways, I just deselected the Contacts, Calendars and Notes check boxes.  The Mail is working fine.

     

    Hopefully these steps work for others with a similar problem.  Other than this, Mountain Lion has been a joy to work with!  Peace!

     

    Joe

    iMac (2010)

    OSX 10.8

  • smittyrocks Level 1 Level 1 (10 points)

    Joseph,

    Now close mail app. Wait a few seconds, reopen mail app, wait a few seconds, open mail preferences, check server name.  Did is switch a different server name?

  • Joseph Romano Level 1 Level 1 (5 points)

    Bummer! I did what you said and it doesn't connect.  Guess I'm not done after all.

  • Joseph Romano Level 1 Level 1 (5 points)

    Guess I could leave Mail app. open all the time!

  • smittyrocks Level 1 Level 1 (10 points)

    Sorry to burst your bubble. I've been working on finding a solution for two days. The solution is Apple has to fix it.

  • smittyrocks Level 1 Level 1 (10 points)

    That won't work either, if your device ever goes to sleep, the issue will reoccur upon waking up.  I thought that would work as well, but when my MacBook comes out of sleep mode, Mail reconnects to server and switches account server name again.

  • Joseph Romano Level 1 Level 1 (5 points)

    I'm glad you told me Smittyrocks.  I guess you tried everything others have posted so far? (I was going to look at the IMAP option next, but if you've already tried, I won't waste my time.)

     

    Joe

  • smittyrocks Level 1 Level 1 (10 points)

    I believe exchange imap or just imap will work. I haven't tried that yet. I'm solely working on exchange so far. As this is wasn't present in Lion, it shouldn't be present in ML either.

  • mgamadeus Level 1 Level 1 (0 points)

    i'm asking myself when apple reacts on that, since a lot of people are using exchange in companies - and i like to work on macs - and i push our ceo tu buy more macs, yeah, and then such a crap...

  • mgamadeus Level 1 Level 1 (0 points)

    i think they simply had a deadline to go out on since the announcement was made it will be shipped untils the end of july.

Previous 1 3 4 5 6 7 Next