Skip navigation

Exchange under Mountain Lion

290584 Views 831 Replies Latest reply: Feb 27, 2014 4:47 PM by Michael Paine RSS
  • wangenent Calculating status...
    Currently Being Moderated
    Sep 30, 2012 11:05 AM (in response to m@zo)

    Looks like this was fixed in 10.8.2: "Resolves an issue that may cause the "Enable Autodiscover" checkbox to always remain checked".

  • sceptic Calculating status...
    Currently Being Moderated
    Sep 30, 2012 11:31 AM (in response to wangenent)

    It was 10.8.2 that broke it.

     

    I've given up.

     

    My problem is that my workplace doesn't offcially support OSX so I have absoluetly no chance of asking then to address this their end.   It's a great shame beacuse it was extremely useful being able to sync my work emails and calendars accross my personal devices.   I'll just have to use my sh*tty work laptop when working from home, which almost makes me physically ill to look at.

     

    I can't even attempt any more solutions or workarounds because although Mac Mail says that it cannot find the server it's obviously connecting enough to give me failed password attempts and locks me out of my account.

     

    Apple referring people to their companies IT department is almost pointless.   How many people have enough influence to make such a request?   Most people in this thread suggesting solutions seem to work in their companies IT department already.

     

    I'm not unreasonable, I fully appreciate that ensuring compatibility between a multitude of platforms and operating systems must be a thankless task.  However for something as fundamental as mail I think that it is essential that the resources are made available to ensure all issues are acknowledged and addressed as a matter of urgency.

     

    Very very poor I'm afraid, Apple. 

  • Slartibartfest Calculating status...
    Currently Being Moderated
    Sep 30, 2012 1:14 PM (in response to m@zo)

    Ok,

     

    I was experiencing the exact same symptoms of the problem being described by other posters.

     

    However I have managed to solve my problem so I share the solution which worked for me with others in the hope that it might help someone.

     

    I followed steps described by others to untick the autodiscover box (which doesn't seem to stay unticked for me either) and I have also over-written the internal and external server addresses but the solution for me was simply to change the username from the format "username" to format "domain\username" where the domain is the domain in which the exchange server operates and the username is the usual windows username for my active directory account.

     

    Before the 10.8.2 update Mail used to work quite hapily without the domain name being entered as part of the username but now it doesn't.

     

    If this succeeds for anyone else, please post here.

  • Dämon Calculating status...
    Currently Being Moderated
    Oct 2, 2012 7:11 AM (in response to Slartibartfest)

    > If this succeeds for anyone else, please post here.

     

    Thanks, Slartibartfest.

     

    The measure of modifying the user name by adding the domain like described does not suffice to remedey the problem for me.

     

    Calendar and Contacts settings for my Exchange account still show the same, self-modifying behaviour to me, now that I added the domain name as you described and deleted the old entries (those without domain) from the keychain.

  • Bohaty_MD Calculating status...
    Currently Being Moderated
    Oct 2, 2012 7:12 PM (in response to m@zo)

    Slow e-mail loading and e-mails disappear for me as well. Just wanted to jump on board so apple gets this resolved asap. PLEASE HELP APPLE! The exchange account works great on my iPad and iPhone but not my MacBook Air. Really frustrating. Disappointed Apple.

  • Dämon Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 3, 2012 4:03 PM (in response to Dämon)

    Reporting back in: got it all fixed thanks to all the suggestions here.

     

    Situation: my Exchange server uses a certificate for a different FQDN, than it is required for me to use for access from the Internet.

     

    My symptoms were: Exchange Calendar and Contacts internal and external server settings kept on "self-modifying" from the name I configured in the configuration dialogs to an inaccessible (and via DNS also unresolvable) hostname, that the Exchange server's X.509 certificate was issued to (CN). This self-modifying behaviour appeared like this: 1. I change the settings of the internal / external servers to the working ones, can verify the access, 2. quit the application, 3. restart the application, experience "self-modified" server settings to non-functional results, probably "auto-configured" based on the Exchange server's X.509 certificate properties. As a result Mail access was always possible and only the Calendar and Contacts access was repeatedly getting lost, which was a huge annoyance.

     

    Following measures were taken:

    * added Domain in front of username in Mail account settings of the Exchange account

    * deleted the Exchange entries with domain-less usernames from the keychain

    * inactivated the "Auto Discover Service" in Mail account settings of the Exchange account

    * corrected all settings once again, quitted the affected applications

    * also restarted the Mac

     

    Result: configurations now keep being intact. Both seems to have worked on two almost identically configured MacBooks (Air and Pro 15, late 2011), latest and greatest software installed.

     

    I didn't verify which of these measures that I've taken and listed above were really the ones responsible and necessary to achieve the desired results - all I can say, it works now, and thank you!

  • simwit Calculating status...
    Currently Being Moderated
    Oct 4, 2012 11:53 PM (in response to Dämon)

    FINALLY IT WORKS!!!

     

    Apple released OS X 10.8.2 supplemental update yesterday. I updated and restarted my macbook last night. I didn't think anything of it but when I restarted Mail a window flashed up saying Mail had been updated and some progress bars flashed across my screen. I took this as a sign as I have been trying everything mentioned on this forum for each update from Apple.

     

    Just to be sure I followed all the instructions in the last post:

    1. Cleared Keychain of any mention of the Exchange account

    2. Added the mail settings through System Preferences->Mail,Contacts & Calendars making sure the "User Name" was prefixed with the domain, i.e. domain\username

    3. Went into Mail Preferences unticked "Use Autodiscover service" an then entered the exchange server under both "Internal Server" and "External Server"

    4. Restarted OSX (before clicking on the Exchange Inbox)

    5. Opened Mail and clicked on the Exchange Inbox and voila...

     

    The Calendar and Contacts also seem to work too. Very happy.

  • Michael Paine Level 2 Level 2 (315 points)
    Currently Being Moderated
    Oct 7, 2012 1:16 AM (in response to simwit)

    Just did the supplementary 10.8.2  update. My single Exchange account was working OK before the update and is still working afterwards (fingers crossed). When Mail started up it was a bit alarming because it said "Welcome to Mail"  but then it explained that the Mail database would be upgraded. This took less than a minute (with over 8,000 emails!) and then the Mail window came up normally.

     

    At least this indicates that the supplementary update is fixing something in Mail. I hope this rectifies the problems that others have been having. It is important to follow simwits tips if you have been having problems as the previous version of ML may have corrupted your settings.

  • tyr0ne Calculating status...
    Currently Being Moderated
    Oct 7, 2012 1:25 AM (in response to simwit)

    Unfortunatly .. This took so long that i had to migrate a clients exchange enviroment to an linux imap

  • AndrewK457 Calculating status...
    Currently Being Moderated
    Oct 7, 2012 4:46 AM (in response to m@zo)

    Just downloaded the new version of ML, but I still can't even add my exchange account to mail. Everything is setup correctly, any ideas??

  • FortKnUX Calculating status...
    Currently Being Moderated
    Oct 8, 2012 5:45 PM (in response to m@zo)

    I fixed it by removing the following directories:

     

    ~/Library/Mail

    ~/Library/Containers/com.apple.mail

     

    Notice that com.apple.mail is a directory.

     

    I did have other types of email configured but I was ready to redo from scratch them for the sake of fixing exchange and now it works like it used to.

  • Slartibartfest Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 8, 2012 5:55 PM (in response to FortKnUX)

    Woa FortKnUX,

     

    Won't that delete all stored mail from every account you use? (including non-exchange accounts which may be working just fine)

    Doesn't sound like a great idea to me unless you are desperate. Just gotta hope your download cap isn't too low!

    Beware! This wasn't necessary for me certainly. My setup works fine again now without this nuclear option.

     

    Slarti

  • FortKnUX Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 8, 2012 6:10 PM (in response to Slartibartfest)

    Nothing was working for me and I just got tired of waisting time.  I am yet to see if the the fix holds.

  • pmdworks Calculating status...
    Currently Being Moderated
    Oct 8, 2012 7:59 PM (in response to simwit)

    Simwit et al. nailed it. 

     

    This got so bad I had to email Tim Cook and like magic a few days later it was fixed, thanks Tim, Simwit, and others who contributed to this work around (I have a hard time calling it a fix)!

     

    Note that in addition to Simwit's summary, I had to go into Apple Calendar and manully update the server address for the exchange calendar to be mail.companyname.com (our external address format) since it autofilled with the same local server id that was autofilled in Apple Mail which needed to be replaced, otherwise dead on for me.

  • Userfeedback Calculating status...
    Currently Being Moderated
    Oct 9, 2012 1:10 AM (in response to simwit)

    Simwit

     

    I woud like to retry it. Can you please help me with your suggestions, as I am not an expert.

    re 1: How can I clear a keychain

    re 2: I am nut sure, what has to be used as domain. Is it the web address of my hosted exchange provider?

    Thanks for the feedback.

1 ... 39 40 41 42 43 ... 56 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (62)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.