Previous 1 43 44 45 46 47 Next 806 Replies Latest reply: Feb 27, 2014 4:47 PM by Michael Paine Go to original post Branched to a new discussion.
  • TominStafford Level 1 Level 1 (0 points)

    Windows has its own irritations and I enjoy pretending I'm immune to all the viruses and malware out there. I'm not mad enough to ditch Mac just yet. Plus, one of the things that pulled me over to Mac to begin with was all the beautiful software from developers. I don't see as much innovation from windows developers. You're right about the work aspect though. I'm sure PC Outlook is better but for now, the Mac version works fine.  Glad MS keeps supporting it. Apple has clearly ceased development of iWork. 

     

    You now it's funny, Mail on IOS actually works great with exchange. Why not on ML? Come on Apple!

  • alexkli Level 1 Level 1 (0 points)

    You now it's funny, Mail on IOS actually works great with exchange. Why not on ML? Come on Apple!

     

    Well, that's mostly because on mobile devices there is a completely different and much more efficient & faster exchange protocol called ActiveSync. This is the one that you get with Exchange servers on iOS. Unfortunately, Microsoft won't license it except for mobile devices, so no chance to see it on a Mac. It's always funny how my exchange mails reach my phone first, usually by a few minutes.

  • BonesDT Level 1 Level 1 (0 points)

    alexkli wrote:

     

     

    You now it's funny, Mail on IOS actually works great with exchange. Why not on ML? Come on Apple!

     

     

    Well, that's mostly because on mobile devices there is a completely different and much more efficient & faster exchange protocol called ActiveSync. This is the one that you get with Exchange servers on iOS. Unfortunately, Microsoft won't license it except for mobile devices, so no chance to see it on a Mac. It's always funny how my exchange mails reach my phone first, usually by a few minutes.

     

    This doesn't explain why Exchange used to work with the Mail app on Mac only until recently. 

     

    In response to Mac blaming anyone else, unless Microsoft revoked certain rights to the Mac (which Apple would publically explain), this issue was obviously created by bad reprogramming of the Mail app.  What's taking so long to fix, can't they just revert the Mail app to an older version?

     

    Also, I am almost certain I had this problem with Lion before upgrading to Mountain Lion.  IIRC, my Exchange just got up and stopped working randomly in the middle of my Lion days - not in response to any major OS upgrade.  I remember hoping the ML upgrade would fix it.  Anyone else?

  • benveen Level 1 Level 1 (0 points)

    I bought a brand new MacBookPro with Retina screen, OS Mountain Lion pre-installed. Exchange intitially seemed to work in Mail.app but after a while stopped syncing my inbox. Apple support does not support this and advised to create a new user to test mail settings as they claimed another program might have interfered. After reinstallation my inbox synched but i had regular issues with other folders synching, mails which appeared not to have been sent but had been sent etc. Then after a few weeks my Inbox stopped synching again without any obvious reason, Apple support refuses to help as they claim it's an Exchange issue.

    I implemented Ondray's solution and it seems to work just fine, as i could not uncheck autodetect somehow. Thanks for finding this solution! I was hoping that by spending double the price for a laptop i would no longer have typical ' windows'  issues but it sees that Apple is going that way too unfortunately.

    For those depending on Exchange mail i would recommend to stick to Windows despite all its deficiencies.....

  • Mattzda3 Level 1 Level 1 (0 points)

    What is "Ondray's" solution? I searched the past several pages of this thread and found no post by Ondray. I have yet to find anything that will keep my Mail app from asking for my password.

     

     

    BTW: I was on Mt Lion for a while with Mail working before this issue started happening. Is there a chance that MS changed anything in an update to Exchange or the webmail services?

  • benveen Level 1 Level 1 (0 points)

    It appears the workaround of editing the /etc/hosts file as suggested earlier works.  For those less technically inclined this is how to do it:

     

    1. Close Mail.  Wait a few seconds and then open it back up.  Got to Preferences - Accounts.  Select your Exchange server entry and see what value ML insists upon putting in Internal Server.  Write this down somewhere.

     

    2. Open up Terminal.  Type "ping server.domain.com" (no quotes) where server.domain.com is the value that you previously used in the Internal Server setting for Mail.  If you're lucky the server will respond at least once.  Write down the IP address (xx.xx.xxx.xx).

     

    3. Open up Finder.  Select Go-Go To Folder menu.  Enter /etc in the dialog and click Go.  Find the file named "hosts".  Copy it to the  Desktop.

     

    4. Open up the "hosts" file on the Desktop in TextEdit.  At the end enter the Internal Server name you wrote down in step 1 on the left.  A few spaces over on the same line enter the IP Address you wrote down in Step 2.  Save the file and close TextEdit.

     

    5. Drag the updated "hosts" file on the Desktop back into the Finder window display the /etc directory from Step 3.  You will need to authenticate with your password.  Be sure to select the replace option.

     

    6. All the Exchange enabled apps should work now.

     

    What this does is tell the OS that "server.domain.com" should resolve to the IP address of the actual external server you want to use ... rather than the IP address it actually has.  You've basically "tricked" the system in order to get around this boneheaded change.  So far I haven't seen any issues.  Emails in the Exchange inbox sometimes disappear ... but I have the feeling that's a separate bug.  Switching from one mailbox to another and coming back often fixes this issue.  Restarting Mail seems to fix it consistently when it occurs.

  • TominStafford Level 1 Level 1 (0 points)

    Ondray's "For those less technically inclined" solution is too technical for most and WAY over the top for an app that should "just work" and for which we pay a premium.  I'm getting used to Outlook in Mac Office and actually starting to like it.  The aesthetics aren't quite there - probably never will be with MS, but it works well and that is critical.

     

    So my stand:  ditch the forum work arounds and buy a product that works.

  • bpossolo Level 1 Level 1 (0 points)

    Benveen: are you suggesting that apple denies a defect in one of their products? Impossible!

     

    I am a big apple fan but they are notorious for responding to possible bugs with "you are just doing it wrong" type statements.

  • ecarr Level 1 Level 1 (0 points)

    Been having issues with Mountain Lion Mail similar to what is described in this thread. Whenever I awoke my MBAir from sleep I would get the spinning rainbow ball consistently in Apple Mail for some time. I have zero issues accessing same accounts with iPhone / iPad and it used to work fine in previous OS X releases. In Console, it seemed to be Exchanged related due to the following error message:

     

    >>>

     

    *** Assertion failure in -[EWSGateway fetchCopyOfSyncIssuesEntryID], /SourceCache/Message/Message-1499/Message/EWS/EWSGateway.m:1853

    Didn't get a proper response for a GetFolder request on Inbox

    ...

     

    >>>

     

    I found either in this thread or a similar thread suggesting disabling Spotlight for Messages & Chats, Contacts, and Events & Reminders. At least for the last few sleep + awake cycles, the spinning ball has not occurred / been a few seconds. It sounds like there are multiple issues at play in this thread. Specific for my case, I am hoping disabling Spotlight for these specific categories fixes the painful Mail problem. Fingers crossed.

  • Slartibartfest Level 1 Level 1 (0 points)

    Have implemented the benveen/ondray(?) hostfile edit and so far it seems to be working for me. (I can't find the Ondray post Benveen refers to either but wherever it is - Thanks!)

     

    It makes sense of the fact that when connected to my exchange server via a VPN (or LAN) I had no issues but when relying on the external server (Which resolves just fine via DNS) it didn't work reliably.

     

    Apple have to recognise this problem now surely?

  • BonesDT Level 1 Level 1 (0 points)

    benveen, your instructions seem very simple, thank you.

     

    I have some questions:

     

    In Step 1, you say "see what value ML insists upon putting in Internal Server", but the value I have is mail.mycompany.com, which is a value I entered when I initially set up my Exchange.  ML isn't "insisting" on anything.  Am I missing something?

     

    So then I ping'ed it and you said "if you're lucky the server will respond at least once", but I'm not sure if the first line of the following means it responded or not:

     

    PING mail.mycompany.com (209.47.6.120): 56 data bytes

    Request timeout for icmp_seq 0

    Request timeout for icmp_seq 1

    .....[this goes on into the hundreds as I type]

  • benveen Level 1 Level 1 (0 points)

    so in your Hosts file you enter at the very end:

    mail.mycompany.com    209.47.6.120

     

    and follow rest of istructions

  • BonesDT Level 1 Level 1 (0 points)

    Yah, I tried that anyway and it didn't work.  I just tried it again, and still nothing. 

     

    Do I leave "Use Autodiscover service" checked? 

     

    Is "External Server" supposed to be "external.example.com"?

     

    Do I leave "Use SSL" checked for Internal Port = 443, but unchecked for External Port = 80?

     

    Is "Internal Server Path" supposed to be "ews/exchange.asmx"?

     

    Is "External Server Path" = "EWS/Exchange.asmx"?

     

    Thanks!

  • benveen Level 1 Level 1 (0 points)

    One of the problems is that you cannot uncheck autodiscover once the account has been set up but you overcome this to change the Hosts file. Both external and internal server is as described under 1 (your provider can give you this address, it is the same you would use to configure exchange under IOS).

    SSL checked for both internal and external, both ports 443. Server paths EWS/exchange.amsx

    restart the Mail app

  • emsi2000 Level 1 Level 1 (0 points)

    This solution worked for me very well. Include domain name + same adresses for the servers in the Accounts tab.

    Thanks.

Previous 1 43 44 45 46 47 Next