Previous 1 9 10 11 12 13 Next 358 Replies Latest reply: Mar 1, 2014 10:21 PM by lfcitz Go to original post Branched to a new discussion.
  • PSurette Level 1 (0 points)

    Well, did a clean install of the operating system about two weeks ago, and my problem looks to be resolved (fingers crossed).



  • DaveRoberts Level 1 (0 points)

    Bob Allison's fix is the only thing that has worked for me:


    The solution to this is usually very simple (or has been for all machines I have dealt with).

    Go to Network Preferences then in the lower left click the service 'wheel' icon.

    Select set service order and drag your WiFi to the top of the list. Click OK then Apply.

    Obviously, there's a bug there somewhere, because WiFi should not have seniority to the other wired network types, but there you go. This actually works.


    Just in case anybody from Apple actually reads this or care about this bug (sigh), I have also found that even with WiFi set down in the service order (as it should be), running a ping in a terminal window will keep WiFi up and running as well. There's a bigger problem in the stack somewhere, I think. This probably isn't a WiFi problem per-se.

  • Tatan21 Level 1 (0 points)

    No solution at this time...


    - Changing location is not working.

    - Reinstalling Mountain Lion is not working.

    - I can't install Snow Leopard or Lion because Mountain Lion is not supporting old OS X versions. Now Apple decides what I can install on my machine. I remember I paid USD 3.000 for my iMac and now Apple is the owner!!


    Still without Apple solution. They say "we can not do anything. Go to the store or go to the forums". In the store there is people without technical knowledge and in the forums are lots of users with the same big problem..


    Where is Apple?? Can I decide what software install on my computer??? Apple you are close to make me move to PC...

  • mbpro2012 Level 1 (0 points)

    I have been having the same problem with wifi disconnecting, unable to connect, very slow download speeds occassionally etc just as others are reporting on this and numerous other threads.  I just found this simple tip which I hadn't seen after many hours of searching.  I tried everything suggested except re-install the OS.



    been working great the last couple of hours.  let's see if it helps others as well.

  • Steve Monday Level 1 (0 points)

    New macbook pro 13 inch(just one week)

    Updated to 10.8.2. wifi is connected but no internet

    When i turn wifi off and on it works for 5 to 10 minutes.


    I've tried

    Cleared all router/Airport entries in Keychain, "forgot" all Prefered Networks, created new Location, renewed DHCP

    Changed MTU to 1453

    Router was already set to WPA/WPA2

    Updated firmware on router


    Go to Genius Bar 4 times, Not even Help~~~~~~~~~~~~~~~


    My PC is working well. Apple, Do you want me switch back to Samsung!!!!!!!!!!!!!

  • Csound1 Level 8 (46,987 points)

    What DNS servers are you using?

  • MoogNinja Level 1 (0 points)


  • Steve Monday Level 1 (0 points)

    I followed the AppleFanSite


    Added two new OpenDNS servers: &


    still stay the same!

  • fromevanston Level 1 (0 points)

    How long Apple will ignore us and test our patience???

    My work has become unbearable. I have to close the applications every time and restart my MBP to get the Internet working only for short time. Then I need to repeat everything again and again.

    No such problems with previous OS Lion and Bootcamp Windows but with Mountain Lion my work turned into nightmare.


    ps. clean install, etc. and problem is not resolved. wifi internet connection still drops constantly. ty Apple :/

  • kx2 Level 1 (0 points)

    This morning my connection wasn't working and i'm now using a wired connection.  Tried wifi and after rebooting a "few" times i finally got a connection.  I new the broadband was working as mu Linux server worked fine.  Finally found that it had changed the workgroup setting.  Reset and now working.  When it changed the workgroup setting it also couldn't get the right IP address.  Why is apple making a meal of this, my linux and windows boxes never have a network problem.  between this and apples miror displays, most expensive mirrors in the world, maybe it is time to change and get a linux laptop up and running with a decent anti glare sceen.

  • DaveRoberts Level 1 (0 points)

    Okay, even Bob Allison's fix of moving WiFi to the top of the service order has not helped in the long run. It looked like it did for a while and then... nope. Maybe I was just getting lucky.


    The *ONLY* thing that has consistently worked for me as a workaround to this is to open up a terminal window and type:

    ping <IP-address-of-my-router>


    and then let it run in the background forever. For whatever reason, that seems to keep the network stack active and things work. My hunch is that there's a bug somewhere in the power management of the network stack, that if the stack isn't kept active, something gets shut down but then isn't correctly brought back up when there is new activity. The active ping in the background keeps it from doing whatever it would normally do and therefore it keeps working. That's just my theory, and I'm probably wrong, but there you go.


    Yes, that's not a real fix in any sense of the word. It's a big hack. Apple, it's abysmal that so many people can be suffering so badly on such a high priority component as WiFi and you haven't release an über-emergency hot-patch in the first week after Mt. Lion was released. That's just horrible product management. And given the widespread nature of the outtages, exactly how many people beta tested Mt. Lion for you? I find it hard to believe that this was so subtle that it would have slipped through the cracks. Worst case, look for all the people who have posted to this thread, then have your network engineering team contact 10 of them, fly engineers to their houses to do on-site debugging, and get this thing solved and an OS update released by Christmas. Why is that hard?

  • Luke8400 Level 1 (0 points)

    With every ML update, I'm hopeful that the fix is contained, but it never is. I've found myself using Windows 7 via Bootcamp more and more, particularly when I have work to do. Otherwise I'm interrupted every 5-10 minutes because the wifi dies. I'm not sure what's more frustrating, the issue itself, or the silence on Apple's part. Infuriating.


    And many of the fixes don't work for me because I'm not using a router.

  • GypsyPete Level 1 (0 points)

    I've just tried this option - upgraded my D-Link's firmware to AF_1.65_R01. Initially it was throwing out superb stats and I thought I'd cracked it. It was even streaming HD YouTube clips when I was outdoors. I have a 2MB line and was pulling 1.76MBs dowload speeds and I was ecstatic.


    However,,, I've just tested it again and have the following results: Ping: 28ms Download: 1,44MBs Upload: 0.40MBs. Its been fluctuating unremitingly for the past couple of minutes and displays extremes - from quadruple digits (1084) for pings to abysmal download speeds of 0.15MBs


    I was hoping this wasn't an entirely Apple 10.8.2 software issue and that maybe updating the router would fix it. Apparently not.


    My MB Pro is  month old and I'm suffering the anguish of the damned - to have this beautiful machinery on my lap, but to be unable to use it fully.


    I hope Apple releases a patch/fix before the next IOS is released. Don't think I can wait till mid-2013 and keep my sanity intact

  • GypsyPete Level 1 (0 points)

    I tried that. Worked phenomenally well for about 5 minutes, now its reverted back the the same old.

  • johnboyuk Level 1 (0 points)

    Just thought I'd post my experiences here as I seemed to have fixed my issues... (well... 12 hours in so far so good)


    I have a iMac mid 2010 and since updating a couple of weeks ago to Mountain Lion have had an awful wifi connection. I tried various things I found on here and other sites, which, in isolation didnt fix my problem. What did seem to do it though was a whole bunch of them plus a re-install of Mountain Lion (though trying to downlload the installer again was fun!)


    What I did....


    reset PRAM

    boot up into the utilities thing (command R?) and repaired disk, and repaired disk permisions

    Deleted all wifi locations from the network preferences panel

    Deleted all wifi passwords from the Keychain App

    Trashed the SystemConfiguration folder from Library>Preferences


    Then re-installed Mountain Lion (not a completely clean install... just the normal one)


    So far so good... hope it helps somebody

Previous 1 9 10 11 12 13 Next