Previous 1 11 12 13 14 15 Next 358 Replies Latest reply: Mar 1, 2014 10:21 PM by lfcitz Go to original post Branched to a new discussion.
  • Csound1 Level 8 (46,965 points)

    If you are using WPA2 security on the router, change it to WPA.

  • wclyffe Level 1 (5 points)

    I wish I could try that, but this is in an office where I have no control over the settings of the router, and of course, no one else has a problem at all. I notice that when I am backing up to the cloud I always get discvonnected several times in the process forcing me to turn wifi off and back on to re-establish a connection to the internet. It's ridiculous that this is even a problem on a brand new computer.

  • Csound1 Level 8 (46,965 points)

    If you can't adjust the router may I suggest a Cat 5 cable connection, far more reliable and much faster than wireless.

  • wclyffe Level 1 (5 points)

    Yeah, I'm thinking you're right, but it's such a shame that Apple is making an OS that has this problem when no one else is. I'm guessing it could be set to "G" instead of "N" and that would solve the problem for me, but that's nuts for everyone else.

  • Csound1 Level 8 (46,965 points)

    Why guess when you can look and see?


    Hold the option key and click the wifi icon in the menu bar, your connection details will be displayed.


    Try making a new connection on your Mac.


    Open System Preferences>Network, click the + sign at lower left, select WiFi, give it a name (office?) and configure it for your office network.

  • wclyffe Level 1 (5 points)

    Yes, thanks...a great tip! The router is 802.11N and it's WPA2 Personal for security. I could ask them to make a change, but why should they. This is ridiculous!  Thanks again!

  • Csound1 Level 8 (46,965 points)

    wclyffe wrote:


    Yes, thanks...a great tip! The router is 802.11N and it's WPA2 Personal for security. I could ask them to make a change, but why should they. This is ridiculous!  Thanks again!

    And this issue (I have seen it twice) only appears when the bulk of the network clients are PC's and WPA2 is the security chosen, changing to WPA is simple and does not affect any other clients.


    Plugging it in with a wire is even simpler and as I said, a far superior connection.


    Or try making a new connection, I posted instructions above.


    All I can tell you is that if you do nothing, it will stay the same.

  • wclyffe Level 1 (5 points)

    Thanks so much for your help!!

  • Csound1 Level 8 (46,965 points)

    wclyffe wrote:


    Thanks so much for your help!!

    You're welcome.

  • DaveRoberts Level 1 (0 points)

    johnboyuk wrote:


    What I did....


    reset PRAM

    boot up into the utilities thing (command R?) and repaired disk, and repaired disk permisions

    Deleted all wifi locations from the network preferences panel

    Deleted all wifi passwords from the Keychain App

    Trashed the SystemConfiguration folder from Library>Preferences


    Then re-installed Mountain Lion (not a completely clean install... just the normal one)


    So far so good... hope it helps somebody


    What is the consequence of deleting the SystemConfiguration folder in Library>Preferences? Does OSX rebuild it back to a default level, or does it require a reinstall at that point? I have already deleted the Wifi locations, deleted passwords, etc., but nothing has worked so far. I'm ready to kill the SystemConfiguration folder but I'm nervous that I'll have a bit of a lobotimized machine after that.


    So, can anybody speak to that?

  • johnboyuk Level 1 (0 points)

    it will just get rebuilt - no need for a reinstall... just restarting should create a new one

  • irtriskit Level 1 (0 points)

    I just got a new MacBook Pro a month or so ago and it came with Mountain Lion. The WiFi and Ethernet connections work fine where I work and on a separate network we maintain here. However, when I take my laptop home, the WiFi and Ethernet don't work. It shows a connection and an IP address, but I can't resolve any host names. I can ping IP addresses like, but pinging gives no results. If I disconnect and reconnect, I can sometimes get it to resolve one host before the network stops working. And that's just it, it KILLS my network. If I disconnect my laptop from my network, everything works fine, but as soon as I connect my laptop, no device on my network is able to resolve anything.


    I have tried every solution in this thread and nothing has worked. Using a tool on a separate computer on my network shows that my laptop is spamming it with weird traffic - like DNS flushes and whatnot. So my theory is that my computer is spamming everything to the point that nothing works... like a denial of service attack.


    Does anybody have any feedback on this? I don't know why it works at my work, but not at home. The other network I've tried uses the same model of router and it's fine. I tried updating firmware and that did nothing. It behaves the same way whether it's a WPA or WPA2 key. My cable modem has a wireless router built in which I've tried and it does the same thing as the standalone router.


    This is really frustrating. I could just go back to Lion or Snow Leopard, but that seems like a ridiculous solution. I can't believe Apple hasn't released a fix for this with as many people that are having trouble.

  • jawt Level 1 (0 points)

    Just go back to Lion, it works.


    It seems Apple is not interested about this "challange" as "problem" might be your WLAN basestation...

  • kx2 Level 1 (0 points)

    It's not only wifi that has the problem, changed to network cable and still have problems.  i can connect to the router, every other machine on the home network can connect without any problems but not so the mountain lion crap.  I hope everyone has given feedback.  Do you know if your are really fed up you can just click the back button and send it again and again and again.  How many can you send !

  • Rustproofbug Level 1 (0 points)

    Alright guys. I bought a new iMac mid 2011 on Dec 2, 2012. It came in about a week later. I noticed the WiFi issue. For me it would connect, then after a while, somtimes ten somtimes an hour, it would disconnect. The thing in the corner would show had it is connected, with full bars, but on Safari it wouldnt load pages, iTunes would load, Mac App Store wouldnt load, and all that crap. I scoured for a confirmed fix, but no one had anything concrete. I ruled out my router being bad b/c my iPad, Xbox, old MacBook with Lion, and my awesome Blackberry, never had a problem with it. My Xbox does from time to time, it just dissconnects but the network card on that thing is kinda old. So i decided to call up Apple support and chit chat with them. We trouble shooted it, I told the chap that i read through all these forums and blah blah. He had me reset the PRAM and whatever the other one is. At the end he said give that a go, if it still occurs make a Genius Bar appointment and have them take a look. Well about 15 minutes after i got off teh phone with them it did the thing where it disconnected. I, reluctantly, made a Genius Bar appointment; I just didnt feel like walking around the mall with a freaking iMac in my hands. I felt pretentious and stupid and people stared. It was also heavy and my arm was tired. I had the fellow at the Genius Bar take a look at it. He said they would hold onto it, do some crap and change the out the Airport card. I believe what they did was go on the website called and run that overnight. Pretty interesting site btw. I dont know whos idea it was, or why they thought it was a good one, but good on them. I just got my computer back today, everything is going good so far. So if your computer is still on warrenty or Applecare, I would sugguest you try that. So far I have not had an issue with it, and everything seems to be running swimingly. If not, it will cost about $108 for a new card + service.


    TL;DR Make a Genius Bar appointment and ask them to put a new airport card in. I think it did the trick for my machine.

Previous 1 11 12 13 14 15 Next