Previous 1 13 14 15 16 17 Next 358 Replies Latest reply: Mar 1, 2014 10:21 PM by lfcitz Go to original post Branched to a new discussion.
  • pdbowers Level 1 (0 points)

    Try this, it worked for me. If you are currently using WEP on your wireless network, go into your router settings and change  your wireless setting to WPA 2. I did this after talking to Apple Support, and after doing this, it has worked perfectly.



  • rheba Level 1 (0 points)

    I have only Hughes satellite service unfortunately. I am not surfing at all but I appear to be using up all of my daily allowance. I have already been shut down by Hughes for exceeding download allowance.

    Does anyone know whether something is running online in the background that I can't see and, if so, how to shut it off?

  • davidgrantaustin Level 1 (0 points)





    After months of messing around with PROMs, Wi-Fi router settings & channel settings, Mac MTU & channel settings, Router FW updates, the simplest fix of all...your fix... has ACTUALLY fixed this issue.


    I don't need to change from 2.4GHz to a 5GHz network, I was already running WPA2.


    N.B. - If any one is running WEP, you should just consider disabling it altogether as it is very easily crackable. Don't believe me. Google it. If your router doesn't support WPA2, then it is time for a new router. If your mac doesn't support WPA2, then it most likely can not run Mountain Lion.


    Basically, it seems that Mountain Lion (upon coming out of a sleep state) looks at the "service order" list and attempts to connect using the first thing in that list. In this case, the default order is: 1.) Bluetooth DUN, 2.) Firewire, 3.) Ethernet, 4.) WiFi.


    To be honest, from a probability standpoint of consumer usage, I would quite confidently say, that list is almost inverse.


    The absolute most common method of internet / network connection for almost any device running OS X 10.8.2, should be WiFi, then Ethernet, and as a stretch, someone using Firewire to move some files via Mac-to-Mac direct connect.


    With more an more Mac Book Pros and Mac Books out there, perhaps some poor entry-level programmer thought that Bluetooth DUN (Dial-Up Network) protocol should be THE most important and hence primary connection menthod. Not sure about you, but the last time I used a dial-up script it was for ADSL when I lived in Taiwan... 9 years ago.


    Bluetooth DUN, which is not be confused with using your phone as a "WiFi Hotspot", which IS becoming quite common with people moving to 5GB data plans as well as shared family data plans, is probably helpful for the 0.001% of the Mac computer owning population that lives in areas where dial-up (via cell phone) is the ONLY method for getting on the internet. I am thinking, serious "3rd world" action or very remote sites within N.A. where you only have a cell connection with voice service only (no EDGE, GPRS, 2G, 3G, 4G/LTE).


    This may be a cause as to why some folks are seeing some random improvements when they take Bluetooth devices (include Apple's own Magic Mouse) out of the range of the Mac.


    So, there is something that happened in Mount Lion and that something is it obey's (unconditionally) this "service order" list and since WiFi was not listed first (by default), it will tell the network manager to just keep trying to make a connection via Bluetooth DUN while your WiFi taskbar symbol at the top just keeps looking to re-establish the last connection it had, but is unable to see anything - because the network connection has now been handed over to the Bluetooth device in  your Mac which keeps looking for someone to put in a PIN into their Bluetooth cell phone to establish the connection.


    I believe this same solution will solve other issues reported with Ethernet connections. Just move Ethernet to the top of the "service order" and when your computer comes out of sleep, it will re-establish the same Ethernet connection with the same DHCP or hard-coded IP address it had before going to sleep.


    I sure hope this message makes it out to others that have been plauged with this issue.


    If my continued testing results in anything other than pure success, you can believe that I will be back here to make an update to this post.


    Best Regards,


  • Csound1 Level 8 (46,900 points)

    davidgrantaustin wrote:


    Basically, it seems that Mountain Lion (upon coming out of a sleep state) looks at the "service order" list and attempts to connect using the first thing in that list. In this case, the default order is: 1.) Bluetooth DUN, 2.) Firewire, 3.) Ethernet, 4.) WiFi.


    To be honest, from a probability standpoint of consumer usage, I would quite confidently say, that list is almost inverse.


    The Service Order list is by user choice, you can change it: (see below)


    Screen Shot 2013-01-19 at 4.03.26 PM.png


    In System Preferences>Network.

  • Austin.Sanderson Level 1 (0 points)

    I'm still not convinced that everyone here is experiencing the same issue.


    If I am understanding correctly, the major problems presented are:


    1. slower than expected network performance, dragging, etc.
    2. no auto-connect to wireless out of sleep (due to service order issues)
    3. random dropping of wireless signal


    Most of these questions have been answered, but I think they require some further investigation and definition for us to really know for sure.


    With problem 1, I'm not convinced that changing your network security protocols is really going to help the issue. I am on a WPA network at my home, and at work WPA2, and I am still having slow performance in both places. Not only that, but most of my users on Mountain Lion are experencing the same thing on WPA2 Enterprise network. In reading further, I am wondering if some of the complaints we are seeing are specific to Safari. I don't seem to be having problems with Firefox loading pages, and many other people are claiming to have better success with Chrome than Safari right now. Also, file downloads run at an acceptable speed. I'm not sure what other Internet lagging issues people may be having. Can anyone else speak to this?


    With problem 2, many people (Including Bruno above) have it right when resetting the service order. Once I did that on my Macbook Retina, I saw the auto-connect issues go away..... UNTIL recently. The problem has resurfaced in a very strange and different way. The problem is no longer that it will not attempt connecting to wireless. For example, coming out of sleep, my laptop does not connect to my first listed wireless network anymore. This was not the case a couple of weeks ago. I have not seen a pattern yet, as it seems to be random and happened both at home and work (in some cases trying to connect to an open wireless network that I've never used). Also, resetting the service order has not resolved my users issues with wireless dropping, so it has nothing to do with Bluetooth interference in that case, especially considering we are using a 5gHz band. Perhaps, this problem is totally unique from everyone else's. However, the one particular user in question was having the issue straight out of the box, 15" Macbook Pro Retina. I've tried all the tricks including a reinstall, so I did my due diligence.


    With problem 3, I'm still not convinced this is not a design flaw in 2012 Macbook Pro Retina machines. Everyone has wireless issues, and many are unique or specific to their home configurations. However, what I have seen (and confirmed) is that some users with the MBPretina are experiencing these issues across networks of different types (WPA2, open, etc). So, we cannot even say the problem is specific to the type of network. Again, it would also have nothing to do with blueTooth interference, since we are talking about 5gHz bands in this case. I, personally, have seen wireless drop on my own laptop, and I am not using Bluetooth devices when it happens. I have confirmed packet loss by running WiFi diagnostics on a 5gHz band; in the same case, I verified that the RSSI and transmit rate was on par with what it should be. This should rule out any concerns people have regarding signal strength or interference.


    All in all, I think the biggest issue, and perhaps the one still truly unresolved, in the random dropping of the wireless. I am waiting for more information about 10.8.3 in hopes that they are really addressing THAT part of the problem.


    Frankly speaking, it took some convincing to my user that the problem was with Apple and not in my ability to do my job. Amazingly, people think Apple is perfect.



    Frustrated support person

  • Austin.Sanderson Level 1 (0 points)

    If you are a MBPretina user and experiencing wireless issues, see

  • Luke8400 Level 1 (0 points)

    The only thing that has worked for me in the months of having this problem (wifi frequently going in and out) is turning off Bluetooth. I tried it after the last few posts that seemed to imply BT being the root cause, and the solution seems to have far. Thankfully I don't need BT for anything. I'm glad I finally found a solution, but it's still inexcusable for Apple to remain silent on a widespread issue that cripples such a basic function.

  • Luke8400 Level 1 (0 points)

    Nevermind. Turning off BT isn't a fix.


    It was doing fine when I had an active torrent going, but now it's acting up again this morning. It seems to die after more than a few seconds of inactivity.

  • Robert Zieske Level 1 (0 points)

    To everyone that is experiencing wifi issues, I concur -- it is beyond frustrating. I am writing this on a July 2010 iMac which had the same fail-to-connect from sleep issues beginning with Lion. Finally after months of manually reconnecting, Apple published a fix. I waited until 10.8.2 was out before moving to Mountain Lion and I cannot believe that I was this stupid to do so. I thought surely, Apple could not make this same mistake again, right?


    My wifi will not connect / stay connected /randomly drops. I have tried numerous suggested "fixes" and none work. I have been using Apple computers since a Mac II I began with around 1990. I have put up with decades of all the derision of being a Mac user, having to buy compatible hardware and software mailorder, until of course Apple got wide-spread cool and $uccessful with non-computer products.


    The very company that wants my entire digital life on iCloud servers can't keep my internet connection alive when they publish new OS software. I am unbelievably dissapointed. I guess Steve was serious when he said  “We’re going to demote the PC and the Mac to just be a device.”


    I am writing this on a July 2010 iMac, connected via Ethernet cable.

  • CT Level 6 (17,545 points)

    Can't confirm.

  • dedge.guarim Level 1 (0 points)

    I agree with Austin, changing to WPA didn't solve the issue, as i was already using this encryption and tested other encryptions too on router. BTW i'm using Linksys E1200 with the latest firmware 2.0.04.

    Agree also that Bluetooth maybe not be the cause, works for some time, then slows down… but it helps for now.


    (I will test Firefox more, but be aware of Google Chrome, it almost killed my CPU.

    I can't remember if i was on a website with flash, or several tabs, but the temperature went to 100o Celsius on the CPU. Uninstalled it and everything back to normal. Now i always keep activity monitor on, when fans begin to make noise, i open and see which application is demanding to much processing of CPU. Hope they have fixed it, it was my preferred browser.)

  • DaveRoberts Level 1 (0 points)

    OK, so I ended up replacing my access points with Airport Express and Time Capsule. It was the expensive route, but I wanted the Time Capsule anyway. Everything now works well.


    But I shouldn't have had to do that. To repeat, everything I tried fiddling with settings did NOT work. I was having problems on both an 18-month-old MacBook Pro and a brand-spankin'-new-for-Christmas iMac. Same issues and same symptoms. I disabled all manner of things, reset my configs, etc. Nothing worked. The only thing that would function as a workaround was to run a ping command in a terminal window and keep it going continually.


    The MacBook Pro functioned well with Snow Leopard and Lion and the same old access points. No issues. Install Mountain Lion, and things went to ****. There is a definite problem with Mt. Lion's WiFi stack. And whatever the problem is, it doesn't manifest itself with certain access points (e.g., Apple Airport works fine).

  • wclyffe Level 1 (5 points)

    If you'll look back at my previous posts in this thread you'll see my setup, and I'm now happy to say, I recently solved the wifi dropping problem, but not with any idea I found on this thread. In the end, I got the IT department at our company to isolate the issue and the only thing that worked was to replace the access point (router) with a different unit from a different manufacturer. Even after running the latest firmware update on the router it still did not function correctly.


    I have a brand new MacBook Pro running OS10.8.2 that works fine on my home router (Airport Extreme) and would work on several other routers with no problem, but the one at work would disconnect me anytime I tried to backup a large file to the cloud or download a bigger file. This happened every 10 minutes or sometimes even more.


    The airport card in my laptop was checked at the Genius was operating perfect. They could not figure it out so I tried everything listed here including a clean install....none of it worked! The bottom line was that the router at work would not function dependably with Mountain Lion. The IT guys who handle thousands of computers (PC's & Macs) at the studio said they have not been able to solve it with Mountain Lion except by exchanging the router with a different brand. They have followed this thread, too and tried many ideas listed here!! 


    This is ridiculous, and Apple's lack of response is what angers me the most, but I'm happy it finally works and its really fast as well. Last thought, even when the old router would work for a few minutes it was never able to reach these speeds which also confirms it was not relating well to Mountain Lion's handling of the connection.


    See results attached:


  • davidgrantaustin Level 1 (0 points)

    After 3 days of testing on my wife's iMac 2009 Fall 21.5" (8GB RAM, TWC Road Runner is my ISP, D-Link DIR-825 is my wireless router, 2.4GHz is the band I select) after making a change to the "service order", I have had ZERO issues!!!


    This iMac shipped with Snow Leopard, then I upgraded to Lion, then I upgraded to Mountain Lion. I did not observe the WiFi reconnect issues after coming out of sleep until Mountain Lion was installed.


    While I am sure there are other fixes that include going out and buying new Apple products or other brand routers, I refused to go to such lengths.


    It was Bob Allison's recommended fix that resulted in my now experiencing zero issues. Others may be experiencing other issues, such as WiFi drop out, which may not be fixed by this approach, however, for the issue I was experiencing.


    I would encourage others on this thread to try this fix and report back to this forum.



  • wclyffe Level 1 (5 points)

    ps. I forgot to add in that lengthy explanation above that no one else was having problems working with the original router except for rme running Mountain Lion. There were several other Macs, but they were not running the latest OS.

Previous 1 13 14 15 16 17 Next