Previous 1 2 Next 22 Replies Latest reply: Jul 31, 2014 11:39 AM by David Gross2 Go to original post
  • angel_light Level 1 Level 1 (0 points)

    Hi all,

     

    Smart Mailboxes disappeared one day randomly (I think is due to iCloud-Document and Data Sync), or when creating new smart folders. If that is the case, I have checked these two files and discovered the following:

     

    SyncedSmartMailboxes.plist

    SmartMailboxesLocalProperties.plist (no change required in this file)

     

    I found that the data and filter rules are all intact, what is causing it not to show is due that the value for "mailbox type" is incorrect.

     

    Close Mail,

    Open up SyncedSmartMailboxes.plist,

    for more technical savvy people (can do a find/replace), ensure this for relevant mailboxes:

     

    <key>MailboxName</key>

    <string>mailboxname</string>

    <key>MailboxType</key>

    <integer>0 or 7</integer>

    7 - top level smart mailbox/folder

    0 - sub level smart mailbox/folder


    FYI:

    <key>IMAPMailboxAttributes</key>

    <integer>1 or 2 or 17 or 18</integer>

    17-top/mailbox

    18-top/folder

    1-sub/mailbox

    2-sub/folder

     

    *sub - any level that is non-top,

     

    One of my smart mailbox within a smart folder has its <key>MailboxType</key> set as 7, which is incorrect. That's why it "disappeared" in mail osx.

    By changing it to '0', the smart mailbox reappear upon mail launch.

  • Patrick Gibson Level 1 Level 1 (95 points)

    Apple marked the bug a duplicate of 10535951. 10.9.2 did not resolve this issue.

  • Daniel Sonnenfeld Level 1 Level 1 (20 points)

    Losing all my smart mailboxes on my home iMac was a combination rceiving an new Macbook Pro with System preferences -> iCloud:

     

    1) Documents & Data  checked -- so I could sync Preview docs and the like

    2) Mail turned off -- because I don't want to mix up the Mail accounts used on both machines

     

    As a result, iCloud sync'ing kept wiping out my  iMac smartmailboxes with the (empty) smart mailboxes on the MacBook

     

    To fix this, I copied over  contents between two files on my home iMac, using a Time Machine backup of SyncedSmartMailboxes.plist:

    from: ~/Library/Mail/V2/MailData/SyncedSmartMailboxes.plist

    to:  ~/Library/Mobile Documents/com~apple~mail/Data/MailData/ubiquitous_SyncedSmartMailboxes.plist

     

    I've also filed a suggestion with Apple that smart mailbox info should be stored with the iCloud -> Mail setting, and not iCloud -> Documents & Data.

  • Patrick Gibson Level 1 Level 1 (95 points)

    Thank you! That was a total help. I discovered that my ~/Library/Mobile Documents/com~apple~mail/Data/MailData/ubiquitous_SyncedSmartMailboxes.plist was 0 bytes. I overwrote this file with the locked file I've been using, and so now each launch of Mail just gives me this file instead of the 0 byte one it had.

     

    On your suggestion, I disabled iCloud sync for Documents & Data. This allowed me to make changes to my Smart Mailboxes. I then backed up the file (because iCloud) and turned on Documents & Data syncing and relaunched Mail. To my surprise, it had the updated smart mailboxes; however, not to my surprise, any changes I make are once again lost.

     

    So, at least now there is a cockamamy work-around should I need to update my smart mailboxes.

     

    I added the same request to my radar bug report that these settings should be part of the iCloud -> Mail setting instead of Documents & Data.

  • Bryrock Level 1 Level 1 (80 points)

    I've been on Mavericks since it was released.  Suddenly, today, experienced a variation of this disappearing smartboxes problem—the one where they're all replaced with one smartbox named "Today."

     

    The Patrick Gibson solution worked for me.  My SyncedSmartMailboxes.plist file is now locked, but my smartboxes have all returned.

  • Our tiny Planet Level 1 Level 1 (0 points)

    Congratulations, Edouard!  You solved it, indeed!  Thank you so much for your effort and for taking the time to post an articulate set of instructions. 

     

    Please fix this incredibly annoying problem, Apple!

  • Bob Stern Level 1 Level 1 (5 points)

    Based on David Sonnenfeld and Patrick Gibson's clues, I recovered my smart mailboxes and rules (all of which had disappeared) by:

    1. Quit Mail

    2. In OS X Prefs > iCloud, un-tick "Documents and Data", then click the "Delete from Mac" button.

    3. Tick (re-enable) "Documents and Data".

    4. Launch Mail.

  • David Gross2 Level 1 Level 1 (0 points)

    The following solution just worked for me. No need to turn off Documents & Data in the iCloud control panel.

    You do need an older copy of the file,

        ~/Library/Mail/V2/MailData/SyncedSmartMailboxes.plist

    because the current is basically empty, destroyed by an evil Apple mistake. I found my file in yesterday's TimeMachine backup (yay, Apple!).

     

    It seems the file,

        ~/Library/Mail/V2/MailData/SyncedFilesInfo.plist

    maintains a list of sync'd files.


    My Steps:

    1) Quit Mail

    2) Deleted the final entry in the file

         ~/Library/Mail/V2/MailData/SyncedFilesInfo.plist

    which looks like this:

         <key> a bunch of stuff</key>

         <dict> a bunch of stuff </dict>


    3) Start mail app, and voila! the smart folders are there.


    Hope it works for you!

Previous 1 2 Next